9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)
  • Q:
    Bijdrager
    Rub3n

    xampp en mod_rewrite

    Hallo,

    Ik probeer mod_rewrite op mijn locale apache server voor elkaar te krijgen.

    Ik heb een apache lopen via XAMPP.

    Ik krijg alleen een 500 internal server error zodra ik wat in de .htaccess probeer te zetten.

    Bijdrager
    MegaChriz

    Hoi, ik heb dit met XAMPP uiteindelijk voor elkaar gekregen, maar het kan zijn dat ik niet meer exact alle stappen weet.

    In ieder geval moet je iets met het bestand httpd.conf doen, te vinden in de map ‘etc’. (/Applications/xampp/etc).
    Het kan zijn dat je de ‘#’ voor ‘LoadModule rewrite_module modules/mod_rewrite.so’ moet weghalen (als deze er staat).
    Dan moet je bij de directory “/Applications/xampp/xamppfiles/htdocs” ‘AllowOveride All’ instellen.
    [code:1:f75bcd2847]
    #
    # This should be changed to whatever you set DocumentRoot to.
    #
    <Directory "/Applications/xampp/xamppfiles/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* — "Options All"
    # doesn’t give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks ExecCGI Includes

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

    </Directory>
    [/code:1:f75bcd2847]
    Vervolgens moet je ervoor zorgen dat er geen fouten in je .htaccess-bestanden zitten. En in de .htaccess moet je de rewrite engine starten.
    [code:1:f75bcd2847]RewriteEngine On[/code:1:f75bcd2847]

    Hopelijk heb ik je goed op weg geholpen.

    Bijdrager
    Lifelogger

    Heb je je server wel zo ingesteld dat hij gebruik maakt van VirtualHosts? Heb je ook VirtualHosts aangemaakt op je server?

    Bijdrager
    Rub3n

    Lifelogger, ik heb geen idee waar je het over hebt. Dus die kans is klein haha.

    MegaChriz bedankt. Ik ga het eens proberen!

    Editje: de oplossing van MegaChriz heeft niet gewerkt:(

    Bijdrager
    Lifelogger
    ”Rub3n”

    Lifelogger, ik heb geen idee waar je het over hebt. Dus die kans is klein haha.

    MegaChriz bedankt. Ik ga het eens proberen!

    Op het forum van Map staat wel wat informatie:
    http://forum.webedition.de/phpBB/viewtopic.php?t=122

    Bijdrager
    Rub3n

    ik gebruik geen Mamp hé?

    Bijdrager
    Rub3n

    zo’n Virtual Host heb ik niet nodig volgens mij.

    Bijdrager
    Lifelogger

    Oh sorry. Vergis me.:-) Maar virtual hosts werkt ook op xampp. Draai hier ook xampp als dev server en heb ook virtual hosts (soort van subdomeinen) draaien.

    Op apachefriends.org is gewoon informatie hierover te vinden. Dan kun je met je .htaccess aan de slag.

    Bijdrager
    MegaChriz

    Ik geloof dat het voor een .htaccess-bestand ook uitmaakt welke regeleindetekens de tekstverwerker gebruikt. Dit regeleindeteken moet ingesteld zijn op Unix (LF of RI). Standaard op je Mac staat dit ingesteld op Macintosh (CR).
    Ik weet niet welke tekstverwerker je gebruikt?

9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.