16 berichten aan het bekijken - 1 tot 16 (van in totaal 16)
  • Q:
    Bijdrager
    JoopJoopJoop

    website zonder www. NIET, met www.wel

    Hi,

    De webstie via daanroukens.com (zonder www. dus) levert geen verbindig met deze site.
    Zonder www. levert in Firefox grote vertraging op en uiteindelijk een verminkte home page.

    onemorething.nl, zonder www wel verbinding

    Iemand hier een verklaring voor?

    Bedankt.

    Bijdrager
    NickR

    Check DNS voor “www” records. Die is namelijk niet aanwezig voor beschreven domain.

    Bijdrager
    KarelWillem

    Check DNS voor “www” records.

    Wait, what, where?? .:)

    Waar check je het DNS voor WWW records? En wat doe je daaraan als het niet goed is?

    Bijdrager
    pruus

    Check dit bij jouw provider. Het kan te maken hebben met basisinstellingen van de site. En dat is met bijv. .htcacces in te stellen in de root van de site. Dus eerst provider checken.

    Bijdrager
    JoopJoopJoop

    pruus,

    Wat zou er dan moeten staan hiervoor in htaccess?

    Heb je een voorbeeld een htaccessfile waarin dit goed staat?

    De provider host talloze sites (Neostrada) is het aannemelijk dat de fout daar ligt?

    VB Joep

    Moderator
    Mac Daddy

    Geen idee of er al iets openbaar staat, maar zowel met als zonder www blijft ie bij mij maar laden en zie ik niets. Ook geen foutmelding helaas.

    Bijdrager
    JoopJoopJoop

    @Mac Daddy,

    dit (https://www.daanroukens.com) werkt bij mij prima in Safari.

    zonder www. na grote vertraging een verminkte pagina..

    Bijdrager
    JoopJoopJoop

    @pruus,

    Zou dit een oplossing kunnen zijn…:

    Zonder www doorverwijzen naar met www :
    ————————————————————–
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^domeinnaam.nl [NC]
    RewriteRule ^(.*)$ http://www.domeinnaam.nl/$1 [L,R=301]
    ————————————————————–

    zou in een htaccess file moeten staan, moet die file in de public_html map staan? het is een wordpress site, heb het geprobeert in de root directory maar dat werkt niet…

    Bijdrager
    pruus

    Een paar links waar hetzelfde probleem aan de hand is, met oplossingen:
    .htacces: https://stackoverflow.com/questions/10135456/domain-doesnt-work-without-www
    .DNS: https://forums.zoho.com/topic/my-site-working-with-www-but-without-www-its-not-working
    Vergt wel even wat leestijd.

    Bijdrager
    pruus

    Voor WordPress heb ik het volgende gevonden:

    Redirect www to non www URL Using HTACCESS

    Inactief
    Anoniem

    De subpagina’s worden overigens wel omgeleid naar www, alleen de startpagina niet.

    Er gaat ook iets mis bij het laden van de stylesheets en javascripts op de startpagina (zonder www). Vandaar dat die verminkt is.

    Bijdrager
    JoopJoopJoop

    @jv65,

    bedankt, dit werpt een ander licht op het probleem…

    Mag ik vragen welke tools je hebt gebruikt om bovenstaande te zien te krijgen?

    Inactief
    Anoniem

    Gewoon met Safari: rechtsklikken op de startpagina > Toon paginabron en dan het tabje Netwerk en/of Bronbestanden.

    Duurt even voordat je die foutmeldingen te zien krijgt.

    Bijdrager
    JoopJoopJoop

    @jv65,

    bedankt,

    Heb de fouten ook gezien inmiddels, in rode tekst., omdat er een url zonder www is opgegeven, wordt er nu een url met www de tekst rood weergegeven?

    Mijn conslusie, ergens komt een fout pad vandaan naar de css en js bestanden

    Nu uit zien te vinden waar het fout gaat, waar zou die foute omleiding naar de startpagina terug te vinden zijn?

    Nu vraag ik misschien teveel, probeer het toch maar…

    Opnieuw bedankt.

    Inactief
    Anoniem

    wordt er nu een url met www de tekst rood weergegeven?

    Nope, mét www geen rode tekst of foutmeldingen.

    Het valt me wel op dat als ik in de broncode kijk van https://daanroukens.com, alle paden naar https://daanroukens.com verwijzen. Volgens mij zou dit https://www.daanroukens.com moeten zijn. Net als de pagina mét www. Verder zou ik het ook niet weten. Ik hou me hier al ruim 10 jaar niet meer mee bezig, dus voor hetzelfde geld is dat juist de bedoeling.

    Succes!

    Bijdrager
    mackerjack

    ik weet niet of iemand hier iets aan heeft maar ik kwam bij dit draadje uit toen ik zocht naar een oplossing voor het volgende:

    met muse heb ik een simpele website gemaakt die een oude, in iweb gemaakte, site verving. wanneer ik de domeinnaam intyp in safari zonder www ervoor (wat ik tegenwoordig eigenlijk altijd doe zonder problemen) wilde de site niet laten en kreeg ik de melding dat ‘domeinnaam.nl/Welkom.html’ niet gevonden kon worden. dat is op zich logisch want die was niet aanwezig. na ‘enig’ zoeken kwam ik erachter dat met www ervoor de site wel goed geladen werd. in mijn zoektocht naar de oorzaak kwam ik hier. de oplossingen hier gaan mij echter boven mijn pet maar ik heb het opgelost door de ‘index.html’ te kopiëren en de kopie ‘Welkom.html’ te noemen. nu werkt het prima, ook zonder www in te typen. er is dus nu zowel een index.html als de welkom.html aanwezig.

16 berichten aan het bekijken - 1 tot 16 (van in totaal 16)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.