7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)
  • Q:
    Bijdrager
    F e r o x

    Webserver Tiger wil niet starten

    Ik heb een raar probleem. Hij (Mac OS X 10.4.9) wil geen webserver doen starten. Wanneer ik klik bij Systeemvoorkeuren > Delen > Persoonlijke webserver en dan ‘Start’ blijft er gewoon ‘Persoonlijke webserver wordt gestart …’. Dus wanneer ik naar localhost of computernaam.local ga, toont hij dat de pagina niet kan weergegeven worden. Wat zou het probleem kunnen zijn?

    (door dit euvel kan een Version Cue server ook niet opgestart worden …)

    Bijdrager
    chrisis_nl

    Het je toevallig PHP5 geinstalleerd, dat het daarna fout ging?

    Bijdrager
    F e r o x

    Ik heb MAMP geïnstalleerd met php 5.

    Bijdrager
    kaydie

    Er zit waarschijnlijk iets fout in de config file. ( /etc/httpd/httpd.conf )

    Open de ‘Console’, in Programma’s/Hulpbestanden/, klik op Log’s en open /var/log/httpd/error_log om uit te vinden waar er fout gaat.

    Bijdrager
    F e r o x

    ===== Logbestand is leeg =====

    Dit is het enigste dat er staat bij errorlog …

    edit: in mijn ‘gewone’ console stond er dit:

    ** (process:1855): CRITICAL **: gaim_account_get_state: assertion `account != NULL’ failed
    2007-04-29 11:35:41.983 Console[1917] Can’t open input server /Library/InputManagers/Smart Crash Reports.bundle
    2007-04-29 11:37:28.678 System Preferences[1923] Can’t open input server /Library/InputManagers/Smart Crash Reports.bundle
    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/+entropy-php.conf
    Syntax error on line 8 of /private/etc/httpd/users/+entropy-php.conf:
    Cannot load /usr/local/php5/libphp5.so into server: (reason unknown)
    /usr/sbin/apachectl start: httpd could not be started
    2007-04-29 11:43:09.174 VLC[1988] Can’t open input server /Library/InputManagers/Smart Crash Reports.bundle

    Het lijkt toch iets met PHP5 te maken hebben, een bekend probleem?

    Bijdrager
    kaydie

    [code:1:6c10f57069]Syntax error on line 8 of /private/etc/httpd/users/+entropy-php.conf:

    Cannot load /usr/local/php5/libphp5.so into server: (reason unknown)

    /usr/sbin/apachectl start: httpd could not be started [/code:1:6c10f57069]

    Het lijkt er op dat je eerder de entropy distributie van php5 geinstalleerd hebt, en dat daarvan nog resten zitten in je apache configuratie waar hij zich nu in verslikt…

    open /etc/httpd/httpd.conf in de terminal of een geschikte texteditor
    (admin paswoord is nodig)

    maak een backup van het bestand, en zoek naar de volgende regels (waarschijnlijk helemaal onderaan:
    [code:1:6c10f57069]
    # begin entropy.ch PHP module activation
    Include /usr/local/php5/entropy-php.conf
    # end entropy.ch PHP module activation

    # begin entropy.ch PHP module activation
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps
    DirectoryIndex index.html index.php
    # end entropy.ch PHP module activation
    [/code:1:6c10f57069]

    comment nu al deze regels uit door er een #-je voor te plaatsen dus:[code:1:6c10f57069]
    # begin entropy.ch PHP module activation
    #Include /usr/local/php5/entropy-php.conf
    # end entropy.ch PHP module activation

    # begin entropy.ch PHP module activation
    #AddType application/x-httpd-php .php
    #AddType application/x-httpd-php-source .phps
    #DirectoryIndex index.html index.php
    # end entropy.ch PHP module activation[/code:1:6c10f57069]

    en probeer de webserver opnieuw op te starten in de terminal:[code:1:6c10f57069]sudo apachectl graceful[/code:1:6c10f57069]

    Bijdrager
    F e r o x

    Het zat zo te zien in +entropy-php.conf, maar het is gelukt. Bedankt !

    (nu nog version cue in gang krijgen, want zo te zien heeft het niet met elkaar te maken)

7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.