4 berichten aan het bekijken - 1 tot 4 (van in totaal 4)
  • Q:

    Bijdrager
    Ruben

    Volledig blanko pagina en toch de juiste source geladen?

    Ik heb op mijn site nu wat zitten klooien met Java en PHP zodat bezoekers c.q. andere “webmasters” geen losse pagina’s van mijn site meer kunnen laden buiten mijn eigen frameset. Als iemand dat toch doet opent alsnog mijn frameset met daarbinnen de oorspronkelijk opgevraagde pagina.

    Nu had ik echter in mijn index ook nog eens een scriptje gezet wat precies het omgekeerde deed, namelijk er voor zorgen dat mijn complete site ook niet binnen een andere frameset kon worden geladen.

    [code:1:979f7fdd67]
    <script type="text/javascript">
    <!–
    if(top!=self)
    top.location=self.location;
    //–>
    </script>
    [/code:1:979f7fdd67]

    Dit werkte goed binnen Safari, Internet Explorer op de Mac en Internet Explorer op Windows 2000 binnen mijn VPC test omgeving. Ook bij een vriendin thuis heb ik dit goed werkend gezien op een “echte” Wintendo. Vandaag was ik echter bij de Dierenbescherming in Spijkenisse en daar kon ik op geen van de computers mijn site tevoorschijn toveren. Overal kreeg ik een totaal blanko pagina. Als ik dan binnen Internet Explorer naar de source ging kijken zag ik WEL gewoon de volledige source van mijn frameset.

    Iemand enig idee wat er mis is met bovenstaande code en/of waarom deze dus blijkbaar op sommige configuraties een blanko pagina geeft?

    PS: Ik heb de code er nu tijdelijk weer uit gemikt, dus het heeft geen zin te kijken of ‘ie het bij jou wel of niet doet.

    [Edit]

    Nu weet ik dus niet meer door welke code het kwam. Kon ook door deze zijn geweest (staan er nu weer beiden in):

    [code:1:979f7fdd67]
    <!– PHPstat code –>
    <script language="JavaScript">
    var ref=""+escape(top.document.referrer); var colord = window.screen.colorDepth;
    var res = window.screen.width + "x" + window.screen.height;
    document.write("<img src=’http://www.iruben.com/statistics/stat.php?referer=" + ref + "&js=yes&color=" + colord + "&res=" + res + "’ border=0>");
    </script><noscript><img src="http://www.iruben.com/statistics/stat.php" border="0"></noscript>
    <!– PHPstat code –>
    [/code:1:979f7fdd67]

    Ziet iemand hier iets verkeerd aan?


    Bijdrager
    Henque
    ”iRuben”

    en daar kon ik op geen van de computers mijn site tevoorschijn toveren

    Als’ie het overal goed doet behalve op één bepaalde plek heb ik het vermoede dat op die pc’s javascript gedisebled is.
    Sommige mensen doen dat om van popupvensters en ongewenst openen van pagina’s af te zijn.
    Even checken door naar een andere site te gaan die ook javascript gebruiikt

    PS bestaat dit plaatje wel, vanwege de <img en dan moet een jpg, gif of iets dergelijks zijn en geen .php <img src=”https://www.onemorething.nl/wp-content/themes/onemorething/external-image.php?src=http://www.iruben.com/statistics/stat.&ext=php&h=1d91f4618ebe6ecd4cdf50a8cce60083&t=1571724697″ border=”0″>
    anders even dit invullen bij: <noscript>Kut… geen javascript</noscript>

    Of een andere tekst ipv: Kut… geen javascript


    Bijdrager
    meneer de koekepeer

    Ja, doe dan “Schede, geen Javascritp.”, dat is nog enigzins beschaafd.
    Javascript kan inderdaad disabled zijn, heel goed opgemerkt.
    Bij sites waar javascript een belangrijke rol speelt is het zo en zo altijd handig om zo’n check even uit te voeren:)


    Bijdrager
    Ruben

    Het probleem bleek ‘m in het tweede deel te zitten, die PHP statistieken teller. Nog geen idee waarom, maar hij is er nu uit en ik zie mijn site daar nu wel. Blijft heel eigenaardig…

4 berichten aan het bekijken - 1 tot 4 (van in totaal 4)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.