10 berichten aan het bekijken - 1 tot 10 (van in totaal 10)
  • Q:

    Bijdrager
    Dick de Roos

    Videofilmpje: Beeld loopt ver achter op het geluid

    Afgelopen week had ik een lezing, waarbij ik ook o.a. verschillende filmjes vanaf USB-sticks vertoonde op mijn oude MacBook 13″ uit eind 2007, waarop Mac OS 10.6.8 draait (hoger kan niet).

    De filmjes waren allen afkomstig van verschillende personen op even verschillende USB-sticks.

    Ik draaide de filmjes met QuickTime Player v. 10.0.

    Geen probleem, totdat ik een filmpje draaide van iemand die mij er op attent maakte dat beeld ver achter liep op het geluid. Omdat ik niet zo gauw wist hoe ik een filmpje vanaf een USB-stick synchroon kan laten lopen probeerde ik het eens met de VLC media player.

    Tot mijn verbazing liep het beeld en geluid nu wel synchroon.

    Achteraf kreeg ik vragen hierover. Ik mompelde wat over codexen, compressie en oude laptop, maar ik weet ook niet hoe dat nu kon.

    Nu bedenk ik dat ik naar de info van het videofilmpje had moeten kijken, maar dat heb ik niet gedaan.

    Toch wil ik weten hoe het komt dat het geluid soms wel en soms dus niet synchroon loopt met het beeld bij een videofilm van een USB-stick.

    Misschien weet iemand hier het antwoord te geven. Dan kan ik dat ook vertellen als ik die persoon weer tegen kom. Met bronvermelding uiteraard.   🤓


    Bijdrager
    Dick de Roos

    Update: ik heb een berichtje van de maker gehad. Erg veel wijzer werd ik er niet van, want hij heeft “niet veel verstand van techniek”.

    Wel weet ik nu dat het een mp4-bestand is en dat hij het filmpje op een Windows-computer heeft gemonteerd met Studio/Pinnacle.

    Hij had dat niet-synchroon lopen van beeld en geluid al eens eerder bij de hand gehad met een filmpje op zijn computer (Windows), zij het minder extreem. 🤔


    Bijdrager
    sedikit

    Bijdrager
    Dick de Roos

    Dank voor het antwoord @sedikit, maar het betrof hier een bestaand (gemonteerd) filmpje (.mp4) dat op een USB-stick was gezet.

    Omdat de aanwezige Windows-laptop problemen gaf, werd ik gevraagd om, naast mijn Keynote-verhaal, ook de filmpjes via mijn MacBook op de beamer te vertonen.

    Dat ging goed tot bij dit betreffende filmpje, waar het beeld achter het geluid liep.

    In QuickTime kan ik het geluidsspoor niet eenvoudig verschuiven (als dat al mogelijk is). Zeker niet, in het zaaltje de aanwezige belangstellenden via de beamer op mijn vingers zitten te turen.  😳


    Bijdrager
    sedikit

    “In QuickTime kan ik het geluidsspoor niet eenvoudig verschuiven (als dat al mogelijk is)”

    Ook niet met Quicktime 7? Die zit, in ieder geval bij mij op Mavericks en El Captan, standaard in Programma’s/Hulpprogramma’s.


    Bijdrager
    McPim

    Dick de Roos op 20 februari 2019 om 16:30
    .. en dat hij het filmpje op een Windows-computer heeft gemonteerd met Studio/Pinnacle. Hij had dat niet-synchroon lopen van beeld en geluid al eens eerder bij de hand gehad met een filmpje op zijn computer (Windows) ..

    Ehh, moeten we het hier nog heel lang over hebben op een Mac forum? Ik bedoel, het is een probleem dat op de Windows computer van de beste man ontstaat toch…


    Bijdrager
    Dick de Roos

    Ehhh… de vraag was dus hoe het kan dat een filmpje (.mp4) op mijn oude MacBook met VLC wel goed draait en dat bij hetzelfde filmpje op dezelfde MacBook met QuickTime het beeld en geluid niet synchroon loopt. Sterker nog: het beeld loopt bij QuickTime bijna 10 sec. achter bij het beeld.

    Dat het filmpje op een Windows PC is gefabriceerd is wat mij betreft secundair.


    Bijdrager
    Facundo

    Het is weldegelijk interessant om te horen waarom een asynchroon filmpje wèl standaard synchroon speelt op de ene player (VLC), maar niet op een andere. Het is niet zo dat VLC dit automatisch doet, maar gaat via de f en g toetsen. Je kunt wèl in de instellingen al een vaste correctie-waarde aangeven voor audio-sync, bijv. voor gebruik met airplay.


    Bijdrager
    McPim

    Dick de Roos op 20 februari 2019 om 09:49
    Nu bedenk ik dat ik naar de info van het videofilmpje had moeten kijken, maar dat heb ik niet gedaan.

     

    Als je het écht wil weten zal de zoektocht daar moeten beginnen. Welke codec gebruikt het betreffende filmpje, wat was de data rate? En daarna is je MacBook aan de beurt: gebruik je wellicht nog ‘Perian‘ of andere software/tools die met video te maken hebben? In de combinatie van deze zaken zal de oorzaak liggen. Of de bitrate van het filmpje was te hoog voor Quicktime en niet voor VLC gezien de leeftijd van de MacBook.


    Bijdrager
    Dick de Roos

    Klopt! Ik zal hem vragen mij de USB-stick met het filmpje te geven om e.e.a. te controleren. 🤓

10 berichten aan het bekijken - 1 tot 10 (van in totaal 10)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.