13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)
  • Q:
    Bijdrager
    12349843

    Totaal andere weergave document in MIE (opgelost!)

    beste medemaccers,

    ik zit met een probleem dat ik best jammer vindt. ik heb wat met html en css zitten klooien en toen had ‘k een menuutje in elkaar geflanst, (alles voorbekeken in safari) nu dacht ik (idd een beetje laat) laat ik het eens checken in MIE. En wat zie ik? een totaal andere weergave en dat vindt ik jammer.:|

    misschien weten jullie iets, je vindt het op http://www.xs4all.nl/~lampekap/others/css/rechts.html

    ik zou het echt top vinden als dit probleempie opgelost zou kunnen worden :D

    groet van de juliuz

    Bijdrager
    tijs

    Probeer je pagina’s volgens de standaard te maken, dan maak je waarschijnlijk de grootste kans dat je site door de meeste browsers goed wordt getoond. Je kan jouw pagina checken op http://validator.w3.org/

    Bijdrager
    boelie

    Ik had een soortgelijk probleem dat hier erg op leek!
    Ik heb m’n CSS een beetje aangepast, blijkbaar was het verwijderen van inset uit: [code:1:54819e4ae6]style=1px dashed #000000 inset;[/code:1:54819e4ae6] al genoeg!

    Anyway, ik heb het nog niet getest op alle browsers, maar volgens mij doet boelie.4mac.nl het goed!;)

    Bijdrager
    12349843

    Bedankt voor de hulp!
    Het is nog steeds niet goed maar wel iets beter, maar ik weet niet wat ik er nou fout aan is..:? Er zaten idd een paar dome fouten in de code zoals dat er gewoon ergens een tabel tussen stond die niet gebruikt werd. Maar het probleem moet wel in de css zitten en daar kan ik niet echt iets fouts in ontdekken :(

    PS. De stylesheet staat in dezelfde directory en is genaamd style.css 8)

    gr. van de juliuz

    Bijdrager
    12349843

    nu wordt het helemaal erg!!!
    alle paginas waarin naar het stylesheet wordt gelinkt zijn in MIE gewoon niet te bekijken. Er wordt gewoon gedaan alsof die link met dat stylesheet niet gemaakt is! :oops:
    zie voor een voorbeeld: http://www.xs4all.nl/~lampekap/boven.html
    in safari is die pagina zwart want dat staat in het stylesheet dat in die pagina wordt aangeroepen. In MIE is dat gewoon helemaal wit, er klopt dus gewoon niets van!
    [code:1:4734133f27]<link href="style.css" rel="stylesheet" type="text/css" />[/code:1:4734133f27]
    is de link naar dat stylesheet. En het stylesheet is op http://www.xs4all.nl/~lampekap/style.css te bekijken. Ik hoop echt dat iemand hier een oplossing voor weet anders kan ik helemaal opnieuw beginnen en kan ik het gebruik van css wel vergeten :oops:

    Bijdrager
    boelie

    Probeer eens[code:1:3f134a61fa]<link rel="stylesheet" href="style.css" type="text/css">[/code:1:3f134a61fa]

    Desnoods zou je een absolute link kunnen gebruiken[code:1:3f134a61fa]<link rel="stylesheet" href="http://jmvdt.diaryland.com/style.css" type="text/css">[/code:1:3f134a61fa]

    Op sommige momenten kan Explorer erg strikt met code omgaan. Op w3schools staat een hele duidelijke uitleg over CSS.

    Succes!

    Bijdrager
    12349843

    niet gelukt.. :|:|
    Maar wat ik nu denk is dat het niet aan de verwijzing naar het stylesheet lgit, maar aan de css zelf. Want sommige dingen worden namelijk wel meegnomen, bv op http://www.xs4all.nl/~lampekap/others/css/rechts.html want daar is het lettertype en de hover actie van de links toch niet standaard, en in het document zelf staat hier dus niets over. Kan het zijn dat achgergronden kleuren dit soort dingen niet worden ondersteund door MIE? Zou het wel raar vinden dus denk eigenlijk wel dat het iets anders is. In ieder geval vast heel erg bedankt voor de snelle reacties! Echt top!
    gr vn big L :wink:

    Bijdrager
    Thijs
    Bijdrager
    boelie

    Ik heb even naar je css-file gekeken, maar misschien is het slim om <!– en –> aan het begin en eind van je pagina te verwijderen? Misschien los je daar al een deel van je MIE-problemen mee op.

    Hieronder de code voor een tabel die ik heb gebruikt, waarschijnlijk kun je het verder uitwerken tot iets waar je wat aan hebt;)

    [code:1:1a5627d600]body {
    background-color: #FFFFFF;
    color: #333333;
    margin: 0px;
    font-family: arial, helvetica, sans-serif;
    font-size: 10px;
    text-align: center;
    }[/code:1:1a5627d600]

    Persoonlijk vind ik het prettig om een gestructureerde css-file te maken, op deze manier kun je het makkelijker lezen en fouten opsporen.

    Overigens staat op de link die Thijs had gegeven een aantal punten die je kunt gebruiken (op twee derde van de pagina). Ik denk wel dat je er iets aan hebt. :lol:

    Bijdrager
    12349843

    Het is opgelost, maar nog steeds vreemd. Alle paginas zouden als frames bij elkaar worden gevoegd. Die frameset pagina was er al. En toen ik die bekeek in IE was er helemaal niets te zien: die framepagina riep die paginas dus niet geod aan! Maar in safari was het wel goed! Ik heb de framepagina overnieuw gedaan, en niet alleen de problemen met de framepagina waren opgelost, maar ook elke pagina afzonderlijk was toen goed te bekijken onder zowel IE als safari. Vreemd, maar het is dus opgelost.:D
    In ieder geval: bedankt tijs, bedankt boelie!!!!!!!!!!!!!!:D
    GR from de Juliuz

    Bijdrager
    boelie

    Graag gedaan, daar is zo’n forum toch voor:wink:

    Bijdrager
    tennapel
    Bijdrager
    12349843

    Alles is op zn pootjes gekomen..!
    De site is te bezoeken op http://www.juliusite.tk
    nog niet alle paginas werken, omdat ik nog niet alles af heb maar hte grootste gedeelte staat online:D

    enne… ik mag dat w3c logo op mn site plaatsen! :D

13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.