6 berichten aan het bekijken - 1 tot 6 (van in totaal 6)
  • Q:
    Bijdrager
    apple freak

    Tiger Server mod_rewrite werkt niet.

    Ik heb op een mac mini met tiger server (10.4.7) een aantal services draaien. Een daarvan is apache met de mod_rewrite module geenabled. Nou heb ik hier een probleem mee.

    Op een of andere vreemde manier werkt het niet. Terwijl de module aanstaat en ik hem ook terug kan zien in phpinfo.

    ”loaded

    Loaded Modules mod_WebObjects, mod_spnego_apple, mod_jk, mod_ssl, mod_digest_apple, mod_hfs_apple, mod_php4, mod_perl, mod_macbinary_apple, mod_setenvif, mod_so, mod_expires, mod_proxy, mod_auth_apple, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_log_config, http_core

    Heeft iemand enig idee wat hier mis zou kunnen zijn of mij in de juiste richting op helpt??

    Het herstarten van apache dan wel de heleserver helpt niet.

    Bijdrager
    tulipan

    Als je de mod_rewrite kan zien met PHP dan zou ik eerder kijken naar wat je in je httpd.conf hebt gezet. Misschien dat je RewriteCond niet helemaal correct is?

    Bijdrager
    apple freak

    Ik heb de httpd.conf niet handmatig aangepast, maar dit staat erin.

    [code:1:9ada0b01e7]LoadModule rewrite_module libexec/httpd/mod_rewrite.so
    ——-
    AddModule mod_rewrite.c
    ——-
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} ^TRACE
    RewriteRule .* – [F]
    </IfModule>[/code:1:9ada0b01e7]

    Die streepjes staan voor; er zit nog wat tussen

    En in de virtual host conf file staat dit ook nog;
    [code:1:9ada0b01e7]<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} ^TRACE
    RewriteRule .* – [F][/code:1:9ada0b01e7]

    Bijdrager
    GeertDD

    Ik zit met exact hetzelfde frustrerende probleem…

    Bijdrager
    GeertDD

    JAA! Het werkt ein-de-lijk! :D

    Okay, het begin van de oplossing vond ik via google: http://www.webmasterworld.com/forum92/5360.htm (begin van tweede post).

    Ga naar /private/etc/httpd/users/jouw-username.conf en bewerk dat bestand:
    1. Voeg FollowSymLinks toe bij de Options
    2. Zet AllowOverride op All

    Daarna Apache opnieuw opstarten. Tot slot voeg je deze regel toe onder RewriteEngine On in je .htaccess:
    RewriteBase /~jouw-username/eventueel-map-van-site/

    Toen deed ie het prima bij mij. Bij jou ook?

    Bijdrager
    apple freak

    Ik heb het ook werkend. Kwam er vanochtend ook achter hoe ik het moest doen, maar had nog geen tijd gehad om het hier neer te zetten.

    Heb het wel iets anders gedaan. Ik heb de httpd.conf aangepast. En de virtual host .conf file.

    Dit in httpd.conf;
    [code:1:653f7621aa]<Directory "/">
    Options FollowSymLinks
    AllowOverride All AuthConfig
    </Directory>[/code:1:653f7621aa]

    En dit in de sites-folder in /etc/httpd/. En dan de file om welke site het gaat, daar heb ik dit gedaan;
    [code:1:653f7621aa]<Directory "/Library/WebServer/Documents/familiecompanjen.nl/httpdocs">
    Options All -Indexes +ExecCGI +Includes +MultiViews
    <IfModule mod_dav.c>
    DAV On
    </IfModule>
    AllowOverride All AuthConfig
    </Directory>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} ^TRACE
    RewriteRule .* – [F]
    </IfModule>[/code:1:653f7621aa]
    Maar of dat er iets mee te maken heeft betwijfel ik, want het staat namelijk bij de mod_dav module. En ik heb niet echt zin om het te proberen. Later in de week misschien.

6 berichten aan het bekijken - 1 tot 6 (van in totaal 6)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.