30 berichten aan het bekijken - 1 tot 30 (van in totaal 40)
  • Q:

    Bijdrager
    marcoenhop

    terminal doet vreemd

    Als ik Terminal open krijg ik een vreemd melding. Mijn mac geeft twee foutbliepjes en in terminal verschijnt onder andere de volgende regel.

    mms(14779,0x104f4b5c0) malloc: *** error for object 0x7ffeecd350c0: pointer bei
    ng realloc’d was not allocated

    De foutbliepjes komen om de minuut terug. Iemand een idee?


    Bijdrager
    hendrik ijzerbroot

    Dit kan een probleem zijn met de bevoegdheden. Als je werkt met OS-X 10.10 of eerder dan kun je deze herstellen m.b.v. het programma “schijfhulpprogramma”. In OS-X 10.11 of later zouden de bevoegdheden automatisch goed moeten zijn omdat dit geregeld op de achtergrond plaatsvindt.

     

    Werk je met OS-X 10.11 of later en je wilt ook al doet het OS dit zelf al toch de bevoegdheden herstellen dan heb je de Terminal nodig. Hoe dat werkt lees je hier.


    Bijdrager
    marcoenhop

    Dankvoor je snelle reactie Hendrik. Dit werkt helaas niet. Ik werk met 10.14. Terminal pikt die ‘bevoegdhedencommando’s’ niet en blijft (ook na schijfEHBO) de melding geven. Iemand een ander idee?


    Bijdrager
    Jakko Westerbeke

    Doet hij dit ook onder een andere gebruikersaccount?


    Bijdrager
    Buzz

    Dat heeft volgens mij niks met bevoegdheden te maken. Het is een fout in een programma dat blijkbaar automatisch opstart als je je Terminal gebruikt. Je zou eens in je ~/.profile, ~/.bash_profile en dergelijke bestanden moeten kijken, of daar iets met “mms” in staat. Zou mms iets met MongoDB te maken kunnen hebben, of zegt je dat niets?


    Bijdrager
    Shmoo

    Automatische (terugkerende) piepjes van het systeem staan volgens mij universeel voor fouten met het geheugen.

     

    https://developer.apple.com/library/archive/documentation/System/Conceptual/ManPages_iPhoneOS/man3/realloc.3.html

    https://developer.apple.com/library/archive/documentation/Performance/Conceptual/ManagingMemory/Articles/MemoryAlloc.html

     

    Ik denk dat je een probleem hebt met geheugenmanagement. Of dit nu komt door een app die automatisch opstart zoals @buzz aangeeft weet ik niet.

     

    Dit is iemand met precies hetzelfde.

    https://discussions.apple.com/thread/8578140

     


    Bijdrager
    marcoenhop

    Ik heb even geprobeerd met een andere account (zelfs speciaal een hele kale account aangemaakt) en daar gebeurt precies hetzelfde. Terminal openen is meteen hommeles. Er komt overigens meer in beeld dan alleen wat ik liet zien. Het totale beeld is

    Broadcast Message from root@MacBook-Pro-van-Marcoen-2.local
    (no tty) at 11:59 CEST…

    mms(76426,0x10b7325c0) malloc: *** error for object 0x7ffee775a1c0: pointer bei
    ng realloc’d was not allocated

     

    Vreemde zaak dit


    Bijdrager
    fred44nl

    klopt het dat je als root bezig bent en niet als “gewone” gebruiker ??


    Bijdrager
    marcoenhop

    Euh… niet bewust. Hoe zie ik dat?

     


    Bijdrager
    marcoenhop

    Ik heb even gekeken en volgens mij ben ik niet als rootgebruiker ingelogd, wel als beheerder.


    Bijdrager
    fred44nl


    Bijdrager
    marcoenhop

    Ik zag het ja. Maar ik ben even via de systeemvoorkeuren gaan kijken en ik ben dus niet als rootgebruiker ingelogd

    .


    Bijdrager
    hendrik ijzerbroot

    <p class=”cite”>Buzz op 23 oktober 2018 om 11:10</p>
    Dat heeft volgens mij niks met bevoegdheden te maken.

    De foutmelding was mij onbekend. Toen ik er op ging zoeken kwam ik verscheidene resultaten tegen waar de bevoegdheden werden genoemd. En in een enkel geval hielp dat bij iemand. Dus het was het proberen waard, maar ik denk dat onder 10.14 de zaken weer anders liggen.

    Hier nog een alternatief Terminal commando:

    diskutil resetUserPermissions / id -u (letterlijk zo intypen en mogelijk moet je er sudo voor zetten)

    Vreemd. Na plaatsen van deze reactie klopt het commando niet meer. direct voor “id” moet een ` staan en ook direct na de “u”.

    Krijg je vervolgens foutcode: -69841, typ dan in: chflags -R nouchg ~ en herhaal het commando.

    Had je er trouwens ook al last van vóór 10.14? Zo niet dan kan het natuurlijk een bug zijn in Terminal of Mojave.


    Bijdrager
    Buzz

    Mijn eerste stappen zouden zijn om te kijken of, en zo ja wat, dat “mms” proces inhoudt. Ik denk niet dat het iets in het systeem is, maar dat je het apart hebt geïnstalleerd.

    Het enige dat ik in die richting kon vinden is dat het iets met MongoDB database software te maken zou kunnen hebben (mms staat dan voor Mongo Monitoring Service). MongoDB wordt veel gebruikt in web development, met bijv. ruby on rails of python. Laat nog maar even weten of dit je iets zegt of niet.

    Zo’n proces moet dan ergens automatisch worden opgestart. Je zou daarom ook zelf in Activity Monitor, en in de eerder genoemde ~/.bash_profile etc. bestanden kunnen zoeken naar “mms” of iets anders waarvan je de herkomst niet herkent. En ook in de Terminal Preferences, onder Shell, en in de System Preferences, Users & Groups, onder Login Items, kunnen processen staan die niet bij Mac os horen, maar wel geconfigureerd zijn om automatisch op te starten.


    Bijdrager
    marcoenhop

    Dankje Buzz, daar ga ik eens naar kijken. Het zegt me allemaal heel weinig. Ik doe op mijn mac weinig bijzonders. Geen games, geen ingewikkelde programma’s en weinig externe software. Ik gebruik terminal bijna nooit dus ik heb er ook geen last van en ik zou ook de eerstvolgende update kunnen afwachten, wie weet is het dan verdwenen.


    Bijdrager
    koen

    1. In die link van @shmoo hierboven staat een mogelijke oplossing, heb je dat al geprobeerd?

    2. Post eens de log van Etrecheck hier. En wat staat er in ~/.profile en ~/.bash_profile (ook al eerder gevraagd)?

    3. Heb je verder geen problemen?

     


    Bijdrager
    fred44nl

    <p class=”cite”>koen op 23 oktober 2018 om 15:29</p>
    En wat staat er in ~/.profile en ~/.bash_profile (ook al eerder gevraagd)?

    in Mojave komen die niet (meer) voor.


    Bijdrager
    koen

    Waar pas je dan je PATH, etc aan?


    Bijdrager
    Shmoo

    Dat laat je tegenwoordig doen, door de tuinman. 🤠

     


    Bijdrager
    fred44nl

    <p class=”cite”>koen op 23 oktober 2018 om 16:49</p>
    Waar pas je dan je PATH, etc aan?

    sudo nano /etc/paths

     


    Bijdrager
    koen

    En aliassen?


    Bijdrager
    fred44nl

    <p class=”cite”>koen op 23 oktober 2018 om 17:20</p>
    En aliassen?

    daar is op internet niet veel over te vinden, maar wellicht heb je hier wat aan:

    The $HOME/.profile does not exist until you create it in an editor. Same for the other hidden, dot (.bashrc, .bash_profile, .bash_login, .bash_logout) files.


    Bijdrager
    Jakko Westerbeke

    <p class=”cite”>hendrik ijzerbroot op 23 oktober 2018 om 12:45</p>
    Vreemd. Na plaatsen van deze reactie klopt het commando niet meer. direct voor “id” moet een ` staan en ook direct na de “u”.

    Dat is omdat je onbedoeld Markdown gebruikt hebt: daarin betekent dat symbool dat alles ertussen code/toetsaanslagen/programma-uitvoer/e.d. is.


    Bijdrager
    hendrik ijzerbroot

    Eigenlijk was ik voor zover ik mij kan herinneren nog nooit een Terminal commando tegengekomen met het ` teken er in dus zag ik dit voor de eerste keer. Dat teken had er volgens mij dus niet bij mogen staan.


    Bijdrager
    koen

    <p class=”cite”>fred44nl op 23 oktober 2018 om 17:30</p>

    <p class=”cite”>koen op 23 oktober 2018 om 17:20</p>
    En aliassen?

    daar is op internet niet veel over te vinden, maar wellicht heb je hier wat aan:

    The $HOME/.profile does not exist until you create it in an editor. Same for the other hidden, dot (.bashrc, .bash_profile, .bash_login, .bash_logout) files.

    Dat is dacht ik altijd al zo geweest (dat je die zelf moet aanmaken)?


    Bijdrager
    Buzz

    Die bash opstartscripts kunnen ook aangemaakt of aangepast worden door software die je via de terminal installeert, bijv via instructies van een website. Altijd verstandig om te controleren bij vreemd terminal gedrag dus.

    Het is ook verstandig om geen terminal commando’s te gebruiken, waarvan je de herkomst niet weet en die je niet begrijpt. Zoek maar eens op “bash backtick operator”, hendrik ijzerbroot.


    Bijdrager
    marcoenhop

    Beste macvrienden. Ik ben inmiddels afgehaakt omdat de discussie me echt boven de pet gaat. Ik zou het graag opgelost zien, maar waar jullie het allemaal over hebben, kan ik niet volgen. Ik waardeer jullie inspanningen wel en als ik binnenkort even tijd heb, duik ik er wat dieper in.


    Bijdrager
    JJmac

    Plaats nou gewoon een Etrecheck, die laat heel veel zien.

    https://www.etrecheck.com/

     


    Bijdrager
    Shmoo

    Voer gewoon een Clean Install uit, dan ben je sneller klaar. 😽

     

    Dat deed de persoon in mijn topic 👆 (Apple.com / supportforum ) namelijk ook omdat hij er niet uitkwam.


    Bijdrager
    hendrik ijzerbroot

    Echt? De TS heeft al gezegd dat hij Terminal bijna nooit gebruikt.

30 berichten aan het bekijken - 1 tot 30 (van in totaal 40)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.