9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)
  • Q:
    Inactief
    Anoniem

    site’je op lokaal netwerk zetten hoe??

    hoi!

    ik heb een klein site’je gamaakt met iweb en ik zou die graag op ons netwerk willen plaatsen maar hoe doe je dit???,

    ik heb het al eerder gedaan maar nu weet ik niet precies wat ik toen had gedaan?!?:cry: :cry:
    (niet echt snugger)

    mvg ,

    axel van raath

    Sleutelbeheerder
    Night

    Je kunt in iWeb kiezen om de site in een folder te bewaren. Selecteer hiervoor een folder op je netwerkschijf en andere mensen zullen in die map ook de index.html kunnen aanklikken en bekijken.

    Bijdrager
    foobar

    Systeemvoorkeuren –> delen –> webserver aanzetten
    dan heb je een mapje in je home-folder met de naam Webpagina’s, daarin dump je dan je website (en dus je index.html)

    vervolgens kunnen de mensen in je netwerk in safari typen: http://ipadresvanjoumac/~Naamvanjouaccount/
    of http://naamvanjemac.local/~Naamvanjeaccount/

    Bijdrager
    ajvankesteren

    Of de bestanden plaatsen in “OSX HD/Library/WebServer/Documents”
    De site is dan oproepbaar via http://computernaam.lan/

    Inactief
    Anoniem

    hee bedankt hij doet het ik kreeg namelijk alleen dat rare apache gebeure!!!

    thanks!!!!!

    Bijdrager
    Jimmie

    Of MAMP installeren en vervolgens in de htdocs slepen en dan bezoeken op:

    localhost:8888

    Dit werkt bijna altijd goed, zeker als je ook dingen met php wilt draaien enz.

    Bijdrager
    WouterReyntjens

    Je kan de poort van mamp ook veranderen van 8888 naar 80 zodat je automatisch op de webpagina komt!

    Bijdrager
    Macs

    Met MAMP lukt het perfect! Met de ingebouwde Mac OS X functie lukt het niet met php en MySQL.

    Bijdrager
    ajvankesteren

    Met zowel de standaard Apache als MAMP lukt het me niet om van buiten mijn eigen netwerk verbinding te krijgen met de Mac mini die als server dienst doet…
    Wat ik ook probeer, ik krijg steeds ofwel een time-out, ofwel het inlogscherm van m’n modem/router te zien.
    Ik heb op m’n router poorten 80 en 8888 geforward naar m’n mini. Poort 80 in eerste instantie voor de standaard Apache, en later ook voor MAMP (met de standaard Apache uitgeschakeld, en MAMP -uiteraard- geconfigureerd op poort 80), en 8888 voor MAMP (ook met standaard Apache inactief, en MAMP op de standaard poort 8888). Alles gedaan volgens de handleiding en gedubbelchecked bij portforward.com, dus zelfs poort 443 en 80 samen open gezet. Niets werkt…

    MAMP zelf draait op zich goed, de servers starten en ik kan de startpagina zien, maar van buitenaf dus nada, noppes, zilch, nichts :x :x :x :x

    Wanneer ik binnen het netwerk de bewuste pagina’s lokaal oproep (met lokaal IP adres van mini) is er geen probleem, zodra ik het via mijn static IP adres van Planet Internet probeer (met of zonder :8888 erachter) gaat het fout… Er lijkt dus iets mis te gaan bij het forwarden, maar wat? Help? Iemand?
    FYI: modem/router is een SpeedTouch 716g v5

9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.