10 berichten aan het bekijken - 1 tot 10 (van in totaal 10)
  • Q:
    Bijdrager
    Manumanic

    Servers achter een Nat

    Wie oh wie kan mij helpen.

    Ik ben nu eindelijk klaar met mijn netwerkje thuis. Een getweakte Alcatel modem (dus router) een airport base met een G4 aangesloten via de ethernet en een ibook via airport. Ik draai(de) een ftp en een carracho server op de g4 (voor de tweak en de airport) nu heb ik al geprobeerd de poorten toe te wijzen met de (op bruring site genoemde) comando’s: deffserver etc etc etc. Maar wanneer ik via dat commando al het binnenkomende verkeer lijk toe te wijzen aan de G4 (met ip 10.0.1.2) lijkt er niet veel te gebeuren, en kan men zowel ftp als carracho server nog steeds niet op. Maak ik contact met de servers door het adres 10.0.1.2 te gebruiken, dan maak ik zelf wel gewoon contact….maar ja daar heeft de buitenwereld niet zo veel aan.

    wie kan mij op weg helpen dit op te lossen.

    please

    Bijdrager
    addyboy

    Hmm.. ik heb geen antwoord voor jou, maar ik heb wel een vraagje.. Kan jij toevallig ook niet met MSN File Transfer werkend krijgen (bestanden kunnen wel naar jou, maar niet van jou verstuurd worden). Ik vermoed namelijk dat het aan mij opstelling ligt dus deze ga ik wellicht veranderen.

    Bijdrager
    reneo

    ik ben ook aardig bezig met een thuisnetwerkje en hoewel ik niet van alles van ik doe iets snap, lijkt het redelijk te lukken. Ik kan je wel vertellen dat als je vanuit je interne thuisnetwerk je eigen servers (ftp etc) probeert op te komen via het externe ip adres, dat dat nooit gaat lukken, hoe dat precies zo komt weet ik effe niet meer, maar 3 maanden geleden stond daar een erg helder stuk over in de macfan… ik heb ook een ftpserver draaien (gewoon die osx zelf) en die kan ik inderdaad niet intern met het externe ipadres oproepen, wel van buitenaf dus…

    bij-de-weg: welke software gebruik jij voor als ftpserver? ik vind die in osx zit ingebouwd nogal sumier, je ziet nooit wie er ingelogd is en wat ze neerzetten of weghalen, er staat wel ergens een logbestand, maar daar wordt je niet veel wijzer van…

    Bijdrager
    black_eye

    Wat heb je precies ingevoerd bij je NAT regels.
    Om vanaf buiten via VNC mn PB over te nemen hoefde ik alleen maar mn publieke poort naar mn interne poort open te zetten via mn interne IP nummer. Werkt perfect.

    Voor FTP heb ik poort 21 open gezet op interne poort 21 naar mijn IP.

    Bijdrager
    cajun

    Je kan het instellen door in je terminal in te tikken:
    telnet 10.0.0.138 (of het inside IP wat je alcatel heeft, 10.0.0.138 is standaard KPN configuratie….)
    bij “user” gewoon op “ENTER” clicken
    dan tik je “NAT” in en “ENTER”
    vervolgens: nat create protocol=tcp inside_addr=10.0.1.2:21 outside_addr=0.0.0.0:21
    hierna kan je met “list” zien of je rule erbij is gekomen.
    vergeet dan niet om “save” in te tikken (anders ben je na een modem reset al je instellingen kwijt)

    hier onder een voorbeeldje

    Cajun-2xG5:~ cajun$ telnet 10.0.0.138
    Trying 10.0.0.138…
    Connected to 10.0.0.138.
    Escape character is ‘^]’.
    User :

    =>nat

    [nat]=>help create
    create : Create/define static NAT/PAT entry

    protocol=IP protocol name or number>
    inside_addr=<ipaddress>
    [inside_port=TCP/UDP service name or port number>]
    outside_addr=<ipaddress>
    [outside_port=TCP/UDP service name or port number>]

    [nat]=>nat create protocol=tcp inside_addr=10.0.0.151:21 outside_addr=0.0.0.0:21
    [nat]=>list
    Indx Prot Inside-address:Port Outside-address:Port Foreign-address:Port Flgs Expir State Control
    [MET OPZET WAT REGELS WEGGEHAALD]
    10 6 10.0.0.154:80 0.0.0.0:80 0.0.0.0:0 template
    11 6 10.0.0.153:261 0.0.0.0:261 0.0.0.0:0 template
    12 6 10.0.0.151:22 0.0.0.0:22 0.0.0.0:0 template
    13 6 10.0.0.151:21 0.0.0.0:21 0.0.0.0:0 template
    [nat]=>

    Ik hoop dat dit je probleem oplost.

    Bijdrager
    gretver

    als ik het goed begrijp heb je een getweakte alcatel en een airport na elkaar, dan heb je feitelijk twee routers achter elkaar hangen. DAn heb je in principe twee keer te maken met NAT instellingen. Ik zou in ieder geval een router gebruiken. De alcatel als bridge, of de airport als acces-point.

    Bijdrager
    Sad

    Twee routers achter elkaar is niet nodig.
    zet de Alcatel als BRIDGE in. Dit kan ook gewoon via het web-interface van je modem http://10.0.0.138 (als je dat IP adres niet veranderd hebt).

    Vervolgens lekker op je AirPort alle poorten openzetten.

    Bijdrager
    Manumanic

    alvast heel erg bedankt allemaal.

    – ik gebruik Crush FTP server erg lekker en doet het heel goed onder winhoos compu’s

    ik heb in mijn modem menu inderdaad de optie bridging gevonden. deze stond uit en heb ik nu op ‘forewarding’ geplaatst.

    nu alle poorten op de airport ‘lekker openzetten’ call me stupid……..maar bedoel je dat ik all poorten moet routen naar de betreffende computer met de server????

    greetz

    Bijdrager
    Manumanic

    okay alle manueel ingevoerde ip koppelingen verwijderd uit de modem…deze geeft nu de volgende list:

    1 6 10.0.0.1:7363 194.109.243.100:10574 62.69.168.11:80 1 8 5
    2 6 10.0.0.1:7364 194.109.243.100:10575 62.69.168.11:80 1 8 5
    3 17 10.0.0.1:7376 194.109.243.100:10587 194.109.6.66:53 1 20 10
    4 6 10.0.0.1:7368 194.109.243.100:10579 212.187.170.12:80 1 8 5
    5 6 10.0.0.1:7365 194.109.243.100:10576 62.69.168.11:80 1 8 5
    6 6 10.0.0.1:7366 194.109.243.100:10577 62.69.168.11:80 1 8 5
    7 6 10.0.0.1:7371 194.109.243.100:10582 62.26.220.5:80 1 8 5
    8 6 10.0.0.1:7372 194.109.243.100:10583 62.26.220.5:80 1 8 5
    9 6 10.0.0.1:7369 194.109.243.100:10580 62.26.220.5:80 1 8 5
    10 6 10.0.0.1:7370 194.109.243.100:10581 62.26.220.5:80 1 8 5
    11 6 10.0.0.1:7375 194.109.243.100:10586 62.26.220.5:80 1 8 5
    12 6 10.0.0.1:7373 194.109.243.100:10584 212.187.170.12:80 1 8 5
    13 6 10.0.0.1:7374 194.109.243.100:10585 62.26.220.5:80 1 8 5
    14 17 10.0.0.1:7241 194.109.243.100:10452 194.109.6.66:53 1 20 10
    15 17 10.0.0.1:7243 194.109.243.100:10454 194.109.6.66:53 1 20 10
    16 6 10.0.0.1:7239 194.109.243.100:10450 62.69.168.11:80 1 8 5
    17 17 10.0.0.1:7226 194.109.243.100:10437 66.79.180.30:6702 1 20 10
    18 17 10.0.0.1:7225 194.109.243.100:10436 131.174.203.59:6702 1 20 10
    19 6 10.0.0.1:7237 194.109.243.100:10448 62.69.168.11:80 1 8 5
    20 17 10.0.0.1:7228 194.109.243.100:10439 194.109.6.66:53 1 20 10
    21 6 10.0.0.1:7238 194.109.243.100:10449 62.69.168.11:80 1 8 5
    22 17 10.0.0.1:7227 194.109.243.100:10438 81.208.84.206:6702 1 20 10
    23 6 10.0.0.1:7244 194.109.243.100:10455 212.187.170.12:80 1 8 5
    24 6 10.0.0.1:7242 194.109.243.100:10453 62.69.162.200:80 1 8 5
    25 6 10.0.0.1:7247 194.109.243.100:10458 212.187.170.12:80 1 8 5
    26 17 10.0.0.1:7234 194.109.243.100:10445 83.114.113.25:6702 1 20 10
    27 17 10.0.0.1:7233 194.109.243.100:10444 194.109.6.66:53 1 20 10
    28 17 10.0.0.1:7236 194.109.243.100:10447 194.109.6.66:53 1 20 10
    29 6 10.0.0.1:7246 194.109.243.100:10457 212.187.170.12:80 1 8 5
    30 17 10.0.0.1:7235 194.109.243.100:10446 68.6.228.7:6702 1 20 10
    31 17 10.0.0.1:7230 194.109.243.100:10441 194.109.6.66:53 1 20 10
    32 17 10.0.0.1:7229 194.109.243.100:10440 68.166.67.62:6702 1 20 10
    33 17 10.0.0.1:7232 194.109.243.100:10443 218.110.14.43:6702 1 20 10
    34 17 10.0.0.1:7231 194.109.243.100:10442 194.109.9.99:53 1 20 10

    – alles lijkt te zijn gerout naar mijn publieke wan adres
    – ik heb de modem gebridged (bridge option: foreward)
    -……………en in de aiport config lijkt alles te staan gerout naar de G4 met intern ip 10.0.1.2 (publieke poort:21 – privaat ip adres: 10.0.1.2 – private poort:21 etc etc etc.

    wat oh wat doe ik toch verkeerd !!!!!!!

    Bijdrager
    Sad

    Die hele lijst kan weg.

    Als je een ftp server hebt dan routeer je poort 21 van buiten naar het ip adres van je ftp server. Dat is dus 1 regel.

    Als je een web server hebt routeer je poort 80 van buiten naar het ip adres van je webservers. Dat is nog 1 regel.

    Dan heb je nog een carracho server die heeft geloof ik een paar poorten nodig (lees de site van carracho) dus dat is nog eens 3 regels.

    Ga niet via de terminal klooien. Je kan gewoon via je browser die poorten doorzetten.

10 berichten aan het bekijken - 1 tot 10 (van in totaal 10)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.