17 berichten aan het bekijken - 1 tot 17 (van in totaal 17)
  • Q:
    Bijdrager
    DannyR

    Router gooit mac er af, pc’s werken wel goed

    Hallo,

    Ik heb al een tijd je het probleem dat mijn router me mac er af gooit (krijg geen verbinding met inet meer). Het rare is dat dit heel wisselvallig gebeurt, soms gaat het een week goed, en zoals nu wordt ik er om de 5 min afgegooit. Ik heb verder ook 2 pc’s op de router aan geslotent, maar die hebben er geen last van.
    Ik heb al gezocht op het forum en heb een hoop geprobeert maar ik kom er niet uit.

    Ik heb de router ingestelt als DHCP server en “MAC-address” gecloned. Mijn mac heb ik gezet op “Via DHCP”.

    situatie:
    @home < Router (Lynksys) < MAC/ PC1/ PC2

    Hier mijn instellingen van de router

    Kan iemand me aub helpen?

    Bijdrager
    www.project-euh.com

    Wat voor IP-adres krijgt je mac als ie het wel doet? En wat geeft ie aan bij netwerk als hij het niet doet?

    Niet per ongeluk ergens op je netwerk een 2e DHCP server draaien?

    Bijdrager
    DannyR

    Aldoor 192.168.1.100

    Als ik mijn mac rechtstreeks aansluit op het modem, dan is volgens mij het ip eerst 168.*.*.* (geen verbinding) als ik dan weer mijn ip vernieuw dan krijg ik de ip address dat @home me geeft (weet niet of dat iets er mee te maken kan hebben?)

    Bijdrager
    www.project-euh.com

    En welke IP-nummers krijgen die PC’s dan..

    Als je hetm rechtstreeks aansluit klopt het dat je het IP-nummer van @Home krijgt, daar ligt het probleem niet. Met de router ertussen gaat dat @Home nummer naar de router en die geeft alle locale computers een eigen nummer.

    Bijdrager
    DannyR
    ”www.project-euh.com”

    En welke IP-nummers krijgen die PC’s dan..

    PC1 = 192.168.1.101
    PC2 = 192.168.1.102

    Hangt dit er van af welke ik als eerste aan doe?

    Bijdrager
    spacemonkey

    Draai jij dan een Domain Name Server op je Mac (lijkt me sterk aangezien je hem dan niet op statisch zet)? Ik zie namelijk bij je instellingen van je router dat je eerste statische DNS adres 192.168.1.100 is. D.w.z. dat elke computer op jouw netwerk voor adres naam gegevens eerst het betreffende adres probeert te bereiken (192.168.1.100) en daar naam gegevens probeert weg te halen… vervolgens pas naar de root-servers.

    Ik weet niet of je het bovenstaande verhaal snapt maar wat ik wil zeggen is dat het veld ‘static DNS 1:’ op ‘0 0 0 0’ moet staan. Aangezien ik in de veronderstelling ben dat jij geen DNS draait op je lokale netwerk.

    Toelichting:
    Bij elke web adres dat wordt ingetoetst in een browser (bijv. http://www.macosx.nl) verwijst jouw router voor een name-resolve naar adres 192.168.1.100, jouw Macintosh dus. Maar daar draait (waarschijnlijk) helemaal geen DNS op. Gevolg is dat jouw internet er uit klapt(?).

    Ik hoop dat je het bovenstaande verhaal snapt… laat het ff weten als dat niet het geval is…
    Of zit ik nu helemaal verkeerd???

    succes

    Bijdrager
    DannyR

    Hmm..

    Dit had ik in het begin ook zo staan, maar toen viel me verbinding er ook af en toe uit.
    Op deze manier trouwens heb ik wel een hele week lang gewoon verbinding gehad.
    ( dacht dat ik zo mijn mac via de router een static ip gaf, maar niet dus!)

    Ik snap er ook niks meer van :(

    Trouwens alleen mijn MAC heeft geen verbinding meer, de 2 pc’s wel.

    Bijdrager
    spacemonkey

    Okay dan even wat extra info:
    Voor elk web-adres (www.foo.nl) dat wordt aangevraagd vanaf jouw lokale-netwerk (dus of dat nou Mac’s of PC zijn) wordt een name-resolve gedaan. Dit houdt in dat de computer in kwestie die een web-adres (www.foo.nl) opvraagt, aan een DNS vraagt welk IP-adres bij een bepaalde web-adres hoord.

    Hoe werkt dat?:
    Als je http://www.macosx.nl in jouw browser (safari) in typt moet die naam (www.macosx.nl) worden vertaald naar een IP-adres. Een computer kan immers niks met namen en werk alleen op IP-adressen. Ergens op internet staan DNS-servers waarin ‘tabellen’ zijn opgenomen met namen en de bijbehorende IP-adressen.

    Hoe weten mijn computers dan weer het adres van die DNS (domain name servers)?:
    Ergens bij servers van jouw provider (@home) staan de adressen van deze root-DNS-servers.

    Wat kan/is jouw probleem nou (zijn)? (volgens spacemonkey):
    In jouw router heb jij zelf een adres opgegeven van een DNS (zie afbeelding ‘static DNS 1:’). Dus jouw router verwijst eerst voor elke name-resolve naar het betreffende adres (192.168.1.100).

    Kortom:
    Jij zit te surfen achter je Mac. Persoon twee op één van de andere PC’s die op jouw router zijn aangesloten. Persoon twee opent zijn internet explorer en typt in http://www.foo.nl. Jouw router krijgt dit binnen en kijkt of hij adressen weet van een DNS. en… JA! dat weet ie… namelijk 192.168.1.100… Maar dat ben jij… achter je Mac…
    Ineens krijgt jouw Mac allemaal raar netwerk verkeer binnen… namelijk een DNS-resolve aanvraag… jouw Mac denkt ‘huh?… was dat?’ (er draait immers geen DNS op). Gevolg is dat Mac hem flipt en het zijn netwerk eruitgooid…

    Hoe los je dit op? volgens spacemonkey:
    Verwijs in je router niet naar een DNS. Dus het veld ‘static DNS 1:’ terug zetten naar ‘0 0 0 0′.

    Ik weet niet zeker of dit de oorzaak van jouw probleem is maar ’t was het eerste wat mij opviel… Misschien heb ik het wel mis, in ieder geval heb je een hele hoop kunnen leren van het bovenstaande verhaal….

    succes;)

    Bijdrager
    DannyR

    :D Thx !

    Heb die static dns 1 weer op 0.0.0.0 staan
    Alles loopt nog steeds goed, nu maar af wachten of hij er nog een keer uit vliegt!

    bedankt voor het consult :wink:

    Bijdrager
    spacemonkey

    noprob!

    Hoop dat je wat heb geleerd van het verhaal… het was namelijk heel veel typen;)

    Succes

    Bijdrager
    Aqua1

    Mocht het nog een keer misgaan: ik zou denken dat de MAC-clone-functie ervoor zorgt dat je twee dezelfde MAC-adressen in 1 LAN krijgt. Omdat een DHCP-server dat MAC-adres in een functie stopt om een ip-adres uit te geven, kan het ook nog zijn dat dat een conflict oplevert
    Je zou eens kunnen kijken of je Mac (als in Apple) en je router niet toevallig hetzelde MAC (als in Media Access Control) adres hebben. Dat lijkt mij namelijk vragen om moeilijkheden.
    Bij je router staat dat vast ergens in een summary en op je Apple staat het bij prefs/network/ethernet en heet het “ethernet ID”.

    Bijdrager
    DannyR

    Ah dat kan het zijn!

    Mijn MAC-address is idd op mijn Apple gelijk aan die van de router!

    Thx

    Danny

    Bijdrager
    spacemonkey

    Dat lijkt me niet uit te maken toch? Anders zou die functie overbodig zijn. Je router met zijn gecloonde MAC-adres hangt op WAN (internet) en jouw Mac (als in Apple) op jouw LAN (lokaal). Een heel ander netwerk dus. Die twee netwerkkaarten communiceren niet met elkaar. Die van jouw router (WAN) geeft alleen de netwerk-pakketjes door naar je Apple en daar zit een lokaal IP-adres aan gekoppeld (192.168.1.100).

    Toch?:?

    Je zou het voor de zekerheid i.i.g. kunnen doen. Voor zover ik weet doet @home niet aan MAC-adres identificatie. Maar het lijkt mij niets uit te maken.

    Bijdrager
    Aqua1
    ”spacemonkey”

    Dat lijkt me niet uit te maken toch? Anders zou die functie overbodig zijn. Je router met zijn gecloonde MAC-adres hangt op WAN (internet) en jouw Mac (als in Apple) op jouw LAN (lokaal). Een heel ander netwerk dus. Die twee netwerkkaarten communiceren niet met elkaar. Die van jouw router (WAN) geeft alleen de netwerk-pakketjes door naar je Apple en daar zit een lokaal IP-adres aan gekoppeld (192.168.1.100).

    Toch?:? ……..

    Hmjahmhmhmhm. Daar zeg je zo wat… Ik weet het niet. Zou die clone functie alleen maar zijn voor als je een DHCP-ISP hebt ? Zodat je ongemerkt een router kan plaatsen ? Lijkt me ook niet heel waarschijnlijk. :?
    Iig kan je eens proberen je router MAC te veranderen. Kijken of het werkt. Vergeet niet het resultaat te posten.

    Bijdrager
    spacemonkey

    Hmjahmhmhmhm. Daar zeg je zo wat… Ik weet het niet. Zou die clone functie alleen maar zijn voor als je een DHCP-ISP hebt ? Zodat je ongemerkt een router kan plaatsen ? Lijkt me ook niet heel waarschijnlijk.

    Volgensmij is die functie er meer voor wanneer de DHCP-lease van de ISP gekoppeld is aan een specifiek MAC-adres. In dit geval, @home, wordt er ook gewerkt met DHCP (’t lijkt me dat alle ISP’s dat doen), maar hierbij is de DHCP-lease gekoppeld aan een hostname (dat CC******* gebeuren).

    Het lijkt mij sterk dat het hele dubbele MAC-adres gebeuren de oorzaak van het probleem is, aangezien die van de router (met eenzelfde MAC) alleen in de header kijkt naar een lokaal IP-adres om vervolgens zijn pakketjes door te sturen. Maar het blijven computers dus je weet maar nooit. Bovendien is dat hele cloon gedoe overbodig bij @home. Dus.. niet doen! net als dat DNS spul. Als je niet weet wat het betekent… zoek het is of vul het niet in;)

    b.t.w. Ik ben ook benieuwd of het probleem nu is opgelost.

    Bijdrager
    Jurriaan.

    heb ik ook gehad. nadat ik de pc op de router aansloot, wou de mac niet meer op internet. hoe ik dit heb opgelost? Alle ip-adressen, DNS, subnet en noem maar op, handmatig instellen. dus iig geen instellingen in de router zelf(als je deze tenminste volgens de handleiding hebt geinstalleerd).

    Bijdrager
    DannyR

    Oke een week later!

    Nog geen problemen gehad (ff afkloppen)
    Heb nu het mac-adress nu NIET gecloont, en dat verhaal met DNS weer op 0.0.0.0 staan.

    Thx voor jullie hulp

17 berichten aan het bekijken - 1 tot 17 (van in totaal 17)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.