7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)
  • Q:
    Bijdrager
    NewToMac

    Root Login MySql

    beste mensen,

    voorheen mysql heerlijk gebruikt op mijn xp machine. Wil het nu graag ook werkend hebben op mijn mac.

    Telkens als ik een nieuwe database wil creeren krijg ik de volgende melding:

    ERROR 1044 (42000): Access denied for user ”@’localhost’ to database <databasename>

    Wel kan ik in een bestaande database werken…

    Bijdrager
    hansenonline

    probeer eens een programma als cocoamysql om je databases te beheren.
    verder in terminal>mysql -u root en dan je wachtwoord als daar om gevraagd wordt.

    Bijdrager
    NewToMac

    Wanneer ik in mijn shell het volgende intik: mysql -u root

    Dan krijg ik de volgende melding: -bash: mysql: command not found

    Mysql start ik middels de volgende commando: /usr/local/mysql/bin/mysql

    Bijdrager
    DarkRaverNL

    zo moet je ook commandos uitvoeren,

    /usr/local/mysql-max-5.0.22-osx10.4-powerpc-64bit/bin/mysql <commando>

    zo is het bij mij:)

    Bijdrager
    TGV

    Die laatste methode is fout, want zoals je kunt zien verandert het commando met elke versie en platform. De binary wordt standaard in /usr/local/bin ge├»nstalleerd en door die directory aan je PATH toe te voegen, kun je ‘m gewoon meteen met “mysql” starten. Zet deze regel in ~/.profile

    export PATH=$PATH:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/local/sbin

    Die voegt al die directories toe aan de plaatsen waar de shell zoekt naar commando’s.

    Bijdrager
    DarkRaverNL

    ik zei ook, “zo is het bij mij :)” bij hem zal het natuurlijk iets anders zijn.

    Bijdrager
    dj bazzie wazzie

    /usr/local/mysql/bin/mysql

    Het vet gedrukte mysql is een link naar de map van de laatste versie van MySQL. Dus als je dit commando gebruikt werkt het altijd ook nadat je een nieuwere versie hebt geinstalleerd.

    Dus je commando moet dan zijn:

    [code:1:3d26eee61d]/usr/local/mysql/bin/./mysql -h localhost -u root -ppassword -D database –disable-column-name -e "select column from table name where column = ‘value’"[/code:1:3d26eee61d]

    Mijn versie van mysql mag geen spatie tussen de -p en het wachtwoord maar dat weet ik niet of dat bij alle mysql versies zo is.

    Zelf gebruik ik navicat om mysql in te stellen en waarden in de tabellen te bekijken en wijzigen. Volgens mij kan dit niet bij de freeware die je bij mysql kan downloaden.

7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.