13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)
  • Q:

    Bijdrager
    riji

    Rechten op mijn Macintosh HD aanpassen?

    Gisteren heb ik een 1-dag oude backup met Time Machine teruggezet om van Sierra terug te keren naar EC.
    Sinds dan heb ik een probleem dat ik blijkbaar onvoldoende rechten heb op mijn enige harde schijf.
    Als ik mezelf (enig gebruiker) of een administrator wil toevoegen krijg ik die melding dat ik niet bevoegd ben. (zie afbeelding)

    In Finder wordt ik bij het verwijderen gewaarschuwd dat dit niet meer ongedaan kan gemaakt worden (niets in prullenmand).
    In ForkLift moet ik telkens mijn wachtwoord ingeven om iets te kunnen verwijderen.

    Ik zie met het Schijfhulpprogramma: Eigenaren ingeschakeld: JA (zou dit er iets mee te maken hebben)?

    Hoe dit oplossen?

    • Dit onderwerp is gewijzigd 2 jaren geleden door  riji.
    • Dit onderwerp is gewijzigd 2 jaren geleden door  riji.
    • Dit onderwerp is gewijzigd 2 jaren geleden door  riji.

    Bijdrager
    TheBigZ

    Bijdrager
    riji

    bedank, maar het is (nog) niet gelukt.
    ik heb uitgevoerd:
    sudo /usr/libexec/repair_packages –verify –standard-pkgs /
    sudo /usr/libexec/repair_packages –repair –standard-pkgs –volume /

    Ik heb het ook geprobeerd met OnyX, dat een onderdeel herstellen rechten heeft, tevergeefs.

    Zou dit misschien een uitweg zijn?

    diskutil [quiet] <verb> <options>

    disableOwnership (Ignore on-disk User/Group IDs for a mounted volume)

    • Deze reactie is gewijzigd 2 jaren geleden door  riji.

    Bijdrager
    koen

    Ik zou niet gaan lopen rommelen met allerlei vage terminal commands om dit op te lossen. In jouw geval lijkt het me beter om een complete clean install van El Capitan te doen, en dan je documenten, etc. weer terug te zetten met TM.


    Bijdrager
    riji

    bedankt, maar dit is het laatste wat ik zal ondernemen


    Bijdrager
    koen

    Maar waarom klooien met de terminal als je niet eens goed weet waar je mee bezig bent? Als het dan mis gaat zul je alsnog een clean install moeten doen. Maar goed, je moet het natuurlijk helemaal zelf weten.

    Wat heb je trouwens nog meer uitgespookt met Onyx?


    Bijdrager
    Jakko Westerbeke
    riji op 22 september 2016

    Ik zie met het Schijfhulpprogramma: Eigenaren ingeschakeld: JA (zou dit er iets mee te maken hebben)?

    Ja, dat heeft het: als eigenaren uitstaan voor de schijf, kan iedereen alles (lezen, schrijven, verwijderen, enz.) met elk bestand dat erop staat. Alleen kun je precies om die reden op zo’n schijf geen Time Machine gebruiken.


    Bijdrager
    riji

    Bedankt Jakko, ik heb dit geprobeerd:
    diskutil disableOwnership

    Wrong number of parameters

    Usage: diskutil disableOwnership MountPoint|DiskIdentifier|DeviceNode
    Disable exact consideration and writing of User and Group ID at the file system
    level; that is, all User and Group IDs will appear to be that of the current
    user instead of what is actually on the target disk. This is the default for
    plug-in disks. The target disk and this setting is persistent across disk
    injects via the OS’s Volume Database.
    It is required that this command be run as root.

    Ik heb eerst info geprobeerd met disk1 en dit blijkt inderdaad mijn Macintosh HD volume te zijn

    diskutil disableOwnership disk1 —> root is nodig, dit nu uitzoeken — OK, maar nu lukt het nog niet

    mac2:~ root# diskutil disableOwnership disk1
    Error enountered disabling user/group ownership: The underlying task reported failure on exit (-69860)

    • Deze reactie is gewijzigd 2 jaren geleden door  riji.
    • Deze reactie is gewijzigd 2 jaren geleden door  riji.

    Bijdrager
    koen

    Het eerste wat ik dan altijd doe is die foutmelding even googlelen. En dat levert dan zoiets op: https://discussions.apple.com/message/19018520

    Oh, en je post is wat beter te lezen wanneer je de terminal command’s tussen code-tags plaatst:

     
    mac2:~ root# diskutil disableOwnership disk1
    Error enountered disabling user/group ownership: The underlying task reported failure on exit (-69860)
     

    Je kunt je posts altijd aanpassen door op je avatar te klikken.(y)

    • Deze reactie is gewijzigd 2 jaren geleden door  koen.

    Bijdrager
    koen

    Je moet trouwens nooooooiiit als root inloggen in de terminal. Veel beter en veiliger is het om je commands vooraf te laten gaan door ‘sudo’:

     
    mac2:~ sudo diskutil disableOwnership disk1
     
    • Deze reactie is gewijzigd 2 jaren geleden door  koen.

    Bijdrager
    riji

    Ik waardeer dat je me wilt helpen, maar je hoeft niet als een onderwijzer te doen.

    Je moet trouwens nooooooiiit als root inloggen in de terminal. Veel beter en veiliger is het om je commands vooraf te laten gaan door ‘sudo’:

    mac2:~ sudo diskutil disableOwnership disk1

    zie mijn aanbreng:

     
    diskutil disableOwnership
    Wrong number of parameters
    Usage:  diskutil disableOwnership MountPoint|DiskIdentifier|DeviceNode
    Disable exact consideration and writing of User and Group ID at the file system
    level; that is, all User and Group IDs will appear to be that of the current
    user instead of what is actually on the target disk.  This is the default for
    plug-in disks.  The target disk and this setting is persistent across disk
    injects via the OS’s Volume Database.
    It is required that this command be run as root.
     

    It is required that this command be run as root

    Het eerste wat ik dan altijd doe is die foutmelding even googlelen. En dat levert dan zoiets op: https://discussions.apple.com/message/19018520

    Hiermee geraak ik er ook niet.

    • Deze reactie is gewijzigd 2 jaren geleden door  riji.

    Bijdrager
    koen
    riji op 22 september 2016

    It is required that this command be run as root

    Ja, en dat doe je als ‘sudo’, dat is daar speciaal voor gemaakt Als je als ‘root’ inlogt is het ongelooflijk eenvoudig om een spatie te veel of te weinig te tikken en je hele systeem ligt op z’n kop. Dat kan trouwens ook met ‘sudo’, maar daar wordt je regelmatig herinnerd om je paswoord in te tikken. Met ‘root’ alleen maar de eerste keer.

    En mijn excuses als ik wat belerend overkwam.

    • Deze reactie is gewijzigd 2 jaren geleden door  koen.

    Bijdrager
    riji

    OK.
    Ik heb mijn backup met TM nog eens teruggezet en dit keer kon ik wel de schijfrechten aanpassen.

    probleem:
    “In ForkLift moet ik telkens mijn wachtwoord ingeven om iets te kunnen verwijderen.” –> OPGELOST

    probleem:
    “In Finder wordt ik bij het verwijderen gewaarschuwd dat dit niet meer ongedaan kan gemaakt worden (niets in prullenmand).”
    NOG NIET OPGELOST
    Ik heb nochtans ook de rechten voor mijn thuismap kunnen wijzigen naar lezen en schrijven.

    UPDATE: opgelost –> verborgen map Trash gezocht en daar iedereen rechten gegeven, Finder herstart –> OK

    ZO ALLES OPGELOST: iedereen bedankt.

    • Deze reactie is gewijzigd 2 jaren geleden door  riji.
13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.