20 berichten aan het bekijken - 1 tot 20 (van in totaal 20)
  • Q:
    Bijdrager
    stefsegers

    qnap verbinden via naam ipv ip nummer

    Hey allen,

    Ik heb een QNAP ingesteld staan op DHCP (statisch geeft hier en daar wat problemen). Nu heb ik een connectie script gemaakt met Automator die verbinding maakt met de server via een afp en het ip nummer. Maar geregeld refreshed mijn router het ip nummer dus moet ik het script elke keer weer opnieuw maken.

    DDNAS werkt ook niet want die maakt verbinding met het externe IP nummer en niet het interne nummer.

    Is er een moeilijkheid een verbinding te maken met de hostname ipv het ipnummer zodat mijn script altijd werkt? Dit script wil ik op al mijn macs zetten dan. Het liefst dus niet de hosts file aanpassen oid.

    Ben benieuwd oif iemand een tip heeft, ik heb het nog niet op het forum kunnen vinden namelijk.

    Bijdrager
    macpro

    Je kunt in je router mogelijk instellen dat de QNAP zijn IP adres via DHCP vasthoudt.
    En anders moet je de QNAP toch een vast IP adres geven, maar dan een adres dat buiten de DHCP range valt. Dan heb je niet meer de “hier en daar” problemen.

    Bijdrager
    Wyodor

    In mijn Experiabox heb ik het begin en eind ip nummer van de DHCP reeks gewijzigd. De reeks begint op nummer 5 .

    De nummers (1 t/m 4) die daaronder zitten gebruik ik o.a. voor de NAS.

    De NAS heeft dus een statisch IP nummer.

    Zo voorkom ik dat o.a. de NAS een ander IP nummer krijgt na een herstart.

    De NAS heeft ook een eigen naam. Die kan je dan gebruiken in een URL.

    Alleen voor port forwarding heb je weer het IP nummer nodig.

    Bijdrager
    stefsegers

    vast ip geeft een probleem met de dns. De QNAP geeft aan dat de router/gateway geen geldige DNS server is. Via DHCP werkt het wel,maar krijg ik dus het probleem dat het ip nummer aangepast kan worden.

    In Windows was het ooit gebruikelijk dat je de naam van de machine ingaf in de address bar en dat je deze machine kon inloggen.

    Daarom dus mijn vroaag hoe dit in OSX op te lossen?!?

    Bijdrager
    friesappeltje

    Hoi. Ik heb ook een QNAP (perfect ding) en het verbinden via Automator lukt mij via de taken: ‘Haal opgegeven server op’ en ‘ verbind met server’
    Als naam van de server heb ik opgegeven: SMB//:QNAPNAAM/MAPNAAM
    Doe jij het anders?

    Bijdrager
    friesappeltje

    sorry, als naam van de server heb ik: SMB://qnapnaam/mapnaam (dubbelepunt en slashes net andersom)

    Bijdrager
    stefsegers

    Hi Friesappeltje, dus alleen SMB werkt dat mee als ik het goed begrijp?

    Bijdrager
    friesappeltje

    Hoi Stef. Ik heb het ook nog even met AFP geprobeerd maar dat lukt inderdaad niet. Lukt me nu alleen via SMB.
    Op de QNAP moet onder ‘Network Services’ je SMB wel aan staan.
    Het verbaasd me trouwens dat het via AFP niet lukt. Misschien doe ik iets niet goed maar.. ach via smb lukt ’t wel

    Bijdrager
    johnkeates

    Je kan kijken of MDNS / Multicast in je netwerk werkt. Als dat niet het geval is kan Avahi op je NAS z’n werk niet doen en is het apparaat onvindbaar.

    Bijdrager
    stefsegers

    Hey allen,

    bedankt voor jullie reacties. Ik heb net even gekeken. Mijn QNAP heb ik SMB ook aan staan en in de Bonjour aangegeven dat mijn nas bij smb QNAP heet.

    In mijn Ziffo wifi modem heb ik gekeken en zie dat Multicast enabled staat.

    Als ik ga naar server SMB://QNAP doe werkt het niet

    Misschien heb ik ergens een stap over geslagen?

    Bijdrager
    johnkeates

    Download Bonjour Browser en kijk hoe het apparaat zich in het netwerk aanmeld

    Bijdrager
    stefsegers

    Hi John,

    Handig programma zeg! Ik heb gevonden hoe mijn QNAP zich aanmeldt.
    AFP: QNAP559(AFP)
    SMB: QNAP

    ip nummers staan ook netjes verwerkt

    Maar wat ik ook probeer bij verbinden met server… het werkt niet. Ik snap er niets meer van want echt ingewikkeld is het niet.

    Ik wil bijvoorbeeld een share verbinden: AFP://QNAP559(AFP)/Download

    Ik krijg dan van osx de melding dat het ip nummer ongeldig is en er een fout is voorgedaan

    Zelfde ook bij SMB:(

    Bijdrager
    friesappeltje

    Moet de connectie vanuit Automator komen?
    Wanneer je vanuit de Finder connectie maakt via <Ga>; <Verbind met Server> (of via appeltje K) kun je dan wel op naam, verbinding maken met je QNAP?

    Bijdrager
    curryhano

    Ik heb ook een QNAP NAS. ik gebruik de bonjour optie in de firmware. Gewoon onder Network Services->Network Service Discovery en dan onder de tab Bonjour afp aanklikken. Dan vinden je macs de storage automagisch.

    Bijdrager
    iep
    stefsegers op 07 oktober 2011

    vast ip geeft een probleem met de dns. De QNAP geeft aan dat de router/gateway geen geldige DNS server is. Via DHCP werkt het wel,maar krijg ik dus het probleem dat het ip nummer aangepast kan worden.

    Dat klinkt als een verkeerde dns server. Wat je beter kunt doen is via dhcp alles laten uitdelen en dan eens kijken wat je uitgedeeld hebt gekregen. Dingen als DNS en gateway (vaak ook router genoemd) heb je nodig als je een internetverbinding op wil hebben, die moet je dan ook 1 op 1 overnemen.

    Wat je ook kunt doen in menig router is op basis van het MAC-adres (hardware adres in OS X termen) van de NAS een ip-adres uitdelen via DHCP. Op die manier krijgt de NAS altijd de juiste gegevens en heeft het toch een ip-adres dat niet veranderd.

    Welk apparaat in je netwerk is de DHCP server?

    In Windows was het ooit gebruikelijk dat je de naam van de machine ingaf in de address bar en dat je deze machine kon inloggen.

    Dat werkt middels NetBIOS en dat doet OS X nog steeds mits je SMB gebruikt. Voor de rest werkt het in Windows, Linux en OS X hetzelfde. Wil je het op basis van naam doen dan heb je iets van DNS of je /etc/hosts bestand nodig. Dat Bonjour is trouwens een hele simpele DNS. Dat komt ook vaak terug op diverse NAS apparaten dus dat zou ook nog een oplossing kunnen zijn.

    Bijdrager
    stefsegers

    Hey allen,

    Weer een hoop reply’s. Gek dat ik ze niet via de mail steeds krijg.
    Maar goed.

    Ik heb een Ziggo Wifi Modem welke als DHCP server werkt. Hij deelt alles netjes uit. Dit is 10.0.1.1

    Alle apparaten in het netwerk hebben dus automatisch een IP nummer.

    10.0.1.1 krijgt dus van ziggo de DNS gegevens door.

    Mijn QNAP geeft aan dat 10.0.1.1 dus niet goed functioneert als DNS server

    Wanneer ik via FINDER -> GA -> verbind met server doe lukt het inderdaad niet.

    Ik kan alleen browsen naar de servers, maar ik wil juist via een script (bijv automator) mijn shares automatisch mounten. Het werkt prima zolang de QNAP niet van ip verandert. Daarom is dus het mooiste als ik de NAAM kan gebruiken ipv een IP nummer zodat ik niet afhankelijk ben van een nummer maar van een naam.

    Misschien zo iets duidelijker uitgelegd wat een hoe ik het probeer?

    Bijdrager
    Wyodor

    Op een lokaal netwerk moet je achter de naam .local zetten. Zoiets dus :

    AFP://QNAP559(AFP).local/Download

    Mijn Synology NAS mount ik met afp://diskstation.local

    En kijk of (AFP) in de naam werkelijk nodig is.

    Bijdrager
    stefsegers

    Hi Wydor,

    Heb ik ook even geprobeerd: smb://QNAP.local en ook AFP maar helaas

    Er heeft zich een probleem voorgedaan bij de verbinding met de server QNAP.local

    De server bestaat niet of momenteel niet bereikbaar

    Echt vreemd?!?

    Bijdrager
    friesappeltje

    Ik ben destijds ook een poosje aan het klooien geweest om via automater de QNAP automatisch te laten mounten. Uiteindelijk bleek het via ‘Systeemvoorkeuren’, ‘Gebruikers en groepen’ en daar onder het kopje ‘inloggen’ het makkelijkst te werken. Eenmaal via browsen naar de juiste map op de QNAP en vanaf mijn bureaublad gewoon slepen in het vakje voor de programma’s welke moeten openen bij het opstarten.

    Kun je via de browser, onder het jouw bekende ip-nummer van de NAS wel bij het inlogscherm van je NAS komen?

    Bijdrager
    friesappeltje

    Is het al gelukt?
    Ehh.. misschien ten overvloede maar nog niet zo heel lang geleden heeft QNAP nieuwe firmware uitgebracht waarmee de NAS ‘Lion-proof’ werd. Heb je gekeken of je de nieuwste firmware op de NAS hebt geinstalleerd?

20 berichten aan het bekijken - 1 tot 20 (van in totaal 20)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.