22 berichten aan het bekijken - 1 tot 22 (van in totaal 22)
  • Q:
    Bijdrager
    Artishoque

    Prullenbak wil niet leeg, ook niet op andere manieren

    Ik heb zojuist adobe cs2 in m’n prullenbak gegooid, en er zijn 2 bestanden die daarin blijven staan.
    Die bevinden zich in twee mappen: “photoshop cs2” en “illustrator cs2”.
    Na diverse submappen door te worstelen stuit je dan op de uiteindelijke file die niet weg wil:

    Ik heb het ook geprobeerd met programma’s zoals Coctail, maar óf er gebeurt helemaal niets, óf ik krijg een “error -43”.

    Wie heeft de gouden tip?

    Bijdrager
    trabant

    Meestal laten bepaalde bestanden zich niet verwijderen omdat ze nog in gebruik zijn. Sluit het programma waar je het betreffende bestand mee hebt geopend eens af en probeer het dan nog eens.

    En heb je al gegoogled op ’error -43″?

    Bijdrager
    HSL

    in de terminal

    [code:1:b4ca075ab9]rm -rf ~/.Trash/*[/code:1:b4ca075ab9]

    en *klaar*

    Bijdrager
    Neowave

    Probeer Secure Empty Trash. Dat werkt bij mij altijd, zelfs als een bestand in gebruik is.

    Bijdrager
    sedikit

    Of heel simpel : herstarten?

    Bijdrager
    Roggie

    Ik ben ook zeer benieuwd…heb al tijden een onzichtbaar bestand in de prullenmand dat .lhs heet en niet weg wil. Ook niet met die programma’s als onyx en dergelijke. Zelfde geldt voor een unicode.bundle bestand. Ook via de terminal werkt het niet. Krijg voor de eerste de mededeling dat de operation not permitted is en voor de tweede dat de directory niet leeg is.

    Bijdrager
    vhbart

    Is reeds verschillende malen gepasseerd, hier is er bv. ook een draadje over. Je kan geforceerd legen als je de option (alt) toets ingedrukt houdt terwijl je opdracht “leeg prullenmand/ empty trash” geeft :wink: .

    [edit] Doe dit alleen maar als je zeker weet dat het geen kwaad kan voor je instellingen. [/edit]

    Bijdrager
    Esquare
    ”Roggie”

    Ook via de terminal werkt het niet. Krijg voor de eerste de mededeling dat de operation not permitted is en voor de tweede dat de directory niet leeg is.

    Als je de terminalcode van HS-L gebruikt, zou dat laatste eigenlijk niet moeten kunnen… Het eerste zou je kunnen oplossen door de volgende opdracht te geven:

    [code:1:08bbca9034]sudo rm -rf ~/.Trash/*[/code:1:08bbca9034]

    Je wordt dan als het goed is gevraagd om je password.

    Bijdrager
    michelvdb

    Open Terminal
    typ ls -lo door een spatie gevolgd
    sleep het niet-verwijderbare bestand in het Terminalvenster en geef Enter
    je zult een gelijkaardig resultaat krijgen als hieronder

    [URL=http://imageshack.us][/URL]

    het geselecteerde tekstje is een flag als er schg staat kun je het niet verwijderen als er uchg staat kun je het verwijderen na een Terminalingreep.

    als er uchg staat
    typ sudo chflags -R nouchg door een spatie gevolgd en sleep het aan te passen bestand in het Terminalvenster en geef Enter
    typ je beheerderswachtwoord en geef Enter

    schg is niet te wijzigen met noschg, dat kan alleen in single-user

    Meer info vind je hier:
    http://www.westwind.com/reference/OS-X/commandline/

    Bijdrager
    Roggie
    ”Esquare”
    ”Roggie”

    Ook via de terminal werkt het niet. Krijg voor de eerste de mededeling dat de operation not permitted is en voor de tweede dat de directory niet leeg is.

    Als je de terminalcode van HS-L gebruikt, zou dat laatste eigenlijk niet moeten kunnen… Het eerste zou je kunnen oplossen door de volgende opdracht te geven:

    [code:1:28e4e69486]sudo rm -rf ~/.Trash/*[/code:1:28e4e69486]

    Je wordt dan als het goed is gevraagd om je password.

    Dat commando geeft precies hetzelfde resultaat…

    Bijdrager
    Roggie
    ”michelvdb”

    Open Terminal
    typ ls -lo door een spatie gevolgd
    sleep het niet-verwijderbare bestand in het Terminalvenster en geef Enter
    je zult een gelijkaardig resultaat krijgen als hieronder

    [URL=http://imageshack.us][/URL]

    het geselecteerde tekstje is een flag als er schg staat kun je het niet verwijderen als er uchg staat kun je het verwijderen na een Terminalingreep.

    als er uchg staat
    typ sudo chflags -R nouchg door een spatie gevolgd en sleep het aan te passen bestand in het Terminalvenster en geef Enter
    typ je beheerderswachtwoord en geef Enter

    schg is niet te wijzigen met noschg, dat kan alleen in single-user

    Meer info vind je hier:
    http://www.westwind.com/reference/OS-X/commandline/

    Dit is wat ik krijg als ik het zo doe:

    Last login: Thu Jul 6 14:59:10 on ttyp1
    Welcome to Darwin!
    g5:~ hansroggen$ ls -lo /Users/hansroggen/.Trash/Previous Systems/
    total 0
    drwxrwxr-x 3 hansrogg admin – 102 Jun 24 21:17 Previous System 1
    g5:~ hansroggen$

    Bijdrager
    Esquare

    Zo te zien, zit dat bestand nog in de Trash van een gebruikersaccount dat gewist is…

    Bijdrager
    Roggie

    Dat Previous Systems is de naam van de map waarin het unicode bestand zit. dat andere bestand dat nieyt weg wil is onzichtbaar. Er zijn geen gebruikers accounts gewist en er is ook geen nieuw systeem op gezet.

    Bijdrager
    Esquare

    Herstel: ik bedoelde eigenlijk dat er klaarblijkelijk een Archive&Install is uitgevoerd. Dat is vziw de enige manier waarop je zo’n ‘Previous System’-map op je schijf krijgt staan.

    Enniwee. Ik neem aan dat je dit allemaal al eens geprobeerd hebt:
    http://docs.info.apple.com/article.html?artnum=106272-nl

    Bijdrager
    michelvdb

    Doet dit commando het?[code:1:4e99e83f98]rm -R /Users/hansroggen/.Trash/Previous Systems/[/code:1:4e99e83f98]

    Bijdrager
    Roggie

    Nee, werkt ook niet…nog steeds de mededeling: directory is not empty.

    Bijdrager
    alaska

    ik heb hetzelfde probleem. weet iemand een oplossing die wel werkt?
    ik heb alles al geprobeerd wat hierboven beschreven is…

    Bijdrager
    scratch45

    Heb je Xupport 3 al eens geprobeerd. Dit programma verricht aardig wat wonderen. Als je het hebt gedwonload en geinstalleerd zit er onder de knop Maintenance een subknop TRASH. Hier kun je de bestanden via X-trash verwijderen. Werkt bij mij tot nog toe zonder problemen.

    Te vinden op:
    http://www.xupport.ch/

    Bijdrager
    tarun

    Probeer eens met OS9 op te starten en dan de prullenbak te legen. Wil wel eens helpen aangezien OS9 geen Unix is en dus geen rekening houdt met Unix -schrijfrechten.

    Bijdrager
    zAo

    Het is het proberen waard:
    [code:1:9bf2f0b814]
    sudo rm -R /Users/hansroggen/.Trash[/code:1:9bf2f0b814]

    Bijdrager
    Esquare

    Nog twee alternatieven: de eerste is DropNuke, de tweede een vrij omslachtige procedure:

    1. Sleep het onwillige bestand uit de Trash naar de map Gedeeld (Shared)
    2. Maak een (tijdelijk) nieuw gebruikersaccount aan en log daar in.
    3. Sleep het bestand uit Shared naar de Trash van het nieuwe account en log uit.
    4. Ga terug naar het hoofdaccount en delete het gebruikersaccount met het onwillige bestand.

    Bijdrager
    iJoost
    ”zAo”

    Het is het proberen waard:
    [code:1:13096f8334]
    sudo rm -R /Users/hansroggen/.Trash[/code:1:13096f8334]

    Wel heeeeeel voorzichtig dan, want als je per ongeluk iets te vroeg op Enter drukt is je hele harde schijf leeg…

22 berichten aan het bekijken - 1 tot 22 (van in totaal 22)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.