23 berichten aan het bekijken - 1 tot 23 (van in totaal 23)
  • Q:
    Bijdrager
    CorMac

    programma compilen in Terminal

    Ik heb via Google een programma gevonden voor het omzetten van standaard ondertiteling naar 3D SBS maar dit moet via cli/terminal.
    Aangezien ik daar geen ervaring mee heb en het mij dus ook niet lukt wil ik jullie ven vragen wat ik nu precies moet doen.
    Dit is de uitleg op de pagina van Google codes:
    (originele link: hier )
    Basic Usage
    To compile from source code. Run in CLI:

    wget http://sub3dtool.googlecode.com/files/sub3dtool-0.4.2.tar.gz
    tar -xf sub3dtool-0.4.2.tar.gz
    cd sub3dtool-0.4.2
    make
    ./sub3dtool

    Note that the above commands may change as later versions of the software are released.

    To convert a subtitle to Side-by-Side, first cd to the folder you put the sub3dtool program. Then run:

    ./sub3dtool input.srt –3dsbs -o output.ass
    Whereas input.srt is the path to the file you need to convert.

    output.ass is the name of the file you want as the result.

    –3dsbs indicates that you want to convert the subtitle to 3DSBS (Side-by-Side) format.

    Bijdrager
    marcelnijman

    1. Start een terminal (te vinden in /Applications/Utilities).
    2. Knip en plak regel voor regel die 5 commando’s in de terminal, telkens op enter drukkend.
    3. Je zult zien dat je foutmeldingen krijgt bij regel 1, doordat je benodigde software niet hebt.
    3.1. Installeer MacPorts (http://www.macports.org)
    3.2. Open een nieuwe terminal en typ: sudo port install wget
    4. Ga in je eerste terminal verder met het lijstje van 5 commando’s (je zult weer bij de eerste regel moeten beginnen). Nu zal regel 4 mis gaan.
    4.1. Installeer Xcode (via de Mac App Store)
    5. Regel 4 en 5 moeten nu lukken.

    Bijdrager
    CorMac

    Dat is gelukt. Maar wat nu met:

    To convert a subtitle to Side-by-Side, first cd to the folder you put the sub3dtool program. Then run:
    ./sub3dtool input.srt –3dsbs -o output.ass
    Whereas input.srt is the path to the file you need to convert.
    output.ass is the name of the file you want as the result.
    –3dsbs indicates that you want to convert the subtitle to 3DSBS (Side-by-Side) format.

    Hoe weet ik in welke folder hij sub3dtool heeft gezet?

    in terminal heb ik nog het volgende:

    Usage: ./sub3dtool [OPTIONS]… [INPUT]…
    Tool to convert subtitles to 3D format.

    Mandatory options:
    [INPUT] Input file, support SRT and ASS format
    -h –help Print help
    -o –output FILE Output file, support SRT and ASS format
    Output format is determine by extension
    Default is to use ASS subtitle format
    –debug Self-test.

    3D options:
    –3dsbs Side-By-Side subtitle
    –3dtb Top-Bottom subtitle
    –no3d Reverse previously converted subtitle

    Customization:
    –screen WxH Set Play Resolution (subASS). Default: 1920×1080
    –font FONT Set font name. Default: Freesans
    –fontsize SIZE Set font size. Default: 64

    The following commands set colors of subtitles
    -c –color 0xRRGGBB Conventional for Primary & Secondary colors
    –color-primary 0xRRGGBB Default: 0xFFFFFA
    –color-2nd 0xRRGGBB Default: 0xFFFFC8
    –color-outline 0xRRGGBB Default: 0x000000
    –color-back 0xRRGGBB Default: 0x000000
    –color-force Ignore colors in input file

    –border-shadow Subtitles have outline and drop shadow (default)
    –border-box Subtitles have blackbox as background
    Doesn’t work well with 3D

    –outline [0-4] Outline width
    –shadow [0-4] Shadow width

    –align-left Set alignments
    –align-center Default
    –align-right
    –align-bottom Default
    –align-middle
    –align-top
    –margin-left N Left margin
    –margin-right N Right margin
    –margin-vertical N Vertical margin

    Bijdrager
    marcelnijman

    Je hebt eigenlijk zelf al antwoord gegeven: het programma staat in de map waar je in de terminal naartoe bent gegaan.
    Met het commando ‘pwd’ kun je zien waar dat is. De conversie kun je dus direct vanuit de terminal doen. Wel eerst even de bronbestanden (.srt) in diezelfde map zetten.

    Bijdrager
    CorMac

    Mag ik de map van het programma wat nu direct onder Macintosh HD/gebruikers/gebruikersnaam staat verplaatsen naar bv de downloadmap of de programmamap?

    Als ik nu dus een ondertitel wil converteren moet ik dit ingeven zeker: ./sub3dtool input.srt –3dsbs -o output.ass

    Maar wat als ik de output file in srt formaat wil (gewoon outputnaam.srt doen?) en de grootte en de kleur van het lettertype wil veranderen?

    Kun je eens testen of de web based versie bij jou wel werkt?

    Zoja even naar de website gaan en de instructies volgen. Zou fijn zijn, want als ik de stappen volg lukt alles behalve het creëren van een conversie.

    Bijdrager
    marcelnijman

    Mappen verplaatsen mag, maar ik zou eerst even de terminal afsluiten (met ‘exit’) en na het verplaatsen een nieuwe terminal openen. Anders gaat de terminal uit van een niet meer bestaande locatie.

    Hoe je srt als output krijgt staat gewoon in de documentatie:
    -o –output FILE Output file, support SRT and ASS format
    Output format is determine by extension

    Hoe grootte en kleur werkt staat ook in de documentatie. Die opties moet je aan het commando toevoegen.

    Wat gaat er bij jou mis? Welke foutmelding krijg je?

    Bijdrager
    CorMac

    Bij de web based versie heb je dus een soort webpagina, daar heb je dan ook opties om het lettertype aan te passen enz en een groot plus teken.
    Op dat plus teken moet je klikken en dan je .srt selecteren en normaal moet er dan een nieuw icoon komen waarop je right-click kunt toepassen en dan de geconverteerde .srt kunt bewaren. Maar bij mij komt er geen nieuw icoon tevoorschijn.

    Via Terminal had ik het volgende gedaan “./sub3dtool Avatar 3D Half-SBS.srt –3dsbs -o Avatar 3d omgezet.ass” met als error “too much arguments”
    Daarop volgende dacht ik dat het teveel tekens waren dus heb ik de bestandsnaam aangepast en het volgende ingegeven “./sub3dtool Avatarg.srt –3dsbs -o Avatargo.srt” waarop ik dezelfde melding kreeg.

    Voor de kleur te veranderen weet ik ook niet goed wat ik in moet geven, -c dat is duidelijk maar dan weet ik het niet.
    Is het -c en dan de kleurwaarde of -c -color en de kleuwaarde of nog iets anders.

    Voor jou staat het er en is het duidelijk wat er moet gebeuren maar ik heb 0,0 ervaring met Terminal dus voor mij is het niet zo duidelijk ;), hoop dat je dat begrijpt:)

    Bijdrager
    marcelnijman

    Verander eerst even die bestandsnamen naar iets zonder spaties…

    Bijdrager
    marcelnijman

    -c –color betekent dat je mag kiezen tussen -c en –color (wat je maar leesbaarder vindt).

    Ik zou zoiets doen: ./sub3dtool –fontsize 32 -c 0xFF0000 -o output.srt input.ass

    Dan krijg je kleine, rode ondertitels.

    Bijdrager
    marcelnijman

    let op het dubbele minteken:)

    Bijdrager
    CorMac

    In de vorige post zie je dat ik de bestandsnaam al had veranderd naar een naam zonder spaties. Misschien heb je er over heen gelezen…:)
    En wat met de web based, wat zou daar mis zijn? Want ik heb het aan iemand gevaren met een windows pc en daar lukte het wel. Dus ik weet niet of het probleem Mac gerelateerd is of dat het enkel bij mij is.

    Bijdrager
    marcelnijman

    Yep, sorry. Werkt mijn voorbeeldje? Als dat zo is zou ik dat web-interface gewoon laten zitten. Dat kan sowieso minder.

    Bijdrager
    CorMac

    Ik had als laatste dit ingevoerd: ./sub3dtool –fontsize 32 -c 0xFF0000 -o Avatarg.srt -3dsbs Avatargo.ass (jij was de 3dsbs vergeten;)
    en dan krijg ik de melding: “sub3dtool: invalid option — 3”

    Bijdrager
    marcelnijman

    Let weer op het dubbele minteken voor de 3

    Bijdrager
    CorMac

    In wat ik ingeef zie ik geen dubbel minteken staan ” ./sub3dtool –fontsize 32 -c 0xFF0000 -o Avatarg.srt -3dsbs Avatargo.ass”

    Bijdrager
    marcelnijman

    Precies, daarom gaat het ook mis…:-D

    Typ maar eens: ./sub3dtool -h

    Als je goed kijkt zul je in diverse regels een dubbel minteken zien.

    Bijdrager
    CorMac

    Ja dat dacht ik al na nog wat geprobeerd te hebben, maar waarom de 3 erachter?
    Als ik “./sub3dtool –fontsize 32 -c 0xFF0000 -o Avatarg.srt -3dsbs Avatargo.ass” doe dan krijg ik nog dezelfde melding.

    (in jou bericht moet je idd heel goed kijken want het ziet er uit als 1 minteken:))

    Bijdrager
    marcelnijman

    Ja, deze website vervangt een dubbel minteken door een lang minteken (n-dash). Ik had natuurlijk even een codeblokje moeten maken:

     
    --3dsbs
     

    De ontwikkelaar heeft besloten de optie 3dsbs te noemen. Daar had hij alles voor kunnen kiezen, maar deze keus is makkelijk te onthouden (3D side-by-side). Die optie voer je in met een dubbel minteken ervoor.

    Bijdrager
    CorMac

    Ik had het ondertussen gezien dat er daar geen dubbel minteken voorstond als ik het plakte.
    Het werkt nu, althans het converteren. Maar VLC wilt het geconverteerde .srt niet afspelen, de .ass doet het wel. Dus daar zullen we dan mee doen:)
    Bedankt voor de hulp!

    Bijdrager
    marcelnijman

    Hebben film en subs dezelfde naam (dus ook de spaties verwijderd)?

    Bijdrager
    CorMac

    heb mijn vorige post aangepast, filmbestand en ondertitelbestand hebben altijd dezelfde naam bij mij;)

    Bijdrager
    marcelnijman

    ok, succes met het geleerde;)

    Bijdrager
    CorMac

    Bij Avatar doet hij het niet zie ik nu, zowel de .srt als de .ass. De container van de film is “.ts” welke niet met .ass om kan denk ik.

23 berichten aan het bekijken - 1 tot 23 (van in totaal 23)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.