24 berichten aan het bekijken - 1 tot 24 (van in totaal 24)
  • Q:

    Bijdrager
    gipsman

    PHP verouderd in iWebsite

    Hallo forum,

    Mijn hostingaanbieder (Systray solutions België) stuurde een bericht ivm mijn verouderde PHP in een iWebsite. Moet 7.2 ipv. 5.x zijn. Ze voegen er aan toe dat ik dat kan aanpassen via Plex ( geen benul van) èn dat het snel moet gebeuren want dat ze de site uit de lucht halen als er niets gebeurt. Als zij het moeten doen kost het €45 per begonnen half werkuur 🙀. Ik vermoed dat dit met het nooit geupdate iWeb te maken heeft. Maar ik wil deze site nog even laten doorlopen tot ik wat anders heb (Sandvox bv.) Heeft iemand enig idee hoeveel meer die €45 kan worden of wat ik zelf kan doen voor een update ?

     

     


    Bijdrager
    Shmoo

    Het staat los van iWeb.

     

     

    Maar de uitleg is een beetje raar of onduidelijk. WAT is nu aan de hand. Jouw hosting draait waarschijnlijk op PHP 5.x dat zie je wel vaker dat men lang op oude versies blijft zitten. Echter. Ik begrijp niet uit het verhaal of jij nu via Plex (dat is software om de server mee in te stellen) alleen zelf de PHP versie op 7.x moet instellen OF dat jij in je site iets van PHP broncode hebt zitten dat niet compatible is met PHP 7 en dat je dit eerst moet fixen.

     

    Normaal schakelen webhosters namelijk automatisch hun klanten naar PHP 7 – daar vallen ze hun klanten niet mee lastig omdat 9/10 niet weet wat PHP is, laat staan als ze gaan inloggen in Plex. Dat kan allemaal behoorlijk intimiderend overkomen als je geen idee hebt waar het allemaal voor is en wat je wel en niet moet doen.

     

    Zo kun je de PHP versie van je webhosting veranderen. Je zou dan moeten inloggen in dat Plex gebeuren en naar de PHP instellingen gaan en dan kiezen voor versie 7.2.x (gewoon de hoogst mogelijke)

    https://mediatemple.net/community/products/dv/207591256/how-do-i-change-php-versions

     

    Maar nogmaals stel dat je broncode hebt in je iWeb site die niet met PHP 7 kan werken dan krijg je wel foutmeldingen of kunnen bepaalde pagina’s niet meer geladen worden. Als je dit doet controleer dan 5 en 15 minuten laten of alles nog werkt. Contactformulieren en dat soort dingen worden met PHP gemaakt.

     


    Bijdrager
    pruus

    Een aantal providers hebben een zgn hostingmanager of websitebeheer. Daar kun je veel dingen regelen, zoals bijvoorbeeld subdirectories, redirect en ook PHP versie. Plex ken ik ivm instellen van e-mails. Maar jouw provider moet je toegang geven voor het aanpassen van de php of zelf al doen. PHP 5.x pagina’s bevatten opdrachten richting tabellen die in PHP 7 niet meer ondersteund worden. Dus je moet de php-pagina’s nalopen die contact maken met de database en de querys. Zoek op Google maar eens naar het overzetten naar PHP 7 versie.


    Bijdrager
    gipsman

    Bedankt Shmoo. Ik zal maar denken dat het bedrijf deze dingen normaal niet overlaat aan klanten en dat de fout dus in mijn oude webpagina’s zit of in de broncode van iWeb zelf, waarvan de laatste versie toch dateert van 2011.

    Voor de volledigheid hier nog het bericht van Systray solutions:

    BELANGRIJKE UPDATE:
    Nieuwe PHP versie
    Beste,

    we willen u graag laten weten dat uw website nog een oude PHP-versie (PHP 5.x) gebruikt. Intussen is een nieuwe versie PHP 7.2 beschikbaar bij Systray Solutions op Plesk. We hadden u dan ook graag verzocht om de overgang te maken.

    Wat betekent dit voor u?
    U gebruikt nog steeds de verhouderde PHP versie voor uw site(s) dehofhouding.be. Voor die versie is er binnenkort helaas geen support meer, en bovendien kunnen er veiligheidsrisico’s ontstaan voor uw website indien u de versie toch verder zou blijven gebruiken.

    Daarom verzoeken we u om tegen eind januari 2019 de overgang te maken naar PHP 7.2. Indien u hiervoor zelf over onvoldoende kennis beschikt, kan u hiervoor altijd bij ons terecht. Stuur gerust een mailtje naar sales@systray.be en u kan een offerte ontvangen om de upgrade door Systray te laten uitvoeren.

    LET OP! Niet-geactualiseerde websites zullen na eind februari 2019 door Systray offline gehaald worden om de veiligheid van de andere klanten niet in gevaar te brengen.


    Bijdrager
    gipsman

    En bedankt ook pruus.


    Bijdrager
    Shmoo

    Maar gebruik je wel PHP in iWeb?

     

    Standaard zit geen PHP module in iWeb, dus als je zelf geen PHP-code van buitenaf in iWeb hebt gestopt dan gebruik je site niet eens PHP. Ik zie namelijk nergens een contactformulier of iets op de site waar ik van denk, dat komt via PHP tot stand. iWeb zelf maakt geen gebruik van PHP dus als je het gebruikt heb je het zelf of iemand anders aangebracht om extra functionaliteit (meer dynamische elementen) toe te voegen aan iWeb.

     

    Als je geen PHP gebruikt op je website dan kun je het gewoon installeren/upgraden en activeren zoals in mijn linkje staat.  Ik zou het wel extreem amateuristisch vinden van een hostingbedrijf als ze jou daar mee lastigvallen want het is allemaal nogal technisch qua termen. Dit zijn dingen die een hostingboer normaal gewoon op de achtergrond doet voor hun klanten. Steker nog, als je er voor moet betalen om het te laten doen dan zou ik eens gaan nadenken over een andere webhost. Dat komt op mij zelfs over al bewust misbruik maken van onwetenheid van je klanten.

     

     


    Bijdrager
    TheBigZ

    Hoi Jan, is dit niet een mooie aanleiding om je hele website eens flink op de schop te nemen, en op zoek te gaan naar een alternatief voor iWeb?

     

    Kijk bijvoorbeeld eens naar iets als Hugo:

    https://gohugo.io/getting-started/

     

    Mocht je vastlopen, er zijn hier voldoende mensen op het forum die je kunnen helpen. Levert misschien zowaar nog een aantal nuttige postings van Shmoo op!:-)

     


    Bijdrager
    nnsa

    PHP is doorgaans Provider georiënteerd en niet Webbuilder georiënteerd. Heeft dus feitelijk niets met iWeb te maken. Zelfde melding zou bij WordPress of RapidWeaver komen. Een update van PHP 5 naar PHP 7 is voor de Provider een fluitje van een cent, laat staan € 45,00.

    Als je naar PHP 7 gaat, zorg dan wel voor een backup van je site. Wat me intrigeert is wat Plex hier voor rol speelt. Dit is een Multimedia-server (of speler). Daarin zit geen instelling voor PHP (updaten). Of er moet een programma zijn met dezelfde naam, maar dat betwijfel ik ?


    Bijdrager
    TheBigZ

    nnsa op 3 januari 2019 om 14:51
    Wat me intrigeert is wat Plex hier voor rol speelt. Dit is een Multimedia-server (of speler). Daarin zit geen instelling voor PHP (updaten). Of er moet een programma zijn met dezelfde naam, maar dat betwijfel ik ?

    Dat was een typo.

    Plesk

     

    Zie de eerder gegeven link van Shmoo hoe je PHP versie kunt aanpassen in Plesk.


    Bijdrager
    McJohn

    Verwondert me dat je nog bij Systray zit, die mannen zijn méér down dan up na de overname. Normaal moet een hostingbedrijf dit soort dingen niet aan hun klant vragen.

    PS. Had destijds een goed contact met Systray en was er zelf 15 jaar klant, maar het geklungel van de nieuwe eigenaars heeft me doen besluiten te switchen naar ander hostingbedrijf. Lees maar op hun FB pagina na, die mannen doen werkelijk als tegen de regels van klantvriendelijkheid.


    Bijdrager
    gipsman

    Welbedankt voor alle suggesties. Ik zal eerst eens Plesk ( ja sorry  moest Plesk zijn, niet Plex) uitzoeken. Is ook wel betalend denk ik. Maar ooit moet het ophouden met iWeb en ik denk dat ik ga doen wat TheBigZ aangeeft, nl. iWeb loslaten ( en na Mojave werkt het misschien niet meer), maar ook wat Shmoo zegt: andere webhost.


    Bijdrager
    nnsa

    iWeb werkt ook nog in Mojave en er is een vervanger: EverWeb (eventueel).


    Bijdrager
    JoopJoopJoop

    Gewoon een andere hoster nemen, dit getuigt van een slechte partij, de mijne, Neostrada, loste dit gratis op zonder enige moeite voor mij.

    Laat je niet als melkkoe gebruiken…


    Bijdrager
    gipsman

    One more thing:

    Wat is de beste volgorde? Eerst hosting verhuizen ( nog steeds in iWeb of in nieuwe site), daarna domein verhuizen. Of andersom. Ofwel: domein laten staan bij Systray ( is €8) en enkel andere hosting zoeken?


    Bijdrager
    TheBigZ

    Ik zou eerst even die PHP versie in Plesk ophogen, dan ben je van dat gezeur van je hoster af.

     

     

    We willen u graag laten weten dat uw website nog een oude PHP-versie (PHP 5.x) gebruikt. Intussen is een nieuwe versie PHP 7.2 beschikbaar bij Systray Solutions op Plesk. We hadden u dan ook graag verzocht om de overgang te maken.

     

    Wat betekent dit voor u?
    U gebruikt nog steeds de verhouderde PHP versie voor uw site. Voor die versie is er binnenkort helaas geen support meer, en bovendien kunnen er veiligheidsrisico’s ontstaan voor uw website indien u de versie toch verder zou blijven gebruiken.

     

    Daarom verzoeken we u om tegen eind januari 2019 de overgang te maken naar PHP 7.2.


    Bijdrager
    gipsman

    Punt is dat er in control panel van de hosting geen PHP upgrade optie gegeven wordt.


    Moderator
    Night

    Dat is dan een vraag die je met dat mailtje retour kan sturen 😉


    Bijdrager
    Wyodor

    Voor wie het toch wil proberen, hier kan je lezen hoe je PHP in iWeb gebruikt :

    http://responsive.2kool4u.net/misc/iweb/


    Bijdrager
    TheBigZ

    Ik heb nog even in de broncode rondgekeken op jouw website, maar ik kan eigenlijk geen enkele pagina vinden die PHP gebruikt. De enige referentie naar PHP is een Facebook like.

     

     
     
    <iframe src="http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.dehofhouding.be%2F&amp;layout=standard&amp;show_faces=true&amp;width=450&amp;action=like&amp;font=verdana&amp;colorscheme=dark&amp;height=80" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:450px; height:80px;" allowTransparency="true"></iframe>
     
     

    Bijdrager
    gipsman

    Hm, die facebooklink moet ik dan weg zien te halen, ik gebruik trouwens al lang geen facebook meer. Ik moet Systray dan toch vragen waarom dit zo’n issue is. Maar ze reageren traag of gewoon niet op mails, en bellen kan al helemaal niet.

    Bedankt hoor TheBigZ om dit verder uit te spitten.


    Bijdrager
    McJohn

    @gipsman: Omdat Systray momenteel een bende knurften zijn, ze vroegen aan een klant van mij 45 euro als zij het moesten aanklikken in de Plesk software. Het is werkelijk 10 seconden werk.

    Dit is wat je moet doen:

    1) Je logt in op Plesk
    2) Om makkelijk te zijn tik je links boven net onder het systray logo in het zoekbalkje: “php”
    3) Dan zie je staan “PHP-ondersteuning (PHP-versie 5.x) en dat verander je naar 7.3.0
    4) Onderaan klik je op “OK”

    Om te kijken of je website effectief versie 7.x heeft, kan je een .php bestand aanmaken met volgende code:

    <?php
    echo PHP_VERSION;
    ?>

    dat bewaar je bv als test.php en upload je via je ftp software naar je hosting.

    vervolgens surf je dan naar: http://www.domeinnaam.be/test.php  waar je dan je versie nummer van je php ziet.


    Bijdrager
    Shmoo

    Dat laatste (testen) hoef je niet eens te doen. Als je 7.2 activeert en je drukt op OK dan kun je er wel vanuit gaan dat het binnen 15 minuten of zo zal functioneren. Mogelijk log je een dag later nog eens in om te kijken of versie 7.2 echt geactiveerd staat en versie 5 niet.

     

    Maar zoals al een aantal keer is aangeheven waarschijnlijk gebruikt hij niet eens PHP, hij weet niet eens wat het is, hoe het werkt dus ….. verder dan versie 5 deactiveren en versie 7 activeren moeten we hem daar niet mee lastigvallen. Laat hem vooral versie 7 activeren zodat dit hostingbedrijfje niet aan het einde van de maand zijn website weggooit. Zodra hij versie 7 heeft geactiveerd kan hij rustig gaan kijken hoe hij z’n nieuwe site wilt gaan opbouwen + hoogstwaarschijnlijk elders hosten dan bij deze blokhoofden.

     

    Mijn advies:

    https://www.netlify.com/


    Bijdrager
    gipsman

    Ik zal morgen om te beginnen even inloggen bij Plesk en dat proberen te fixen. Maar ik ben leraar Engels/tuinarchitect. De wereld zal zich verbazen als dit niet fout gaat. 🤗 Daarna bekijk ik de setup van Shmoo, die gelijk heeft dat ik geen benul van heb. Plan B is nieuwe site bij andere hosting en domein ook daar naartoe.

     


    Bijdrager
    gipsman

    Offtopic:  ik ben blij met de reacties. De laatste maanden dacht ik van: OMT komt tot stilstand, er zit geen leven meer in. Het is maar schijn, zelfs dummies als ik hebben nog ‘a place in the sun’.

24 berichten aan het bekijken - 1 tot 24 (van in totaal 24)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.