9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)
  • Q:
    Bijdrager
    gepeterd

    PHP mail() configureren voor localhost

    Hoi OMT,

    Weet iemand hoe je het voor elkaar krijgt om vanaf je localhost het mail() commando van php te gebruiken?
    De hits op google stammen allemaal uit 2003 of eerder en in mijn php.ini kan ik niet veel meer vinden dan:

    <br />
    [mail function]<br />
    ; For Win32 only.<br />
    ; http://php.net/smtp<br />
    SMTP = localhost<br />
    ; http://php.net/smtp-port<br />
    smtp_port = 25</p>
    <p>; For Win32 only.<br />
    ; http://php.net/sendmail-from<br />
    ;sendmail_from = [email protected]</p>
    <p>; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").<br />
    ; http://php.net/sendmail-path<br />
    ;sendmail_path = </p>
    <p>; Force the addition of the specified parameters to be passed as extra parameters<br />
    ; to the sendmail binary. These parameters will always replace the value of<br />
    ; the 5th parameter to mail(), even in safe mode.<br />
    ;mail.force_extra_parameters =</p>
    <p>; Add X-PHP-Originating-Script: that will include uid of the script followed by the filename<br />
    mail.add_x_header = On</p>
    <p>; Log all mail() calls including the full path of the script, line #, to address and headers<br />
    ;mail.log =<br />
     

    Bij voorbaat dank.

    Bijdrager
    KingAchille

    Je code is nogal een rommeltje:)

    Al eens gekeken op php.net? Probeer dit eens:

    <?php
    // The message
    $message = “Hier komt het berichtje dat je wil sturen”;

    // Send
    mail(‘[email protected]’, ‘Het Onderwerp’, $message);
    ?>

    => Daar de “code” knop van dit forum op niets trekt, zonder “code”.

    Bijdrager
    gepeterd

    De code die je ziet is gekopieerd uit de php.ini regel 1081 tot 1105. De configuratie van Mail. De regel begint dus met een ; om dat het uitgequote is ;).
    Het is dus geen php code voor het mail commando ;). Ik weet hoe het mail commando werkt, ik heb er een hoop verschillende live hangen. Alleen lokaal (op localhost ) werkt mail() niet. Dit omdat ik iets niet heb geconfigureerd.
    Mijn vraag is dan ook, wat moet ik instellen om het mailcommando lokaal te gebruiken. Dit krijg ik namelijk zelf niet gevonden.

    Inactief
    Anoniem

    Normaal heb je standaard postfix staan op je mac, je moet dit gewoon even aanzetten: http://www.freshblurbs.com/how-enable-local-smtp-postfix-os-x-leopard

    Of als je MAMP Pro draait, kan je dit gewoon doen bij de settings.

    Bijdrager
    gepeterd

    W0utR, bedankt voor je reactie. Ik heb de postfix aangezet. echter verstuurd php nog steeds geen mails. Dien ik nog meer in te stellen?
    Ik heb hetvolgende ingesteld in de php.ini:

    <br />
    [mail function]<br />
    ; For Win32 only.<br />
    ; http://php.net/smtp<br />
    SMTP = mail.planet.nl<br />
    ; http://php.net/smtp-port<br />
    smtp_port = 25</p>
    <p>; For Win32 only.<br />
    ; http://php.net/sendmail-from<br />
    ;sendmail_from = [email protected]</p>
    <p>; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").<br />
    ; http://php.net/sendmail-path<br />
    sendmail_path = sendmail -t -i<br />
     
    Bijdrager
    gepeterd

    waarom er <p> tagjes in staan, geen idee. Dat doet de OMT wysiwyg :thumbsdown:

    Bijdrager
    gepeterd

    Ook heb ik dingen geprobeerd als sendmail -t -i -f [email protected]<domeinnaam>.nl in de sendmail_path maar niets blijkt te werken.

    Bijdrager
    blacktoko

    Ik heb onderstaande pagina gevonden over hetzelfde probleem:
    http://roshanbh.com.np/2007/12/sending-e-mail-from-localhost-in-php-in-windows-environment.html

    Ze geven hier aan dat je voor je het email bericht kunt verzenden ook de headers moet definiëren via php:

    <br />
    $headers = ‘MIME-Version: 1.0? . “\r\n”;<br />
    $headers .= ‘Content-type: text/html; charset=iso-8859-1? . “\r\n”;<br />
    $headers .= ‘From: [email protected]’ . “\r\n”;<br />
    mail(“[email protected]”,”test subject”,”test body”,$headers);<br />
     

    Ik hoop dat dit je verder kan helpen:-) Succes!

    Bijdrager
    sjoerdl

    Heb je een mailservice draaien op je localhost?
    Want anders zou het logisch zijn dat het niet werkt.

9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.