5 berichten aan het bekijken - 1 tot 5 (van in totaal 5)
  • Q:

    Bijdrager
    Kstar

    Perl script geeft steeds “not authorized”

    Help! Wat ik ook doe, krijg ik mijn perl script niet aan de praat.

    Ik heb hem staan in Library/web server/cgi …/ Alles wat hij moet doen is “hello” zeggen. Of ik nou probeer als een user of als admin, maakt niet uit. Hij geeft ieder keer aan dat ik geen bevoegdheden hebt. Ik heb ook alles geprobeerd (dacht ik) wat rechten betreft, maar het lijkt allemaal niets uit te maken.

    Het lijkt geen probleem te zijn met het pad naar perl of het script zelf.

    Misschien iets in http.conf? maar wat? Of is er toch iets met de rechten aan de hand? Wat zou de rechten voor die mappen eigenlijk moeten zijn voor owner, group en de rest?


    Bijdrager
    traxlog

    Met Fetch kan je je eigen computer ftp-en, en de permissions op 755 zetten.

    host: 127.0.0.1
    directory: /Library/WebServer/CGI-Executables
    gebruik je admin inlog codes

    Ik neem aan dat je script UNIX line endings heeft en dat je Persoonlijk Webserver aan staat!

    traxlog
    http://www.protrax.nl


    Bijdrager
    Kstar
    ”traxlog”

    Met Fetch kan je je eigen computer ftp-en, en de permissions op 755 zetten.

    host: 127.0.0.1
    directory: /Library/WebServer/CGI-Executables
    gebruik je admin inlog codes

    Ik neem aan dat je script UNIX line endings heeft en dat je Persoonlijk Webserver aan staat!

    Nooit aan gedacht, mijn eigen computer te benaderen met fetch!

    Maar maakt het uit hoe de rechten van de mappen /Library/WebServer/CGI-Executables ingesteld zijn? Is er een setting waarbij alle gebruikers rechten hebben?

    Persoonlijk webserver staat aan, en de script is een kopie van wat ik verder altijd gebruik op mijn internet provider (ook UNIX dus).


    Bijdrager
    traxlog

    De map /Library/WebServer/CGI-Executables zal wel goed zijn qua rechten, maar je script hello.pl moet dan ook 755 zijn.
    Probeer up-te-loaden via Fetch naar je eigen computer toe. Dit regelt de “Finder” rechten.
    Dan zet de 755 op de script via Fetch.
    Over de UNIX line endings – het kan zijn dat je script “vertaald” wordt onderweg van de server, en nu Macintosh endings heeft.
    Ik raad BBedit aan voor textbewerking. Daarin kan je aangeven welke line endings je wilt gebruiken.
    Ik hoor het wel…!

    traxlog


    Bijdrager
    Kstar

    Dat was het. wat simpel!! Heel erg bedankt. You just made my day!

5 berichten aan het bekijken - 1 tot 5 (van in totaal 5)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.