7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)
  • Q:
    Bijdrager
    Demon Hunter

    Pagina 2 WordPress blog geeft 404

    Beste OMT-ers,

    Hoop dat iemand hier mij met dit probleem kan helpen, mijn expertise ligt niet helemaal bij webontwikkeling;) Ik heb mijn bedrijfswebsite al tijden draaien op WordPress. Werkt heel prettig, lekker snel en simpel een goed uitziende filmblog. Enkele maanden geleden heb ik een restyle gedaan, waar ik erg tevreden over ben. Sinds enkele weken/dagen heb ik echter een probleem met mijn website. Als je bij recente films op de homepage op pagina 2, 3 of op volgende klikt krijg ik een 404 pagina. De info is er echter wel, want als ik instel dat er meer entries te zien zijn op de pagina zie ik de films. Ik gebruik het thema Premiere van WooThemes. Deze heb ik opnieuw geinstalleerd, maar dat mocht niet baten. Ik heb wat onderzoek gedaan en het lijkt mij aan de permalinks te liggen. Ik gebruik de /%postname%/ permalink voor mijn posts/pagina’s. Dit werkte tot voor kort prima. Ik kom echter dit probleem meer tegen op Google, maar de genoemde oplossingen werken bij mij echter niet en zijn vaak veelal voor oudere versies van WP. Weet iemand hoe ik dit kan oplossen?

    Bijdrager
    flyerking

    Ik zou eens iets proberen met je .htacces file, bij hostnet is dit iig altijd het probleem geweest bij mij.

    Ik zou proberen ff in te loggen op je control panel en de .htacces syncen

    Bijdrager
    Shmoo

    Een vraagje, voordat je gaat inloggen bij je host wat volgens mij niets gaat uitmaken omdat het eerder wel heeft gewerkt.

    Waarschijnlijk heb jij in deze periode ook een update gedaan van WP van 3.4.0 naar 3.4.1 want dit probleem is vaker gemeld in de tijd dat 3.4.1 uitkwam.

    De oplossing!

    Inloggen in je WP Dashboard
    Settings > Permalinks > Kies de default setting > Save > Kies daarna weer je oude setting > Save

    Waarschijnlijk is het probleem nu opgelost mits er niet bovenaan de Permalinks pagina een foutmelding staat.

    Bijdrager
    Demon Hunter

    Die permalink opnieuw save truuk had ik al gevonden maar mocht niet baten helaas. Zelfde gaat voor de htacces sync:(

    Bijdrager
    Shmoo

    Zijn alle pagina’s en blog posts 404 errors of alleen pagina’s of alleen blog posts?

    En als je even een nieuwe test pagina aanmaakt krijg je deze wel te zien of wordt dat ook een 404?

    Bijdrager
    Demon Hunter

    Alle pagina’s werken, behalve pagina’s 2 en 3 in het onderdeel Recente Films. Normale posts zijn in dit thema blogposts, die werken gewoon zoals het hoort. De hoofdposts zijn in dit thema Video Posts. Deze staan ook in het Recente Films onderdeel. Deze posts bestaan echter wel gewoon, want ik kan ze vinden door op categorie te zoeken bijv. Ze verschijnen ook als ik meer films in Recente Films toe laat. Het gaat echt specifiek om de extra pagina’s op het Recente Films onderdeel.

    Bijdrager
    Shmoo

    Ahaa ik was verkeerd aan het denken ik dacht dat het om ‘pagina’s’ ging die je zelf aangemaakt had maar het gaat om ‘ pagination ‘ dat is een menu.

    Dit probleem komt waarschijnlijk omdat je Thema niet up-to-date is.
    Je gebruikt nu 1.1.11

    Terwijl 1.1.12 de laatste is en ene major code clean-up heeft gehad.
    http://www.woothemes.com/changelogs/premiere/changelog.txt

    Dus update het thema even en het probleem zal weg zijn.

    Gebruik je btw een Gratis webhost? want je site is super traag.

7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.