30 berichten aan het bekijken - 1 tot 30 (van in totaal 33)
  • Q:
    Bijdrager
    TheBigZ

    [Opgelost] OMT Bug: Ouder nieuws niet te zien

    Als ik op de voorpagina klik op de “Toon Meer Nieuws” button, krijg ik dezelfde lijst te zien. Maw /page/2/ en verder doen het niet. (iPad)

     

    https://www.onemorething.nl/categorie/nieuws/page/2/

    • Dit onderwerp is gewijzigd 1 maand, 2 weken geleden door Night. Reden: Topic opgelost
    Bijdrager
    wullie

    Ook niet op de een iMac.

     

    Bijdrager
    hendrik ijzerbroot

    Als dat alles was. Ik erger mij aan een bug (treed niet altijd op) waarbij het invoerveld voor het plaatsen van een link in een reactie totaal verdwijnt.

    En als het verschijnt lijkt het op een willekeurige plek te zijn.

    Sleutelbeheerder
    Night

    @hendrik-ijzerbroot: Kun je daar een schermafbeelding van plaatsen? Deze kende ik (nog) niet.


    @TheBigZ
    : daar is inmiddels melding van gemaakt. Dit probleem hebben we in het verleden al eerder gehad. Alleen was toen alleen pagina  2 niet terug te vinden. Nu werkt niets meer.

    Bijdrager
    hendrik ijzerbroot

    Als ik dus een reactie aan het intypen ben, vervolgens tekst selecteer om daar een link aan toe te kennen verschijnt de ene keer dat kleine invoer venstertje zoals hier, maar ook geregeld helemaal niet. Als ik dan, door de pagina te scrollen, probeert te achterhalen waar het staat vind ik dus niets. Soms verschijnt het op rare plekken zoals b.v. voor de helft buiten beeld hetzij boven hetzij beneden.

    Het verschijnt dus op willekeurige plekken dus niet altijd op de plek als te zien in de afbeelding (wat ook een onlogische plek is).

    Het zou eigenlijk steeds met het pijltje onder de geselecteerde tekst moeten verschijnen maar dat gebeurd dus niet.

    Ik werk met Firefox maar daar ligt het niet aan aangezien het de ene keer goed gaat en de andere keer niet en ook omdat dit ooit goed gewerkt heeft.

     

    Bijdrager
    feek

    js

    Een boel JS errors!

    Sleutelbeheerder
    Night

    hendrik ijzerbroot op 7 augustus 2020 om 19:30

     

    Vreemd. Dit kan ik ik geen enkele browser (Safari, Safari TP, FireFox (78.2 én 79.0), Chrome Opera) reproduceren…

     

    Bijdrager
    hendrik ijzerbroot

    Zojuist klik ik op het link icoon en nu verschijnt het invoervenster haast buiten beeld. Zoals je ziet direct onder het adresveld van de browser terwijl het veld om het bericht in te voeren beneden staat. En soms zie ik het invoer venster helemaal niet. De versie van Firefox is 79.0 (up-to-date) maar ik heb er al langer last van dus.

     

     

    In Safari gaat het bij mij goed. Ik heb al eerder iets vreemds meegemaakt tussen OMT en Firefox en toen hielp een herstart bleek later maar dat helpt nu niet. Ik heb al eens vanwege een ander probleem (niet gerelateerd aan OMT) de cache geleegd en cookies gewist maar dit veranderde niets aan het probleem in kwestie.

    Sleutelbeheerder
    Night

    Welke versie macOS draai je?

    Bijdrager
    hendrik ijzerbroot

    High Sierra (dus 10.13.6) Werd geleverd op mijn nieuwe iMac. Vorige OS was Mavericks.

    Sleutelbeheerder
    Night

    Komt goed uit; ik testte het ook op een iMac met High Sierra (10.13.6) en zowel met versie 78.2 en 79.0 van FireFox.

     

    Toch moet ik helaas zeggen dat ik je probleem, zelfs na herhaaldelijk testen in diverse topics en met diverse vensters geopend, je probleem niet kan reproduceren.

    Bijdrager
    hendrik ijzerbroot

    Dan zal de oorzaak wel hier liggen al heb ik geen idee wat dan precies. Het heeft gewerkt ooit en ik weet niet meer precies wanneer het voor het eerst mis ging. Het komt en het gaat. Zolang het venster zichtbaar is kan ik natuurlijk de url plakken maar soms is het helemaal uit beeld en zie ik het dus nergens staan. In zo’n geval moet ik de url dus direct in het bericht plakken.

    Sleutelbeheerder
    Night

    Scheelt het als je je venster na op de URL button te hebben geklikt, verschaalt (breder, smaller, hoger, minder hoog)? Bij alle browsers die ik testte, verdween de URL balk, om daarna opnieuw – op de juiste plek – weer te voorschijn te komen.

    Bijdrager
    hendrik ijzerbroot

    Bij mij verdwijnt hij ook even als ik de afmetingen verandert maar hij blijft op de zelfde onjuiste plek zitten.

    Ik kom er ook zo juist achter dat de horizontale positie ongeveer overeenkomt met de positie van de geselecteerde tekst, maar verder blijft hij momenteel dus helemaal boven aan het venster staan.

    Sleutelbeheerder
    Night

    Doet het probleem zich nog steeds voor als je de volgende stappen uitvoert:

    1. Sluit FireFox af
    2. Ga naar ? → Library/Bibliotheek → Preferences/Voorkeuren
    3. Verplaats het bestand org.mozilla.firefox.plist naar de desktop
    4. Start FireFox opnieuw op
    Bijdrager
    hendrik ijzerbroot

    Maakte niets uit. Op dit moment gebeurt er het volgende:

    Het invoerveld voor de reactie staat in het midden van het venster, ik klik op het link icon en de inhoud schiet een stuk naar beneden zodat ik jou laatste bericht ziet staan en het invoerveld voor de reactie niet meer zichtbaar is (ik zie nog net de menubalk die er boven zit). Tegelijkertijd verscheen het invoerveld voor de URL helemaal niet. Is nergens te zien op de pagina. De afstand waarover de inhoud naar beneden schiet wordt beïnvloed door de verticale positie van de geselecteerde tekst. (De tekst zit zelf net steeds buiten beeld.)

     

    Ik ontdekte nog iets vreemds: Firefox maakte na herstarten géén nieuw pref bestand aan (in ieder geval niet op de plek van de verwijderde) en mijn voorkeuren leken het zelfde dus geen default instellingen. Dat is raar want het verwijderde pref bestand had een recente bewerkingsdatum (gisteren). Dus het wordt wel gebruikt maar waar is het dan gebleven want als het gebruikt wordt zou er nu een ‘verse’ moeten staan met default instellingen. Ik had Firefox zo ingesteld dat er b.v. geen automatische updates plaatsvonden terwijl dat juist één van de default instellingen is maar ik zie nog steeds mijn eigen instelling staan.

     

    Na wat zoeken zag ik dat het bestand “prefs.js” (staat in library / application support / Firefox / Profiles / wsg2crsg.default ) wel aangepast wordt op het moment dat je een voorkeur verandert. Maar daar blijf ik vanaf want ik heb slechte ervaringen met veranderen van de hier aanwezige data.

     

    Ik betwijfel overigens of voorkeuren iets te maken hebben met het verwerken van dit aspect op OMT.

    Sleutelbeheerder
    Night

    Je zou het bestand even kunnen verplaatsen en dan FireFox opnieuw opstarten. Als het probleem dan niet is opgelost, kan je hem altijd terugzetten.

    Bijdrager
    hendrik ijzerbroot

    Net gedaan, maakt ook niets uit.

    Sleutelbeheerder
    Night

    Vaag probleem ?

    Heb jij nog aparte plugins actief in FireFox?

    Bijdrager
    hendrik ijzerbroot

    Wat noem je apart? Maar zoals gezegd het heeft ooit gewerkt. Dit probleem heb ik nu ik geloof een jaar of zo maar precies weet ik dat niet meer.

    Ik heb de volgende extensies geïnstalleerd:

    addblock plus, download sound, Fire Find, FlagFox, Ghostery, Video Downloadhelper, Save to read, Zoom

    Verder geen extra plug-ins (alleen de meegeleverde die noodzakelijk zijn)

    Sleutelbeheerder
    Night

    @hendrik-ijzerbroot:

     

    Probeer het volgende eens:

    1. klik in FireFox op de drie lijntjes rechts bovenaan
    2. Kies voor ‘Help’
    3. Kies voor ‘Herstarten met uitgeschakelde add-ons’

    Kijk of het probleem zich nog steeds voordoet.

    Kijk verder ook eens of dit probleem zich op andere WordPress fora voordoet.
    Ik vermoed namelijk dat het eerder een probleem is van jouw Mac/macOS/FireFox en niet specifiek van de OMT website. In dat geval is het raadzamer er een nieuw topic van te maken in Mac Software → Mac Apps (Overige)

    Sleutelbeheerder
    Night

    @TheBigZ: Opgelost. Als het goed is werkt alles weer normaal.

    Bijdrager
    TheBigZ

    Helaas Night. Ik krijg een “Pagina niet gevonden” foutmelding (iPad).

     

    https://www.onemorething.nl/nieuws/page/2

     

     

    (Koekenbakkers zijn het….)

    Sleutelbeheerder
    Night

    @TheBigZ: Dat krijg je als je met twee mensen aan hetzelfde probleem werkt ? Het is nu in ieder geval weer in orde (net hoogstpersoonlijk zelf ff getest, verbeterd, en wederom gecontroleerd)

    Bijdrager
    TheBigZ

    Wat alleen nog ontbreekt, is op pagina 2 een button om naar pagina 3 te gaan, etc.

    Sleutelbeheerder
    Night

    Vreemd; die staat er bij mij gewoon hoor. (hij staat in iOS onder de forum topics). Ik ben het wel met je eens, hij had er beter boven kunnen staan.

     

    Bijdrager
    TheBigZ

    Verhip. Ik zie het.

     

    Inconsequent design.  Het is natuurlijk makkelijk om vanaf de zijlijn (zoals ik nu doe) dit soort commentaar te geven, maar van dit soort ontwerpfoutjes zou je verwachten dat die tijdens het reviewproces ontdekt en opgelost zouden worden alvorens ‘live’ te gaan.

    Bijdrager
    hendrik ijzerbroot

    Ik zie het zelfde als Night.

     

    Sites behoren natuurlijk uitvoerig getest te worden en niet alleen dat, ze behoren ook vlekkeloos te werken bij de belangrijkste browsers. (Bij voorkeur eigenlijk bij elke browser). De versie van het OS is daarbij niet van belang want als de browser onder een bepaald OS werkt is dat het uitgangspunt.

     

    Als je de ‘perikelen’ van de afgelopen jaren rond OMT vergelijkt met sites zoals de gerenommeerde nieuwssites of de Wikipedia etc. dan moddert OMT maar wat aan terwijl de rest draait als een tierelier.

    Sleutelbeheerder
    Night

    We zijn achter de schermen al druk bezig aan een nieuwe site ? Ik hoop samen met jullie van harte dat de GUI daarvan wel wat consequenter zal worden ?

     

    Bijdrager
    TheBigZ

30 berichten aan het bekijken - 1 tot 30 (van in totaal 33)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.