One More Thing » Community » Forum » Mac Software » Mac Apps (Apple) » Numbers formule vraag

Numbers formule vraag

Profielfoto van Ruud

Ruud op 09 september 2017 #

Beste Leden,

Ik wil het volgende bereiken met de formule:

Kolom: B1,B2,B3…t/m B220 bevat allemaal getallen oplopend van 1 t/m 94 dit zijn level nummers.
In Kolom A staan de gegevens die daarbij horen.

Nu wil een uitkomst van het aantal tussen B1 t/m B220, die uitkomst is gebaseerd van het variabele level dat ik invoer.
Ik heb een cel A225 (hier vul ik een waarde in van tussen de 1 t/m 94 of hoger
Ik heb een cel B225 hier moet een uitkomst verschijnen van het aantal producten die beschikbaar zijn bij het ingevoerde level in cel A225

Ben ik op level 45 dan heb ik een X aantal producten die ik kan maken of anders gezegd heb vrijgespeeld.
Ben ik op level 75 dan heb ik een X aantal producten die ik kan maken of anders gezegd heb vrijgespeeld.
De X is dus elke keer anders omdat het level anders is.

De formule moet dus ongeveer dit doen:
Wanneer ik een level invul in cel A225 dan moet er gekeken worden in kolom B1 t/m B220 hoe vaak het getal voorkomt dat gelijk of kleiner is dan A225, die uitkomst wil ik in Cel B225 laten zien.

Ik hoop dat jullie hier wijs uit kunnen worden.
Alvast bedankt voor de hulp,
Met vriendelijke groet,
Ruud

Profielfoto van Jakko Westerbeke

Jakko Westerbeke op 10 september 2017 #

Zoiets?

Profielfoto van Ruud

Ruud op 10 september 2017 #

Dit is super! Hier kan ik zeker mee aan de slag. Heel erg bedankt voor de hulp.
Met vriendelijke groet,
Ruud

[Update]

Beste,
Ik heb het nu werkend, ik wil alleen nog een toevoeging.
Achter elke level in kolom B is een waarde gekoppeld in kolom C.
Kan ik deze waarden op laten tellen van de cellen die voldoen aan het level?
B2 level 1 —— C2 aantal 24
B3 level 2 —— C3 aantal 10
B4 level 3 —— C4 aantal 12
B5 level 3 —— C5 aantal 12
B6 level 3 —— C6 aantal 8
B7 level 4 —— C7 aantal 6
Nu wil ik graag ook het aantal dat voldoet aan het level dat ik invoer.
Dus zoals de uitkomst bij level 3 dan heb ik 5 waarden die daaraan voldoen B2 t/m B6
Nu wil ik in de kolom ernaast het aantal dat ik ernaast heb gezet, in het voorbeeld 24+10+12+12+8 = 66
De waarde 66 wil ik naast de cel met het aantal dus in Cel C22 in het voorbeeld.
De bedoeling is om een overzicht te krijgen hoeveel ruimte ik nodig heb om het minimaal aantal producten die ik op dat level heb vrijgespeeld kwijt te kunnen.

Met vriendelijke groet,
Ruud

  • Deze reactie is gewijzigd 1 week, 4 dagen geleden door Profielfoto van Night Night. Reden: Onnodig quote-gebruik verwijderd
  • Deze reactie is gewijzigd 1 week, 4 dagen geleden door Profielfoto van Night Night. Reden: Posts gecombineerd
Profielfoto van Jakko Westerbeke

Jakko Westerbeke op 10 september 2017 #

Zet in kolom C in elke cel (behalve de kop- en voetcellen) de volgende formule:

=ALS(B≤A$22;B;””)

waarbij A$22 de cel is waarin je het gewenste level hebt staan. Hierdoor zal elke cel in kolom C de waarde in de cel er links naast weergeven, op voorwaarde dat die waarde gelijk is aan, of kleiner dan, het level dat je wilt zien.

Dan in de voetcel van kolom C:

=SOM(C)

Het resultaat is dan iets als:

Profielfoto van Ruud

Ruud op 11 september 2017 #

Bedankt Jakko Westerbeke!!

Het is gelukt, ik kan de info geven die ik wil.

Over dit topic

Gestart op 09 september 2017 door Ruud

Laatste reactie door Ruud

Je kunt alleen reageren met een gratis OMT account.
Heb je geen OMT account? Registreer je dan nu gratis!

Inloggen

 

of Wachtwoord resetten?