21 berichten aan het bekijken - 1 tot 21 (van in totaal 21)
  • Q:
    Bijdrager
    iSpons

    Mogelijkheden van persoonlijke webserver

    ik heb zonet ontdekt de “persoonlijke webserver” functie ontdekt 8) maar wat kun je er eigelijk mee? gewoon je webpagina’s naar de folder “sites” slepen en dat is het? hoe voorkom je dat er andere folders kunnen geopend worden en kun je ook een andere naam ipv ip en de huidige korte naam?

    alvast bedankt :D

    Bijdrager
    zakalwe
    ”iSpons”

    ik heb zonet ontdekt de “persoonlijke webserver” functie ontdekt 8) maar wat kun je er eigelijk mee?

    Euh, heel veel, in feite draait deze site op praktisch dezelfde webserver als “Personal Web Sharing” in het Sharing preference paneel (iets andere instellingen hoop ik).
    Je kan er dus websites mee hosten.:D

    ”iSpons”

    gewoon je webpagina’s naar de folder “sites” slepen en dat is het?

    Ja, maar je kan het ook in je ‘/Library/Webserver/Documents/’ folder gooien, die site vind je door ‘http://naamvanjemac.local.’ te typen.

    ”iSpons”

    hoe voorkom je dat er andere folders kunnen geopend worden

    Folders die zich in ‘Sites’ bevinden? Of bedoel je je andere folders in je home directory? De webserver zorgt ervoor dat men niet bij die laatste kan komen.

    ”iSpons”

    en kun je ook een andere naam ipv ip en de huidige korte naam?

    Zoals hierboven beschreven kan je ook een site direct aan je ip koppelen.
    Of bedoel je een eigen domein aan je mac koppelen?

    Bijdrager
    nebbio
    ”iSpons”

    wat kun je er eigelijk mee?

    Dit is wat je er mee kunt: hele websites hosten

    Begon voor mij in juni met dit artikel van Kevin Hemenway

    Ondertussen is http://mac.campusdetoren.be op mijn iMac (of http://campusdetoren.ath.cx:2003 ) verhuisd naar een linux-doos: http://www.campusdetoren.be ; een schoolwebsite/intranet in wording.

    Bijdrager
    iSpons

    Ik heb eens een test gedaan en eens rondgevraagd maar niemand raakt erop :( moet ik (behalve persoonlijke webserver) nog iets anders aanklikken of instellen?

    Bijdrager
    nebbio
    ”iSpons”

    niemand raakt erop

    Waarschijnlijk poort-probleem: telenet blokkeert poort 80 zodat de gewone klant geen webserver kan draaien.

    Configureer daarom apache zo dat ie luistert naar een andere poort dan 80 en stuur je vrienden en kennissen dan ook naar die poort. Cf. campusdetoren.ath.cx (dat is een dyndns.org domeinnaam), je moet daar nog :2003 aan toevoegen.

    Bijdrager
    Sixer

    Heb je een ADSL modem dat zelfstandig verbindt ? (Een routermodem)

    Zoja, zul je poort 80 moeten ‘mappen’ naar je Mac. Anders lopen buitenstaanders dood op je modem.

    Bijdrager
    Deskman

    Als je ADSL hebt en een vast IP-adres kun je via het intikken van dat ip-adres in een externe browser bij je site. Maar alleen het IP-adres verwijst naar een andere locatie op je harddisk:
    [code:1:d205c342ac]/Library/WebServer/Documents[/code:1:d205c342ac]
    Als je geen sites voor meerdere gebruikers wilt hosten dan is dit de beste plek.
    Wil je netjes via een domeinnaam op je server komen dan moet je kijken of je internetprovider zoiets ondersteunt (bij XS4all kun je aangeven dat leukenaam.xs4all.nl naar jouw IPadres doorgestuurd wordt) of je moet een domeinnaam registreren.

    Vergeet niet dat je wel toegang tot je computer moet geven via je internetmodem of router. Dat is overal anders…

    Wil je meer weten over simpele vormen van hosting en de verborgen talenten van je mac, kijk dan eens bij O’Reilly of bij afp548

    Een leuk boek kopen kan ook. Ik ben erg blij met macosx unleashed 1500 pagina’s leesplezier.

    Bijdrager
    iSpons

    Ik verbind via een Topcom adsl router via ethernet, via usb hangt er nog een xp aan
    hoe moet ik het instellen zodat mijn site via internet zichtbaar is?

    poort 80 moeten ‘mappen’ naar je Mac

    kan ik ook bestanden die ik wil doorsturen in de map sites zetten en kunnen andere het dan via daar downloaden?

    dus ik kan ofwel alle files en folders naar de map sites slepen ofwel naar /Library/Webserver/Documents/

    wat is het beste?

    bij de map sites wordt de url dan vb http://127.0.0.1/~kortenaam/
    en bij de map Webserver/documents gewoon het ip? vb http://127.0.0.1/ of http://computernaam.lan?/

    bij “Content Negotiation” worden dan automatisch alle webpagina’s vertaald ofzo? of moet je zelf alles vertalen?

    alvast bedankt

    Bijdrager
    2manydjs

    Als je ipadres iets van 127.0.0.1 is kan iemand anders daar inderdaad niets mee.
    Dit IP adres heb je van je router gekregen en “bestaat niet” op het internet.
    Je moet het ipadres waarmee je router op het internet komt aan andere mensen geven.
    Daarnaast moet je, zoals al vermeld, je router instellen zodat alles wat naar binnen wil komen op poort 80 (standaard voor web) naar jouw computer’s ipadres wordt verwezen.

    Ik zou beginnen met je routers handleiding!
    Succes!

    Bijdrager
    iSpons

    het ip-adres dat bij systeemvoorkeuren/netwerk staat, is dat het internet ip of dat van de modem?

    Bijdrager
    Deskman

    Kijk op http://www.privacy.net

    Daar kun je ook zien welke poorten er toegankelijk zijn.

    De configuratie van poorten zit grotendeels in je router. Die kun je ongetwijfeld via een webinterface besturen. Bij mijn Draytek is dat 192.168.1.1

    Probeer het eens

    Bijdrager
    iSpons

    Ik heb de pagina’s nog niet veranderd/verwijderd uit de map sites of webserver/documenten dus als iemand naar het ip zou gaan wat zouden ze dan te zien moeten krijgen?

    “Alles Werkt! De Apache Web Server is geinstalleerd op deze Web Site”

    of iets anders?

    Als ik mijn ip ingeef of computernaam.lan of computernaam.local kom ik altijd terecht op de “Alles Werkt! De Apache Web Server is geinstalleerd op deze Web Site” wat moet ik ingeven om tercht te komen op de voorbeeldpagina van apple zelf? (die er standaart al staat)

    Bijdrager
    Deskman

    Die Apachepagina wordt vanzelf overal neergezet, in je root en in je usermap. Het verschil kun je niet zien.

    Verander iets aan de pagina (de titel bijvoorbeeld) en e ziet welke pagina je opvraagt. Overigens kun je intern nooit doen wat extern gedaan wordt. Als jij intern je IPadres intikt betekent dat niet dat je daar van buiten af ook terecht komt omdat je aan deze zijde van de router (en firewall) zit.

    Maar probeer het eens met iemand die je kent. Laat ‘m je IP intikken en laat maar horen wat er van komt.

    Overigens is waar je heen verwijst allemaal aan te passen in de .config van apache. Maar lees daarvoor nou dat artikel bij O’Reilly.

    Bijdrager
    iSpons

    ik heb m’n modem al van poort 80 op poort 200 gezet maar er is nog steeds geen verandering

    kom ik altijd terecht op dit

    Forbidden
    You don’t have permission to access /~username/ on this server.
    Apache/1.3.27 Server at computernaam.lan Port 80

    Bijdrager
    Umbwungi

    iSpons,

    Als je je computers webserver benadert op http://computernaam.lan, dan vraag je een document op uit de map Library/WebServer/Documents/, zoals Deskman al aangaf. Je zou daar dus eens moeten rommelen met de index-pagina. Lees het hierboven genoemde artikel ook eens door, en de bijbehorende andere pagina’s. Hierin staat een korte introductie in het configureren van Apache. Het is geen leuk werk, maar wel degelijk de moeite waard.

    De “no-access” fout klinkt als een 403-fout, wat zou kunnen betekenen dat er geen index.html in de map ~username staat. En dat maakt ook niet uit als je http://computernaam.lan bezoekt…

    Focus je het liefst op één map tegelijk en ga eens lekker aan de rommel met BBEdit en de config-bestanden.

    Bijdrager
    dennis

    ik heb m’n modem al van poort 80 op poort 200 gezet maar er is nog steeds geen verandering

    kom ik altijd terecht op dit

    Forbidden
    You don’t have permission to access /~username/ on this server.
    Apache/1.3.27 Server at computernaam.lan Port 80

    Ik heb me nog niet zo verdiept in webservers enz. maar volgens mij moet je erg uitkijken met de /
    Bijv. /~username dan kan ie em niet vinden maar met /~username/ wel.
    Ik kreeg m’n persoonlijke webserver eerst ook niet aan de gang, maar dit was toen het probleem.

    Anyway,:) misschien heb je niet de goede link?
    (Als je geen vast IP hebt dan veranderd de link van je persoonlijker webserver)
    Kijk in de systeemvoorkeuren bij “Delen”.
    Daar heb je de persoonlijke webserver aangezet als het goed is.
    Je ziet nu twee links (bijv. bij mij is dit nu) : http://c2eec182c.cable.wanadoo.nl/~dvanveen/ en http://c2eec182c.cable.wanadoo.nl/ .

    Bij de eerste kan je de bestanden zien (en delen) uit de map Sites in je thuismap. Bij de ander zie je jouw website, als Apache werkt zie je er staan : “Alles Werkt! De Apache Web Server is geinstalleerd op deze Web Site”.

    Zelf heb ik nog niet zoveel ervaring met persoonlijke webservers, maar als het goed is moet alles zo werken:)

    Greetz Dennis

    P.S. ik heb de links van mijn voorbeeld veranderd, vandaar dat ze niet werken;)

    Bijdrager
    iSpons

    ik heb de files uit de bib/webserver/documents verwijderd en m’n eigen index ingezete, via het ip is het nu bereikbaar, enkel moet de modem nog een nieuwe poort krijgen, is het eender welke poort?
    bij m’n firewall staan er dan 2 poorten (80 en 427) moet ik dan 427 nemen? of de firewall veranderen (als dat mogelijk is)

    Bijdrager
    Deskman

    http gaat standaard over poort 80, ftp over poort 21.

    Maar ik (we) blijven erbij: leest eens een stukje hierover op een van de aangegeven sites. Daar staat al deze info handzaam bij elkaar. Dat gaat dan met minder vallen en opstaan dan dit… En sneller!

    Bijdrager
    iSpons

    Hm.. ik heb het al een aantal keer gelezen maar ik geraak er nog steeds niet uit
    bij samengebruik, persoonlijke webserver, onderin komen dan 2 URL’s
    http://isynth.lan/ en http://isynth.lan/~kortenaam/
    bij http://isynth.lan/ krijg ik de pagina uit webserver/documents
    http://isynth.lan/~kortenaam/ krijg ik

    Forbidden
    You don’t have permission to access /~kevintack/ on this server.
    Apache/1.3.27 Server at isynth.lan Port 80

    bij gewoon ip (http://192.168.1.2/) krijg ik terug de pagina uit de lib/webserver/documents
    ip met kortenaam zelfde error :s

    moet ik bij een van de 2 de pagina uit de sites folder te zien krijgen? met de pagina van apple “Uw website hier.”? (zoals beschreven bij Kevin Hemenway )

    you can access your personal web site by opening any web browser on the local network and typing http://127.0.0.1/~morbus/

    Aangezien ik dan toch enkel de pagina in de webserver/documents (root?) te zien krijg zal ik mijn poort ook moeten aanpassen zoals bij de apache core features beschreven staat

    If you cannot use port 80, choose any other unused port. Non-root users will have to choose a port number higher than 1023, such as 8000.

    dus als ik de de pagina’s in de webserver/documents wil zichtbaar maken moet ik dus een poort kiezen onder de 1023? en hoe weet je welke poort al dan niet vrij is

    sorry dat ik iedereen hier mee BLIJF lastig vallen :(

    Bijdrager
    Deskman

    Het moet toch eens aan het werk kunnen zou je denken…

    isynth is de naam van je computer??
    Probeer dan eens http://isynth.local/ en http://isynth.local/~kortenaam/

    Je moet hetzelfde krijgen via http://127.0.0.1/~kortenaam/
    127.x.x.x etc is altijd het IPadres van de webserver die je op je eigen Mac draait, dus niet over het netwerk benaderd word.

    192.168.x.x is je IPadres aan jouw kant van het netwerk. Dat is met een andere computer in hetzelfde netwerk te benaderen. Dit heeft ook niet met de open poorten op je router te maken, eventueel wel met je firewall instellingen.

    Tenslotte heb je nog het vaste IPadres dat je van je provider hebt gekregen en waarmee je van buiten je netwerk te bereiken bent. Wil je daar een domeinnaam aan hebben dan moet die bij je provider in de DNS worden opgenomen. Meestal krijg je een naam als htp://loginnaam.provider.be/ die je kunt laten doorverwijzen naar de webspace op hun server of je eigen server.

    Als isynth de naam van je router is werkt het niet. Je krijgt je locale IP van je router. Dat is denk ik wel op te lossen maar het heeft niet zoveel zin.

    Als je van buitenaf jouw vaste IPadres intikt maak je verbinding met je router, die moet het verzoek voor dat adres doorsturen naar een webserver in je netwerk, dus die moet weten waar het de webserver moet zoeken. Die instellingen moet je in je router/modem doen. (In de gebruiksaanwijzing te vinden) In je apache configfile zitten de verwijzingen naar je user-mappen. Dat gaat allemaal automatisch.

    Dus vertel maar wat je hier en daar te zien krijgt…

    Bijdrager
    iSpons

    Ja iSynth is de naam van de computer

    Probeer dan eens http://isynth.local/

    Krijg ik de “alles werkt” pagina (ik heb die in lib/webserver/documents vervangen dus het is een andere folder)

    http://isynth.local/~kortenaam/

    krijg ik de “Not Found” pagina

    http://127.0.0.1/~kortenaam/

    ook not found pagina

    ik stel m’n modem in via m’n webbrowser daar staat er wel

    DNS Relay
    The DNS Relay is currently enabled. Relaying to:
    195.238.2.21
    (primary DNS from remote server)
    195.238.2.22
    (secondary DNS from remote server)

    kan ik daar iets mee?
    (heb al geprobeert voor /~kortenaam enz maar ze vinden niets :( )

21 berichten aan het bekijken - 1 tot 21 (van in totaal 21)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.