26 berichten aan het bekijken - 1 tot 26 (van in totaal 26)
  • Q:
    Bijdrager
    Josha_R

    Mijn project trilt na exporteren

    Beste leden van het forum.

    ik zit met het volgende. Ondanks het stabiliseren van mijn projecten in iMovie trillen deze ongehoord na het exporteren van het project. Echter ziet alles er tiptop uit bij het afspelen in iMovie. Zowel in de beeldweergave als in fullscreen mode.

    Een voorbeeld van het trillen na exporteren naar Vimeo kan je hier vinden:

    https://vimeo.com/69194565

    Op het apple forum krijg ik geen reactie op dit topic dus hopelijk zijn hier meer bekwame experts te vinden.

    Bvd!

    Bijdrager
    Qmagic

    Lijkt erop dat het originele video bestand van de camera niet goed gelezen wordt (beeld springt continu heen en terug) en het gaat daardoor fout bij de export.

    1e optie:
    Probeer eens video te optimaliseren. Hierbij wordt het video in de AIC codec omgezet.
    Archief -> optimaliseer video -> originele grootte

    2e optie:
    Probeer het ook eens door even de beeld-stabilistatie uitzetten. Misschien is daar ook iets fout gegaan in het renderen.

    3e optie:
    Indien dat niet werkt, even het originele video van de camera opnieuw importeren (en zet ook meteen optimaliseer video aan bij import).

    Bijdrager
    JBStudio

    Hallo Josha,

    Het enige wat ik kan bedenken: probeer het in een ander thema, is het dan ook? Check ook even de beeldopname i.s.m. project 24,25 of 30 bps?

    Dan los van je vraag, maar wilde ik even kwijt…. Doe er mee wat je wilt.
    Onwijs leuk idee om op deze manier jezelf te laten zien aan een toekomstige werkgever. Maar ik mis de ‘gevoelige snaar’. Je geeft na de intro aan dat je sportief ben, getrouwd enz…. Laat dat zien in je intro! Kleine shots van je dagelijkse ‘prive’ leven i.p.v. jezelf in een lift. Dat jij geknipt ben voor de baan zeggen ze allemaal, wat jou uniek maakt ben jezelf. Laat dat dan ook zien. Buiten dat zien ze gelijk dat je meer bent dan een man in een mooi pak en gladde praatjes.. een ‘family man’, sportief, sociaal enz enz..
    Is dus geen commentaar, maar meer een tip. Vind het namelijk persoonlijk een leuke en unieke manier om jezelf goed te laten zien!

    Succes!
    Groet,
    JBStudio

    Bijdrager
    Josha_R

    Hi JbStudio,

    Dank voor je reactie. Ander of geen thema geeft helaas geen verbetering in het afspelen. De beeldopname in bps helpt ook niet jammer genoeg. Hij geeft zelf ook aan dat er een verschil is in beeldsnelheid en of ik dit wel wil. Het is opgenomen in 25 bps en als ik hiervan afwijk trilt hij direct.

    Je feedback neem ik mee. Krijg er reeds leuke reacties op maar baal enorm dat het nog niet in goede kwaliteit is. Zodra ik het probleem begrijp en de oplossing weet ga ik waarschijnlijk een nieuwe Elevator Pitch (vandaar de lift) maken

    Bijdrager
    Fester


    /uploads/community/7087d35a0923ac3d7c8bc97547185e1851b90a2f_0.png

    al eens geprobeerd?
    Ik doe het tegenwoordig via quicktime, maak nog altijd een dvd project aan, bewaar de video op een aparte HD in 720 en 1080 en exporteer naar iTunes.
    Het trillen van jouw opnames heb ik nog nooit gezien in die mate, waar is je opname mee gemaakt? Een iPhone wil de beeldsnelheid afhankelijk van de belichting vari├źren.
    Heel leuke manier om een job te hunten.
    succes.

    Bijdrager
    Fester

    ( deze pic moest ook nog mee )

    Bijdrager
    Fester

    Stabilisatie zet ik eigenlijk pas aan wanneer nodig.
    Het beinvloed je beeldscherpte.
    Rollende sluiter? ( afhankelijk van je camera )

    Bijdrager
    Josha_R

    Beste Qmagic,

    Hartelijk dank voor je inhoudelijke suggesties. Ik ben ze een voor een nagelopen resultaat ervan vind je hieronder.

    1e optie
    ondanks dat ik het project in volledige-originele grootte heb ge├»mporteerd wordt mij vervolgens niet de mogelijkheid gegeven om het project te optimaliseren voor volledige-originele grootte. Deze optie is uitgegrijst. Ik kan alleen klikken op optimaliseren: Groot 960×540. Na het klikken hierop krijg ik geen tot weinig effect na exporteren project. De film blijft trillen en de kwaliteit is erg laag/korrelig.

    2e optie:
    Beeld-stabilisatie uit geeft in iMovie een prima weergave. Na export met quicktime als .mp4 is de kwaliteit wederom laag. Beelt trilt weliswaar stuk minder maar haalt het nog lang niet bij de weergave in iMovie

    3e optie:
    Originele video van de camera opnieuw geïmporteerd. Optie om de optimaliseren heb ik niet. Wel analyseren voor stabilisatie dus heb hiervoor gekozen. Na exporteren via quicktime .mp4. krijg ik wederom een lage kwaliteit en trillend beeld blijft..

    Met deze instellingen exporteer ik:
    – Deel met quicktime
    – bestandsstructuur: MP4
    – Videostructuur: MPEG-4 (basis)
    – Gegevenssnelheid: 64 kb
    – Geoptimaliseerd voor: downloaden
    – Grootte afb: 1920 x 1080 HD
    – Beeldsnelheid: 15
    – Compleet beeld: na elke 24 beelden
    – Audio: AAC-LC-muziek, stereo, 128 kbps, 44,100 kHz

    Bijdrager
    Qmagic

    Waarom niet via exporteer film? Dan staat alles meteen goed qua instellingen.

    Ik zie een paar vreemde instellingen bij jou:
    64 kb??
    15 frames per sec????
    Je origineel is 25 frames per sec en je exporteert 15 per sec. Dan mis je 10 frames per sec, dat ziet er nooit goed uit.

    Als je op deze wijze wilt exporteren moet je de volgende instellingen gebruiken.
    – Deel met quicktime
    – bestandsstructuur: MP4
    – Videostructuur: MPEG-4 (basis)
    – Gegevenssnelheid: 5000 kbps voor 720p en 8000 kbps voor 1080p
    – Geoptimaliseerd voor: downloaden
    – Grootte afb: origineel als project houden
    – Beeldsnelheid: 25 (gelijk houden aan je bronmateriaal/project instelling)
    – Compleet beeld: na elke 24 beelden
    – Audio: AAC-LC-muziek, stereo, 128 kbps, 44,100 kHz

    Bijdrager
    Josha_R

    Exporteer film heb ik ook gedaan. Maar het beeld blijft trillen. Snap er echt geen hout van.

    van de instellingen heb ik onvoldoende kennis om die correct aan te passen. Dus dank voor de duidelijke aanbevelingen tot aanpassing.

    Echter…het beeld blijft trillen.

    Mijn camcorder een samsung heb ik teruggezet naar fabrieksinstellingen en een nieuw kort filmpje gemaakt. Dit is wat ik heb gedaan:

    – Import voor stabilisatie
    – nieuw project zonder thema speelt prima af in imovie
    – export als film –> beeld trilt zowel in quicktime, als vlc als divx
    – export naar quicktime volgens de door jou aanbevolen instellingen –> beeld trilt zowel in quicktime, als vlc als divxplayer.

    Heb ook sterk het vermoeden dat een instelling verkeerd staat maar ben uit mijn opties..

    Bijdrager
    MacKevin11

    Ehhm, ik weet niet hoe je het oplost. Ik weet wel dat dit probleem soms ook optreed bij het bekijken van 480p video’s op YouTube. (zowel op Windows als op Mac en wel op verschillende machines). Het helpt over het algemeen om de kwaliteit te verhogen of te verlagen.
    Dit lost je probleem niet op natuurlijk, maar misschien dat het vergelijkbaar is en iemand nu een oplossing kan bedenken…

    Bijdrager
    Qmagic

    iMovie heeft blijkbaar een probleem met het verwerken van je videobestand van de camera. Om zeker te weten of dit het probleem is probeer het volgende eens:
    Importeer het video bestand in handbrake (www.handbrake.fr)
    Exporteer deze in handbrake (de standaard instelling van handbrake is goed). Het videobestand wordt opnieuw gerendeerd.
    Speel dit bestand eerst eens af om te kijken of het nog steeds goed eruit ziet.
    Importeer dit bestand in iMovie en kijk of het beeld dan nog steeds uit iMovie bibbert bij de export.

    Als het nu wel werkt weet je zeker dat iMovie een probleem heeft met de videobestanden uit de camera, anders zit de fout in iMovie.

    Bijdrager
    Fester

    Misschien het TL licht in de lift?
    De trillingen kunnen hierdoor veroorzaakt worden ( verschil in frequenties in de tl balk en in de opnamesnelheid van de camera? )

    Je haalt de film “groot” binnen en exporteert naar “HD” ???
    Beeldsnelheid in PAL is altijd 25 fps.

    Bijdrager
    Josha_R

    Bedankt voor de reacties.

    @Fester. Zou kunnen, maar zou dan niet verklaren dat een nieuw opgenomen filmpje hetzelfde doet:

    http://www.youtube.com/watch?v=JirINVKGhoU

    Ik haal ze als origineel binnen, samsung camera filmt op full hd kwaliteit.

    Bijdrager
    Josha_R

    @Qmagic:

    Handbrake draait z’n hand er niet voor om. Film gaat prima binnen via import. Standaard instelling Video Codec: H,264 (x264) heb ik laten staan. Film speelt prima af via ‘preview window’ van Handbrake.

    Na importeren in iMovie krijg ik direct een verkleind en trillerig beeld in de volledig beelweergave van iMovie.

    Na exporteren ‘als film’ krijg ik een redelijk goed en trilvrij resultaat
    Na exporteren ‘via quicktime’ krijg ik een redelijk goed en trilvrij resultaat
    Na exporteren ‘via youtube’ krijg ik een redelijk goed en trilvrij resultaat:

    http://www.youtube.com/watch?v=VZA8yFLs8Mo

    Bijdrager
    Qmagic

    De youtube linkjes werken overigens niet (priv├ę video).

    Het probleem zit niet in de camera, dus daar hoef je niet te zoeken, probleem zit in iMovie die een probleem met het video materiaal heeft.

    De reden waarom ik handbrake aangaf is omdat iMovie een probleem heeft met het videobestand bij de export.
    Handbrake renderd een nieuw video bestandje (en ja is in dezelfde codec H.264) om te testen of iMovie deze nieuwe file wel goed verwerkt t.o.v. de originele video.

    In de H.264 codec zitten namelijk nog een heleboel verschillende instellingen betreft de compressie methode. Het wordt misschien iets te technisch nu maar ik probeer het even uit te leggen. Een paar voorbeelden wat Apple gebruikt binnen Quicktime met de compressie bij 720p H.264: “High@L3.1 / 2 ref.frames” en bij 1080p H.264: “High@L4.0 / 5 ref.frames”. Het is dezelfde codec alleen anders gecomprimeerd.

    De camera gebruikt hierbij ook een bepaalde compressie instelling en waarschijnlijk heeft iMovie bij de export een klein probleem (bug) hierin. Als je in handbrake het bestand opnieuw renderd wordt dit veranderd en kan daarmee het probleem (bug) iMovie verholpen zijn.
    Dus stel (als voorbeeld) je camera neemt op in H.264: “Main@L3.0 / 3 ref.frames” en met handbrake wordt het dan “High@L3.1 / 2 ref.frames”.
    De kans is groot dat het dan in iMovie wel goed gaat.

    Playback en renderen kunnen beide verschillend uitpakken. De playback kan goed gaan, maar bij exporteren/renderen kunnen problemen voor doen (geluid dat niet meer sync loopt, beeld gaat klapperen, etc…)

    Ik heb in het verleden namelijk ook wel eens vergelijkbare frames-jumps gehad (niet zo heftig als bij jou) bij de export van een samsung camera bestandje in de montage. Was opgelost door eerst een export met handbrake (of mpegstreamclip) te maken. Daarna ging de export wel goed. Het is een extra render slag, maar loste het probleem wel op.

    Bijdrager
    Qmagic

    Wat mij net ook nog te binnen schoot.
    Het originele video bestand uit de samsung was interlaced. Deze is bij het exporteren in handbrake (of mpegstreamclip) omgezet met “de-interlaced” functie aangezet.

    Bijdrager
    Josha_R

    Youtube linkjes heb ik werkend gemaakt

    iMovie export is idd het probleem. Extra render via Handbrake is idd een oplossing. Wel tijdelijk wat mij betreft. Je ziet namelijk wel zogeheten ‘kamvorming’ optreden bij de gerenderde filmpjes via handbrake.

    Je laatste alinea heb ik iets meer jip en janneke uitleg voor nodig. Krijg via google wel een uitleg over ‘interlaced’ maar dat maakt het er voor mij niet duidelijker op.

    Zie je nog mogelijkheden tot een structurele oplossing? Kan ik iMovie zelf aanschrijven met dit probleem?

    Bijdrager
    Qmagic

    Suggesties en problemen met iMovie kan je melden bij Apple:
    http://www.apple.com/feedback/imovie.html

    Ik zal later vandaag even wat aanvullen in het verhaal, heb nu weinig tijd.

    Bijdrager
    Josha_R

    @Qmagic. Feedback heb ik zojuist doorgegeven via die link en ik wacht je aanvulling af.

    @Fester, ik zag dat ik op jou reactie nog niet had gereageerd. Bedankt voor het meedenken.
    De film wordt gemaakt met camcorder Samsung hmx-h200bp/edc

    – Rollende sluiter had ik nog niet geprobeerd. Blijkt helaas geen effect te hebben na de export.

    Bijdrager
    Qmagic

    Kleine uitleg:
    Rollende sluiter: bij het snel van links naar rechts (of andersom) bewegen komen objecten die filmt (bij gebouwen duidelijk te zien) schuin te staan in het beeld. Om dit probleem te corrigeren zit er een optie hiervoor in iMovie.
    Heeft dus niks met je huidige probleem te maken.

    Interlaced of Progressive:
    Interlaced: Dit is een opname techniek waarop het beeld weggeschreven wordt. Bij Interlaced wordt 1 frame eerst in oneven beeldlijnen en dan in even beeldlijnen weggeschreven. Deze worden weer samen gevoegd tot 1 plaatje bij het afspelen. Op deze wijze werken tv schermen (beeldbuis). Iedere tv speelt het de-interlaced af waardoor je geen strepen ziet, op een pc (afhankelijk van de software) kunnen deze beeldlijnen te zien zijn bij het afspelen.
    Alle HD camera’s nemen interlaced op (1080i25). Ook alle HD (en SD) tv uitzendingen van alle Nederlandse tv zenders zijn interlaced. (1080i of 576i)

    Progressive: hierbij wordt 1 frame als volledig beeld weggeschreven. Sommige camera’s hebben een extra opname functie om in 1080p50 op te nemen, echter kan iMovie de 1080p50 (1920×1080) niet importeren. Sommige camera’s nemen in 720p op, (1280×720) dit is altijd progressive (720p50).

    Jouw probleem:
    Helaas is dit voorlopig de enige (nood)oplossing tot dat er software update van iMovie uitkomt die dit probleem verhelpt.
    Je zult handbrake nodig hebben, of mpegstreamclip (met mpegstreamclip kan je ook eenvoudig via Batch optie direct naar AIC codec omzetten voor iMovie).

    De kamvorming die je ziet zijn waarschijnlijk de interlaced strepen. Door de-interlaced te gebruiken zie je deze niet meer.

    Bijdrager
    Josha_R

    Dank voor de heldere uitleg Qmagic. Als laatste; hoe gebruik ik de ‘de-interlaced’ functie of hoe activeer ik hem?

    Bijdrager
    Qmagic

    Handbrake:

    Picture Settings:
    Decomb: default

    Mpegstreamclip (naar AIC codec):

    Export to Quicktime
    Deinterlaced video aanklikken.

    Bijdrager
    Josha_R

    Een plaatje zeg meer dan….

    Bedankt zo ver

    Bijdrager
    TheBigZ

    Heb je al een keer geprobeerd om in 720p op te nemen? Heb je dan ook last van het probleem na exporteren uit iMovie?

    Bijdrager
    Josha_R

    Wauw, situatie EINDELIJK opgelost via Apple Support. Onderstaand het laatste bericht van de Apple support Sr. mdw die de stappen neerzet die mij tot de oplossing hebben geholpen:

    Het probleem lag hem dus op twee niveaus: Er waren wat problematische voorkeursbestanden die op hun beurt weer de projecten negatief hadden beïnvloed.
    Dit hebben we opgelost door de volgende bestanden en mappen te verwijderen:
    – ~/library/caches (na deze verwijdert te hebben moet u uitloggen en opnieuw inloggen)
    – ~/library/preferences/*imovie* (het sterretje (een zogenoemde wildcard) geeft aan dat alles wat ervoor en erna komt minder relevant is, als “imovie” er maar in staat)
    – ~/library/preferences/*iapps*
    – ~/library/application support/iMovie

    Dit wil overigens niet zeggen dat dit voor iedereen dit probleem oplost. Het probleem had in principe ook op systeem niveau en in de originele bronbestanden kunnen voorkomen. Dit hebben we uitgesloten door eerst een testgebruiker aan te maken. Dat gezegd hebbende zou deze informatie anderen inderdaad kunnen helpen.

26 berichten aan het bekijken - 1 tot 26 (van in totaal 26)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.