5 berichten aan het bekijken - 1 tot 5 (van in totaal 5)
  • Q:
    Bijdrager
    Jorg

    Langzame verbiding tussen Windows server en Macs – SMB?

    Hallo,

    Ik ben een redelijk “verse” switcher, en beschik over een iMac G5 en een Powerbook G4 1.3.

    Ik heb thuis een netwerkje gemaakt waarin een Windows XP Pro computer dienst doet als server voor foto’s, muziek en e-mail. De verbinding tussen deze server en de Macs is echter veeel (!) trager dan die van de server met de andere Windows PC’s. Het copyeren van 20 GB wordt berekend op zo’n 15 uur (!). Wanneer ik gebruik maak van de wifi-verbinding in beide Macs, dan is de tijd vreemdgenoeg iets korter, maar nog steeds vele uren. Het copyeren van dezelfde hoeveelheid data van de server naar een andere Windows PC is in een korte(re) tijd gepiept.

    Nu las ik op diverse sites en fora dat dit te maken heeft met het SMB-protocol, en de implementatie hiervan in OS X en Windows XP. Ik weet weinig van netwerkprotocollen, en nog minder van het fine-tunen hiervan in een van beide besturingssystemen, dus ik vroeg me af of 1 van jullie me misschien kan helpen?

    Hoe kan ik de transfersnelheid van data tussen een Windows computer en een Mac tot een acceptabel niveau brengen?

    (Ter referentie, ik vond eerder deze pagina’s, waar ik weinig wijs uit kan:
    http://forums.macosxhints.com/archive/index.php/t-4976.html
    http://www.macosxhints.com/article.php?story=20050304174918586&query=smb )

    Bedankt!

    Bijdrager
    duder

    Bij mij is het ook altijd baggertraag en ik meen me te herinneren dat het ermee te maken heeft dat de protocollen van windows gesloten zijn en de samba client dus nageaapt wordt .. ofzo… je moet er in ieder geval voor zorgen dat ze in dezelfde werkgroep staan!

    Anyway, ik gebruik een ftp server op mijn windows bak en dan gaat hij full speed. Misschien niet echt een geweldige oplossing, ik hou me dan ook aanbevolen voor een oplossing voor dit probleem!

    Bijdrager
    junkiesxl

    Je hebt de oplossingen al gevonden:)

    in the smb.conf file set this:
    socket options = IPTOS_LOWDELAY TCP_NODELAY

    en uitgebreider http://www.macosxhints.com/article.php?story=20040324053434397&query=smb+buffer

    Hoe doe je dit ? Dit valt ook nog reuze mee maar zal er even mee doorwandelen
    1. Kies vanuit je menubalk onder “Go”, “Go To Folder”, daar typ je dan /etc/
    2. Open TextEditor met root permissie (dit doe je door de Terminal te openen en daar het volgende commando in te pasten [code:1:6ba13b5178]sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit &[/code:1:6ba13b5178], als ie vraagt om je paswoord dit ingeven gevolgd door een return)
    3. Nu sleep je smb.conf (zit in de map /etc/) op TextEditor die zojuist geopend is
    4. Bij het stukje [global] voeg je deze tekst toe
    [code:1:6ba13b5178] read size = 1024
    socket options = TCP_NODELAY SO_KEEPALIVE SO_RCVBUF=2048 SO_SNDBUF=2048 IPTOS_LOWDELAY
    getwd cache = yes[/code:1:6ba13b5178]
    (let op: socket options is 1 regel)
    5. Bewaar het bestand
    6. Herstart je mac (je zou ook je SMB kunnen herstarten maar gewoon je mac is makkelijker)

    Je zou als je meer vertrouwd bent met de Terminal ook alles in de terminal kunnen doen (met bijv vi of pico) maar nu heb je ook meteen geleerd hoe je GUI-apps als root kunt openen, let wel op als root kun je serieuze schade aanrichten, dus sluit TextEdit nadat je je smb.cinf hebt aangepast.

    <edit> Even de let op regel in het vet gezet:) </edit>

    Bijdrager
    lowfi

    bij mij zegt ie dat me password een ongeldig commando is?:|

    tis toch gewoon me username pw? root pw weet ik namelijk niet?

    Bijdrager
    junkiesxl

    Is idd je gewoon paswoord (als je tenminste de hoofdgebruiker bent)

    maar probeer anders eens
    [code:1:6f055b6120]sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit[/code:1:6f055b6120]

    dus zonder de & werkt denk ik wel

5 berichten aan het bekijken - 1 tot 5 (van in totaal 5)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.