29 berichten aan het bekijken - 1 tot 29 (van in totaal 29)
  • Q:

    Bijdrager
    rzwart2

    Kom niet meer in WordPress site op localhost na veranderen domeinnaam

    Ik heb lokaal met MAMP een website lokaal aangemaakt. Nu wou ik de website migreren naar de server bij mijn webhoster en heb daarvoor de plugin “wordpress move” geïnstalleerd. De eerste opdracht was het veranderen van de domeinnaam van “localhost/fsh” naar “www.mijndomeinnaam.nl”. Dat heb ik gedaan met als gevolg dat ik niet meer in mijn dashboard kom van wordpress. Ga ik inloggen via wp-login.php dan krijg ik nu alleen nog de foutmelding Error establishing a database connection. Kortom ik kan geen stap vooruit of achteruit meer zetten. Of toch?? Alle hulp is welkom…….


    Bijdrager
    Shmoo

    Deactiveer de plugin door gewoon de naam te veranderen van de plugin folder :

    wp-content / plugins / [ wordpress move ] — veranderen in — wp-content / plugins / [ blablabla ]

    …en daarna voeg je dit toe aan je wp-config.php bestand.

     
    define( 'WP_HOME', 'http://example.com' );
    define( 'WP_SITEURL', 'http://example.com' );
     

    Bijdrager
    EagerB0bNerd

    En heb je wel een database en user aangemaakt bij je nieuwe webhoster?
    In je config.php vindt je ook de database instellingen (naam, user, wachtwoord) dat zou ik ook checken.


    Bijdrager
    rzwart2

    Dankjewel, ga ik proberen. Ik heb nog geen database bij mijn webhoster aangemaakt, omdat de site nog niet is gemigreerd. Het is nog steeds local en ik wil ‘m eerst local weer laten werken.


    Bijdrager
    rzwart2

    Shmoo, thnx…. Ik vraag me dan even af wat ik moet invullen om de site eerst weer lokaal te laten draaien. De plugin had ik nog niet verwijderd, maar de verandering in de wp-config.php heb ik al eens toegepast maar zonder resultaat. Ik had toen ingevuld

    define(‘siteurl’, ‘http://localhost/fsh’ );
    define(‘home’, ‘http://www.mijndomeinnaam.nl’ );

    Klopt dit en maakt het nog uit waar ik dit in de wp-config plaats?


    Bijdrager
    Shmoo

    Gewoon het adres dat je altijd gebruikt lokaal.

    http://localhost/ <– zoiets?

    Of had je WordPress misschien geïnstalleerd in een folder met een werknaam [ bedrijfsnaam ] dan wordt het:
    http://localhost/bedrijfsnaam

    Zowel define siteurl + define home zijn in 99% van de gevallen hetzelfde, dus twee keer hetzelfde invullen en nooit www er voor tenzij je dit handmatig ooit hebt aangepast in de server settings.


    Bijdrager
    rzwart2

    Ik kom zonder de wijzigingen in de wp-config nog wel in het inlogscherm van wordpress (na inloggen krijg ik een wit scherm). Als ik de wp-config wijzig met de define-opdrachten kom ik ook niet meer in het inlogscherm.


    Bijdrager
    rzwart2

    In de WPconfig lees ik de volgende database-instellingen. Die zijn eerder door MAMP zo aangemaakt (denk ik):

    define(‘DB_NAME’, ‘fsh-db’);

    /** MySQL database username */
    define(‘DB_USER’, ‘root’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘root’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    wachtwoorden e.d. zit ik niet in de wpconfig


    Bijdrager
    EagerB0bNerd

    “Ik heb nog geen database bij mijn webhoster aangemaakt, omdat de site nog niet is gemigreerd. Het is nog steeds local en ik wil ‘m eerst local weer laten werken.”

    Ah, ok,
    nu begrijp ik dat je er ook op je eigen computer er niet meer inkomt.
    Vraag is wat de plugin veranderd heeft.
    Wat heb je ingevuld op de settings page van die plugin?
    Dat moet je weer recht zien te breien

    Overigens (ik heb even op de pagina van die plugin gekeken) moet je de plugin ook op de webserver installeren.
    Verder zul je daar ook een database, user en password nodig hebben. Het heeft niet zoveel zin het migratieproces al (gedeeltelijk) te starten als dat niet in orde is.

    Je kunt die waardes overigens ook makkeijk terugzetten rechtstreeks in de DB zelf.
    Open je lokale DB met PHP myadmin.
    Onder wp options vind je de site URL en het home adres


    Bijdrager
    rzwart2

    Dank weer voor het meedenken Bob.

    Ik was de tutorial van de maker van de plugin aan het toepassen, echt de eerste stap die je in dit filmpje bij 1.10 ziet. Dus alleen de domeinnaam is veranderd, maar daarmee wellicht veel meer.


    Bijdrager
    EagerB0bNerd

    define(‘DB_NAME’, ‘fsh-db’);

    /** MySQL database username */
    define(‘DB_USER’, ‘root’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ‘root’);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    Dat lijkt me goed, MAMP gebruikt standaard “root” als db user en password


    Bijdrager
    EagerB0bNerd

    Dus alleen de domeinnaam is veranderd, maar daarmee wellicht veel meer.

    vraag is wat die plugin doet. Verandert hij die domeinnaam in de DB op het moment van migratie, of is het ook veranderd in je lokale DB (lijkt me niet logisch maar zou kunnen en kun je eenvoudig checken, zie mijn post hierboven)


    Bijdrager
    Shmoo

    Verwijder eens in de browser de cache bestanden en het cookie van het domein localhost.

    Cookie verwijderen.

    Zo ziet de wp-config.php bij mij uit.

    Het is belangrijk dat die define urls kloppen de rest zoals database name, wachtwoord en dat soort dingen die zullen niet snel aangepast worden door iets of iemand.
    In mijn MAMP installatie heb ik een eigen localhost url ingesteld en WordPress geïnstalleerd in een sub-folder omdat ik meerdere WP websites op mijn computer heb staan.

    Maar zoals hierboven zou het moeten werken wanneer je die ‘wordpress move’ plugin hebt gedeactiveerd of verplaatst naar de prullenmand.


    Bijdrager
    rzwart2

    Wat een hulp:-)

    Waar kan ik PHP myadmin vinden Bob?


    Bijdrager
    rzwart2

    Cookies verwijderd, maar zonder resultaat: na inloggen nog steeds een wit scherm


    Bijdrager
    EagerB0bNerd

    Waar kan ik PHP myadmin vinden Bob?

    Ik gebruik geen MAMP, maar staat er op het MAMP beginscherm geen link naar PHP admin?


    Bijdrager
    rzwart2

    MAMP comes with MySQL which is the most commonly used relational database system. There is a MySQL interface for nearly every programming and scripting language available. Thanks to MAMP you can easily develop complex MySQL database applications on your local PC and upload them afterwards on to your live system. For easy configuration MAMP PRO comes with phpMyAdmin and Sequel Pro (Mac).

    MAMP pro dus wel, heb ik niet, met MAMP kom niet meer in dat instellingenscherm. Maar, zal het nog eens proberen.


    Bijdrager
    rzwart2

    Gevonden:

    MySQL
    User Host Type Privileges Grant Action
    root localhost global ALL PRIVILEGES Yes Edit Privileges Edit Privileges

    Users having access to “fsh-db”
    User Host Type Privileges Grant Action
    root localhost global ALL PRIVILEGES Yes Edit Privileges Edit Privileges

    Dat ziet er toch hetzelfde uit lijkt me…..


    Bijdrager
    rzwart2

    Misschien vraag ik veel, maar is het handig om met teamviewer even mee te kijken Bob of Shmoo?


    Bijdrager
    EagerB0bNerd

    mmmh, vreemd verhaal

    bij mij is het: http://localhost/phpmyadmin/

    kan zijn dat het bij jou is;

    http://localhost:8888/phpMyAdmin/

    met MAMP kom niet meer in dat instellingenscherm

    zoiets:

    http://localhost:MAMP

    ???

    afhankelijk van wat je in MAMP hebt ingesteld.

    Anders moet iemand anders je even helpen, die zelf ook MAMP gebruikt


    Bijdrager
    EagerB0bNerd

    Misschien vraag ik veel, maar is het handig om met teamviewer even mee te kijken Bo

    Ik heb hier Teamviewer, hoe ging dat ook alweer?


    Bijdrager
    rzwart2

    Teamviewer is een app die je kunt installeren en dan geef je codes aan elkaar door.

    Tegelijk kun je ook skypen, mijn skype account is rzwart2


    Bijdrager
    rzwart2

    via skype geen ik mijn id en ww door en heb je toegang tot mijn mac


    Bijdrager
    EagerB0bNerd

    Als het vanavond niet gelukt is kunnen we TV even proberen, moet er nu vandoor.


    Bijdrager
    rzwart2

    ok thnx, ik blijf in de tussentijd dus openstaan voor andere tips….


    Bijdrager
    EagerB0bNerd

    OK.

    Nog even snel:

    Ik kom zonder de wijzigingen in de wp-config nog wel in het inlogscherm van wordpress (na inloggen krijg ik een wit scherm). Als ik de wp-config wijzig met de define-opdrachten kom ik ook niet meer in het inlogscherm.

    Zou toch goed kunnen dat de fout in je home en siteurl zit.
    Als je nu niet in die DB komt, zou het denkik ook moeten lukken door dat te definieren in wp-confif, zoals Shmoo schrijft.
    Weet je zeker dat je de goede adressen invult? Kijk anders in je historie voor het goede adres


    Bijdrager
    rzwart2

    Ik kom wel in DB via Myphp, maar weet niet de home en site url daar terug te vinden. Ik ga nog ff kijken.


    Bijdrager
    rzwart2

    Yes, in Myphp siteurl en home aangepast naar local/fsh en ik kan weer in mijn dashboard. Thnx heren. Nu nog de migratie maar dat is weer een ander Topic (hoewel ik hoop dat dit niet nodig hoeft te zijn).


    Bijdrager
    EagerB0bNerd

    OK, goed dat het gelukt is.
    Migratie moet wel lukken, die plugin zal op zich best werken.
    Verder weet je nou hoe je in de DB kan, dan kan je problemen voortaan makkelijk oplossen.

    succes!

29 berichten aan het bekijken - 1 tot 29 (van in totaal 29)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.