13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)
  • Q:
    Bijdrager
    HSL

    Java update verwijderen?

    Ik kreeg afgelopen week een java update in mijn sorftware update binnen, dus ik heb die vrolijk geinstalleerd.
    Nu probeer ik een programma te runnen, maar die zegt dat hij niet loopt op java 1.5, en heeft 1.3.1 nodig (voor de update liep dit programmatje vlekkenloos).
    Weet iemand hoe ik de nieuwe versie weer kan vervangen voor de oudere zodat ik dit programmatje kan blijven gebruiken zolang ik het nodig heb (wat niet eeuwig gaat zijn hoop ik).
    Bij voorbaat dank.

    Bijdrager
    iJoost

    Als je even kijkt in Systeem > Bibliotheek > Frameworks > JavaVM.framework > Versions dan zie je welke versies er zijn. Die kun je allemaal door elkaar gebruiken. Ik denk dat je beter even contact kunt opnemen met de maker van dat programma.

    Bijdrager
    themacs

    Ik had hetzelfde probleem nog deze week.
    Heb dit kunnen verhelpen door in ‘Java Preferences’ (onder Applications/Utilities/Java) de oudere Java versie prioritair te zetten (naar boven slepen in de lijst van Java versies).

    Misschien helpt het bij jou ook.

    Bijdrager
    iJoost

    Maar dan krijg je die oude versie voor alle Java-programma’s.
    Lijkt me niet dat je dat wilt.

    Bijdrager
    HSL

    Okay bedankt.
    Ik kan dus gewoon tijdelijk (op de momenten dat ik dat eerder genoemde programmatje wil gebruiken) de oudere versie van Java gebruiken door in het lijstje naar boven te slepen?
    Als ik dan klaar ben kan ik weer herstellen naar standaard instellingen en zou alles weer up to date moeten zijn dus?
    Klinkt al een goede oplossing sinds dit programma maar tijdelijk gebruikt gaat worden.
    Ik ga niet de programma eigenaar benaderen gezien ik dit niet geheel legaal gebruik (volgens mij).
    Ik ga het vanavond proberen en laat wel weten of het lukt.
    In ieder geval bedankt alvast voor alle nuttige info weer.

    Bijdrager
    HSL

    Het is helaas niet gelukt.
    In het lijstje van Java staan vier opties;
    J2SE 5.0 32-bit
    Java SE 6 64-bit
    J2SE 5.0 64-bit
    J2SE 1.4.2 32-bit
    Het programma vraagt nog steeds om Java 1.3.1
    En vlak voor de laatste Java update deed het programma het nog prima…
    Iemand enig idee?

    Bijdrager
    Pieterr

    Heb je geprobeerd om 1.4.2 bovenaan te zetten dmv “slepen”? Die staat momenteel namelijk onderaan in jouw lijstje.

    Er zijn overigens aparte lijstjes voor Java applets en Java applications. Java applets worden in webpagina’s gebruikt. Jij moet waarschijnlijk in het lijstje van applications zijn.

    Bijdrager
    hendrik ijzerbroot

    Artikel in macfixit over problemen na de Java update

    Bijdrager
    HSL

    Ja ik had in beide lijstjes de 1.4.2 bovenaan gezet maar dat mocht niet baten.
    Kan ik niet ergens die oude 1.3.1 downloaden en zorgen dat die ook in dat lijstje terecht komt?

    Bijdrager
    iJoost

    Die is uit 2000. Maar als je dat graag wilt… gemakkelijk genoeg aan te komen.

    http://www.google.nl/search?q=java+1.3.1

    Bijdrager
    Pieterr

    Staat er bij de Java applicatie die je probeert te draaien nog een Info.plist file? Hierin kan namelijk gespecificeerd worden (middels de JVMVersion key) met welke Java versie(s) de applicatie werkt. Als er geen sterretje of plusje bij de versie staat, zal er dus altijd precies om die specifieke versie gevraagd worden.

    Ik heb gekeken welke versies ik allemaal op mijn systeem heb staan:
    [code:1:355b69b4b9]$ pwd
    /System/Library/Frameworks/JavaVM.framework/Versions
    $ ls -l
    total 56
    lrwxr-xr-x 1 root wheel 5 Sep 26 10:34 1.3 -> 1.3.1
    drwxr-xr-x 3 root wheel 102 Jan 14 2008 1.3.1
    lrwxr-xr-x 1 root wheel 5 Sep 26 10:34 1.4 -> 1.4.2
    lrwxr-xr-x 1 root wheel 3 Jun 15 13:08 1.4.1 -> 1.4
    drwxr-xr-x 8 root wheel 272 Mar 3 2008 1.4.2
    lrwxr-xr-x 1 root wheel 5 Sep 26 10:34 1.5 -> 1.5.0
    drwxr-xr-x 8 root wheel 272 Mar 3 2008 1.5.0
    lrwxr-xr-x 1 root wheel 5 Sep 26 10:34 1.6 -> 1.6.0
    drwxr-xr-x 8 root wheel 272 Jun 15 13:08 1.6.0
    drwxr-xr-x 8 root wheel 272 Sep 26 10:34 A
    lrwxr-xr-x 1 root wheel 1 Sep 26 10:34 Current -> A
    lrwxr-xr-x 1 root wheel 3 Sep 26 10:34 CurrentJDK -> 1.5[/code:1:355b69b4b9]

    Tot mijn verbazing blijk ik 1.3.1 dus ook op mijn systeem te hebben staan, ondanks dat die niet in het preferences lijstje is te vinden!

    Bijdrager
    RB4299

    Ik heb niet zo een map met Java….

13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.