11 berichten aan het bekijken - 1 tot 11 (van in totaal 11)
  • Q:

    Bijdrager
    stefanhendriks

    Java source code in Eclipse?

    Hey,

    Ik ben al een tijd aan het leren voor mijn Java Certified Programmer Exam. Ben vandaag gezakt, dus ik moet wel weer aan de bak.

    Hoe dan ook, ik draai Eclipse op een Windows machine en op mijn Macbook. Beiden gebruiken vresie 5.

    Op Windows kan je “attach source” doen, zodat je F3 op een methode kan doen die van de JDK is, en deze bekijken, wat ik soms handig vind. Dit gaat op Windows zonder problemen, ik zoek de src op en voila.

    Op OS X gaat dit niet zo lekker, ik weet Java wel te vinden in mijn Bibliotheek/Java/… maar geen source. De vraag is, hoe kan ik dit koppelen? Ik ontbreek vast iets, want volgens mij wordt Java niet ‘compleet’ aangeleverd met bron zoals je kan downloaden(?). Als ik een versie dan download, vraag ik mij af of dit wel goed gaat samen , en dat ik niet mijn huidige Java setup vernaggel. Dit is het laatste wat ik kan gebruiken natuurlijk.

    Bedankt voor de hulp alvast!

    EDIT:
    Ik vind in deze directory wel e.a. aan info :
    cd /System/Library/Frameworks/JavaVM.framework/Versions/*

    maar voor versie 1.5.0 geen src.jar. Ik vind wel een src.jar voor 1.3.1 , maar dat is een te sterk verouderde versie.


    Bijdrager
    iJoost

    Als ik me goed herinner wordt Java gedistribueerd in twee vormen als run time environment en als development kit. Je zou dan natuurlijk de laatste variant moeten hebben. Je kunt meerdere versies naast elkaar hebben en als je de development kit van een bepaalde versie installeert dan zit daar de run time environment van die versie bij in. Helpt dat? (Zou je zelf eigenlijk ook geleerd moeten hebben, toch?;-)


    Bijdrager
    IT2Be

    Hmm, dat weet ik ook iet.

    Ik weet wel dat de info van iJoost fout is. Op de Mac wordt de SDK standaard geinstalleerd.


    Bijdrager
    stefanhendriks

    haha. Dat is waar. Nou ja, in het exam leer je niet hoe je de boel installeert, alleen hoe je het moet gebruiken.

    Hoe dan ook. Ik vond een andere topic en daar stond dat je jezelf kan aanmelden bij Apple (developers). Daar download ik nu de laatste Versie 5 JDK op. Inderdaad, de Development Kit, want dat bevat de source.

    Ik heb ook geprobeerd alsnog versie 1.3.1 te koppelen en dat gaat ook goed, zal niet met alles werken (Generics e.d.). De commentaren zullen dus niet altijd overeenkomen, maar in iedergeval weet ik het te vinden.


    Bijdrager
    iJoost
    ”IT2Be”

    Ik weet wel dat de info van iJoost fout is. Op de Mac wordt de SDK standaard geinstalleerd.

    Ja, dank je. Alleen zei ik helemaal niets over wat er standaard op Mac’s geinstalleerd wordt. Ik zei iets over in welke varianten Java gedistribueerd wordt. En ik impliceerde welke daarvan de vragensteller waarschijnlijk moet hebben. Dank voor uw aandacht. ;-P


    Bijdrager
    Fiddich
    ”stefanhendriks”

    Hoe dan ook. Ik vond een andere topic en daar stond dat je jezelf kan aanmelden bij Apple (developers). Daar download ik nu de laatste Versie 5 JDK op. Inderdaad, de Development Kit, want dat bevat de source.

    Ik heb ook geprobeerd alsnog versie 1.3.1 te koppelen en dat gaat ook goed, zal niet met alles werken (Generics e.d.). De commentaren zullen dus niet altijd overeenkomen, maar in iedergeval weet ik het te vinden.

    Welke versie van MacOS X gebruik je?
    Voor Tiger kan je de laatste versie van de 1.5 SDK downloaden op de Apple Developper Connection website, waar je gratis kan aanmelden.

    Ik gebruik zelf ook eclipse, totaal geen probleem.
    Er was zelfs een preview release van 1.6, jammer dat ze wel de final niet hebben uitgebracht.
    Ik vermoed dat die pas in leopard zal zitten.


    Bijdrager
    The – DDD

    Prutsers.:D Gevonden na 10 tellen klikken op Google.

    http://samuelsjoberg.com/archive/2007/03/java-source

    Enne Stefan… Koppelen naar de 1.3 sources… niet doen. Krijg je spijt van.;)


    Bijdrager
    OMT-fan

    Als hier java-experts zitten, kan iemand mij dan vertellen waarom Java op mijn IntelMac niet werkt?
    Ik kan veel sites niet goed spelend krijgen terwijl dat op mijn G4 uitstekend gaat.

    Ik heb de meest recente versie van Java geinstalleerd….


    Bijdrager
    WFG

    Staat Java ondersteuning wel aan in je webbrowser?


    Bijdrager
    iJoost
    ”Hans

    Als hier java-experts zitten, kan iemand mij dan vertellen waarom Java op mijn IntelMac niet werkt?
    Ik kan veel sites niet goed spelend krijgen terwijl dat op mijn G4 uitstekend gaat.

    Ik heb de meest recente versie van Java geinstalleerd….

    Niu daarom dan misschien. Standaard heeft Apple al

    (even kijken….

    [code:1:7b2a2cf450][host:~] user% java -version
    java version "1.5.0_07"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-164)
    Java HotSpot(TM) Client VM (build 1.5.0_07-87, mixed mode, sharing)[/code:1:7b2a2cf450]

    …)

    versie 1.5.0_07 voor je geinstalleerd. Dat lijkt me voor de meeste toepassingen wel voldoende. 1.6 komt vanzelf. ;-)


    Bijdrager
    OMT-fan

    Java ondersteuning in Safari staat aan.
    Ik heb java J2SE 1.4.2 en java J2SE 5.0
    Ik heb nu ook de versie 5 gedownload:

    http://www.apple.com/downloads/macosx/apple/macosx_updates/javaformacosx104release5.html

    Verder geeft de software update geen nieuwere versie aan.

    Moet er meer gebeuren?

11 berichten aan het bekijken - 1 tot 11 (van in totaal 11)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.