9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)
  • Q:
    Bijdrager
    lansedo

    iWeb website online krijgen (Directadmin, Versio)

    Beste forumleden,

    Misschien een domme vraag, maar ik ben nog maar een beginnend amateurtje…

    Ik ben de afgelopen tijd bezig geweest met het bouwen van een website in iWeb.
    Als ik de website upload naar directadmin zie ik ook dat alle bestanden zijn geuploaded in de juiste map.
    Alleen op de een of andere manier wil de website maar niet gepubliceerd worden…

    Wie kan mijn helpen?

    Alvast bedankt!

    Bijdrager
    Hansi2124

    Je hebt van je hostingprovider gegevens gekregen denk ik die je moet gebruiken om je website naar te uploaden. In iWeb kies je dan voor FTP-server. Bij instellingen FTP-server moet je die gegevens invullen in iWeb. Daaronder zie je Test verbinding staan. Als je dit hebt gedaan, krijg je dan een goedkeuring of andere melding?

    Bijdrager
    lansedo

    @Hansi2124

    Ik krijg geen foutmeldingen, er staat gewoon bezoek site nu maar dan krijg ik een blanco pagina met http://www.voorbeeld.com:confused:

    Bijdrager
    Hansi2124

    Kijk eens bij Help van iWeb naar Aan de slag video. Ik denk namelijk dat je in de war bent met diverse handelingen van iWeb…..

    Bijdrager
    iMad

    In welke map staat het html bestand op de server
    die je ziet als jij op je webpagina kijkt.
    Ik denk namelijk dat je je bestanden niet naar de juiste map geüpload hebt.

    Bijdrager
    lansedo

    @iMad domains/voorbeeld.com/public_html

    Probleem is denk ik dat iWeb in de public_html zelf een map aanmaakt…

    Bijdrager
    iMad

    Als alles goed gaat maakt iWeb een index.html in de map public_html aan.
    Deze verwijst naar de map waar je website zich bevindt.
    Verplaats de index bestand eens, dan upload nog eens via iWeb je website.

    /domains/website.nl/public_html/
    Bovenstaande is wat ik er heb staan.

    Bijdrager
    lansedo

    Ik krijg t niet voor elkaar,
    Als ik in directadmin op de index_html klik kom ik zie ik wel de homepage van mijn website.
    Maar als ik naar mijn website ga zie ik een wit scherm met website.nl

    Moet ik een database of iets aanmaken? Een bepaalde map toevoegen/verwijderen? Ik kom er niet uit…

    Bijdrager
    KarelWillem

    Er gaat toch ergens iets niet goed.

    Ik ga er nu even vanuit dat je je site op je bureaublad publiceert.
    En dan met een FTP programma naar de server upload.

    site + index.html is wat iWeb publiceert.
    Haal nooit bestanden uit mappen en verplaats niets. Dat is niet nodig en zelfs ongewenst.

    site + index.html gooi je in dit geval in de map httpdocs.
    Soms heet dat ook www of iets anders wat je webhoster daarvoor heeft aangemaakt.
    Dat is het belangrijkste! site + index.html moeten in de juiste directory staan!

    Doe je het helemaal vanuit iWeb, dan zorg je dat bij directory het juiste pad ingevuld staat.
    In mijn geval dus httpdocs.

9 berichten aan het bekijken - 1 tot 9 (van in totaal 9)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.