8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)
  • Q:
    Bijdrager
    Matata

    iweb symbool

    Ik heb problemen bij het toevoegen van accenten in de tekst die ik schrijf in iweb.

    Foto’s wordt foto’s bv…

    Iemand een idee hoe ik dit oplos?

    Bijdrager
    computer space

    Hier zie je de officiele HTML notaties voor diverse symbolen:
    http://www.handleidinghtml.nl/html/karakters/karakters03.html
    http://www.handleidinghtml.nl/html/karakters/code-posities/unicode3.html
    Kijk eens of de broncode van je site ook die notatie gebruikt. Zo niet, dan zul je het handmatig moeten aanpassen.
    In dit geval is ’ de juiste notatie

    Bijdrager
    a la Mac

    iWeb maakt (alle websites trouwens) van HTML. En daarbij moet je voor speciale tekens een speciale notatie gebruiken. Op W3Schools vind je ze allemaal!

    Dus dit:

    [code:1:ad88cb0bde]Foto’s[/code:1:ad88cb0bde]

    wordt

    [code:1:ad88cb0bde]Foto#39;s[/code:1:ad88cb0bde]

    Er zijn twee soorten, de ‘Entity Name’ en de ‘Entity Number’. Je mag kiezen! Behalve voor een apostrof dan, want ' werkt niet in IE

    Bijdrager
    Matata

    mja ik dacht net dat het de bedoeling was om geen html te sschrijven…

    is er ergens een wishlist voor iweb?

    Bijdrager
    computer space

    Zo zie je maar, er zijn ook nog veel verschillende apostrofen. Ik noemde de netjes gekrulde versie, maar met de strakke rechte van a la mac kan het natuurlijk ook.

    En een website maken zonder kaas van HTML te hebben moet je eigenlijk niet doen. Hoe leuk rapidweaver en iWeb het ook maken.

    Bijdrager
    Matata

    Volgens mij klopt er vanalles toch nog niet. Kijk es naar http://eddyvite.dyndns.org/Site/Blog/Blog.html

    Ik kan natuurlijk ook in de gegenereerde html file zitten spelen, maar dan wordt deze elke keer overschreven als ik een nieuwe update doe. Dit is ook niet handig he:)

    ik snap eigenlijk niet waarom dit nu zo moeilijk is. In Mail hebben ze dit toch ook al staan. Je kan toch perfect een mail sturen met een ‘ in…

    Bijdrager
    Deskman

    iWeb hanteert UTF-8 als codering. Dat gaat goed op je .mac website, maar zowel FTP programma’s als sommige swervers zijn daar niet van gediend en die maken er een rommeltje van / serveren je UTF niet zoals het hoort.

    leesvoer

    Waarschijnlijk wordt door je http://FTP.app iets niet goed doorgegeven. Kijk maar eens de voorkeuren van iWeb en je FTP na.

    Bijdrager
    Matata

    Bedankt voor je hint. In mijn geval lag het niet aan de ftp, maar aan de webserver. Voor iedereen die hetzelfde wilt doen: je apache server moet AddDefaultCharset utf-8 hebben.

    Van zodra dit ingesteld was, werkte het perfect.

    Nogmaals bedankt!!!

8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.