7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)
  • Q:
    Bijdrager
    jverdeyen

    iTunes bestanden renamen

    Hoi,

    Ik ben op zoek naar een oplossing voor volgende probleem:

    Alle bestandsnamen van de audiobestanden in iTunes renamen, zonder dat iTunes deze niet meer terug kan vinden.

    Meer concreet:
    Momenteel ziet een bestandsnaam er bv zo uit:
    – (08) Akro – L’enfant Caché Feat. Kure.mp3 (in dir ~/Music/iTunes/Akro – L’encre, Le Sang Et La Sueur (2006)/)

    Nu zou ik (door sync problemen met mijn andere mac/linux computers) alle speciale characters (éèà…) willen omzetten naar gewone characters, zonder dat iTunes de link naar deze bestanden verliest. Renamen op zich is geen probleem (NameMangler of gewoon een bash scriptje). Maar hoe kan ik er zeker van zijn dat iTunes nog weet waar het bestand staat?

    Alvast bedankt!

    Bijdrager
    Pieterr

    Eén tip: doe het niet (dat renamen).

    Probeer liever je andere probleem (syncen) op te lossen. Misschien kun je daar iets meer over vertellen wat er precies misgaat.

    Bijdrager
    jverdeyen

    Ok,

    Thuis heb ik een MBP en op het werk een MBP.
    Aangezien ik veel muziek luister en mijn iTunes bibliotheek gesynced wil houden, rsync ik mijn recentste bibliotheek steeds via mijn home-server. Hierbij heb ik dan ook meteen een backup.

    Dit doe ik gewoon via een simpel rsync commando als:

    <br />
    rsync -avz --delete --force -e  'ssh -p 2222' [email protected]:/home/media/music/iTunes/ ~/Music/iTunes/<br />
     

    (dit is het commando om een reeds gepushte versie op de server naar mijn MBP te trekken)

    Hierbij worden voor eerst bestanden verwijderd met speciale tekens zoals:
    (11) Kelis – Millionaire (feat. Andre?\#201 3000).mp3
    Waarna deze weer worden geadd. Hoewel het bestand op mijn MBP wel juist staat, ziet rsync deze tekens anders…

    Bijgevolg heb ik dus heel wat overhead aan trafiek, omdat hij steeds alle bestanden met speciale tekens opnieuw sync ipv alleen de gewijzigde.

    Dit is zeer algemeen.

    Bijdrager
    Pieterr

    Misschien kun je dit probleem oplossen met de –iconv optie van rsync.
    Zie http://samba.anu.edu.au/rsync/FAQ.html#2

    Bijdrager
    jverdeyen

    Dat zou inderdaad een oplossing zijn! Maar de rsync versie op mijn MBP ondersteund die –iconv blijkbaar (nog?) niet.

    <br />
    rsync: --iconv=UTF-8: unknown option<br />
    rsync error: syntax or usage error (code 1) at /SourceCache/rsync/rsync-40/rsync/main.c(1333) [client=2.6.9]<br />
     
    Bijdrager
    tinus_omt

    De –iconv optie is er pas in de 3.x serie. Eventueel zou je een modernere versie kunnen compileren.

    Bijdrager
    Pieterr

    Zoals tinus_omt zegt. Roll your own.:wink:

    http://samba.anu.edu.au/ftp/rsync/rsync-3.0.7.tar.gz

7 berichten aan het bekijken - 1 tot 7 (van in totaal 7)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.