2 berichten aan het bekijken - 1 tot 2 (van in totaal 2)
  • Q:
    Bijdrager
    MadDonna

    Installatie vcremote

    Ik probeer voor een project op school, wat ik ga begeleiden, vcremote te installeren op een xserve (met Catalina) en ook voor test op mijn Mac mini.

    Echter ik krijg een sloot aan foutmeldingen, die ik tot op zekere hoogte heb kunnen oplossen. Echter de laatste stap die wil maar niet, ik heb logging, maar geen idee hoe ik een logfile kan attachen :

    Ld /Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/Release/ios-deploy normal x86_64 (in target ‘ios-deploy’ from project ‘ios-deploy’)

    cd /Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -target x86_64-apple-macos10.8 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.15.sdk -L/Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/Release -F/Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/Release -F/Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/_Frameworks -filelist /Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build/Objects-normal/x86_64/ios-deploy.LinkFileList -Xlinker -object_path_lto -Xlinker /Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build/Objects-normal/x86_64/ios-deploy_lto.o -fobjc-arc -fobjc-link-runtime -framework MobileDevice -framework Foundation -framework CoreFoundation -Xlinker -dependency_info -Xlinker /Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/ios-deploy.build/Release/ios-deploy.build/Objects-normal/x86_64/ios-deploy_dependency_info.dat -o /Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/Release/ios-deploy

    ld: framework not found MobileDevice

    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    ** BUILD FAILED **

    The following build commands failed:

    Ld /Users/marcodeboer/.nvm/versions/node/v8.9.3/lib/node_modules/vcremote/node_modules/ios-deploy/build/Release/ios-deploy normal x86_64

    (1 failure)

    npm ERR! code ELIFECYCLE

    npm ERR! errno 65

    npm ERR! [email protected] preinstall: ./src/scripts/check_reqs.js && xcodebuild

    npm ERR! Exit status 65

    npm ERR!

    npm ERR! Failed at the [email protected] preinstall script.

    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:

    npm ERR!     /Users/marcodeboer/.npm/_logs/2020-02-10T09_43_04_846Z-debug.log

    Bijdrager
    ErikCh

    Goeiedag, zo te zien een vaak voorkomend probleem https://github.com/ios-control/ios-deploy/issues/387  zie je een mogelijke oplossing voor je probleem.  Ook kan je de huidige installatie van ios-deploy verwijderen met npm en dan een brew install doen van ios-deploy…zou ook moeten werken.  Kan het nu niet uittesten.

     

2 berichten aan het bekijken - 1 tot 2 (van in totaal 2)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.