20 berichten aan het bekijken - 1 tot 20 (van in totaal 20)
  • Q:

    Bijdrager
    Torz

    iChat AV,de iSight en de Firewall.

    Het openstellen van poorten in een firewall ten behoeve van iChat AV voor het gebruik van een Cam(iSight of ander ).

    Sommige internet providers en netwerk routers maken gebruik van het zogenaamde NAT(Network Adress Translation)protocol om internet te delen.
    Bij standaard instellingen van de router en standaard(default) gebruik van de firewall van de router staan de juiste poorten niet open.
    Als men de ingebouwde firewall van OSX gebruikt moeten ook daar de juiste poorten opengezet worden.

    IChat AV maakt gebruik van de UDP poort 5060 voor initialisatie en aanvraag van iChat invitaties.Deze poort moet dus in beide firewalls open staan.Anders
    kan de aanvraag niet beantwoord worden.

    Daarnaast maakt AOL Aim gebruik van poort 5190.Ook deze moet open staan.

    Ook maakt iChat AV gebruik van de UDP poorten 16384 t/m 16403 om audio en video datapackets door te laten.

    Er worden 4 poorten gebruikt in deze range.Deze zijn voor respectievelijk,
    video in,video out,audio in en audio out

    Het simpelste is om zowel de firewall van OSX die van de router uit te zetten.
    Willen we dit echter niet(wel aan te raden) dan zijn de volgende stappen nodig om het iAV chat verkeer door te laten.

    Stap 1.

    Kies Apple menu>system preferences
    Kies View>Sharing
    Klik op de Firewall Tab
    Klik New
    Kies Other van het Port Name pop-up menu
    In het Port Number,Range or series field,type in: 5060, 16384-16403
    In het Description veld type: iChat AV
    Klik OK
    Herhaal de procedure nog een keer , maar kies bij new
    Aol im (poort 5190)en druk op ok,deze poort wordt automatisch aangemaakt.

    Stap 2.

    Kies Apple menu>system preferences
    Kies network
    Kies bij Configure>manually
    Vul in bij:IP adress :192.168.1.x(getal in de range van 10-100)
    Subnet Mask: 255.255.255.0
    Router:192.168.1.1

    Je hebt nu een vast ip adres voor de computer ingesteld.

    Voor elke andere computer gebruik je een ander nummer uit de reeks.

    Stap 3.De Router (in dit geval een Draytek)

    Login in de draytekrouter via een webbrowser:
    Ga naar Advanced setup > NAT setup> Open ports setup
    NB.Bij mij werkt safari niet goed om de router te sturen.Ik heb dus gebruik gemaakt van Internet Explorer.

    Klik op de eerste lege regel
    Vink Enable Open Ports” aan, en vul bij Comment in iChat AV1 in.
    (als je meerdere computers wil gebruiken voor iChat AV video gebruik,kun je ze straks iChat AV 2 ,3 etc. noemen)

    Vul bij local computer het vaste interne netwerk IP adres wat je net hierboven hebt toegekend aan de Mac met de Webcam. Dat is dus 192.168.1.x.
    Kies bij het eerste invulvak voor UDP en vul zowel bij Start als bij End in 5060.

    Kies bij het tweede invulvak ook voor UDP en zet bij Start 16384 en bij End 16403.
    Kies bij het derde invalvak ook voor uDP en zet bij Start 5190 en bij End 5190.

    Druk op OK.

    Keer terug naar het main menu en reboot the router.

    Zowel de router als Macosx laten nu verkeer tbv. IChat AV door.

    Als je een 2e Mac wilt gebruiken voor de Cam noem deze dan iChat AV2 en herhaal de procedure.NB. wel het juiste vaste ip adres van de 2e computer invullen bij local computer.


    Bijdrager
    Torz

    toevoeging aan stap 2.

    bij DNS Servers de nummers van je provider invullen!


    Bijdrager
    Syndic

    Ehrmmm Torz? Als je nou geen Draytek router maar een Alcatel Speedtouch hebt? Welke settings moet ik dan gebruiken? Dat configuratie scherm van mijn Speedtouch vraagt om hele andere dingen bij NAT settings:D


    Bijdrager
    Torz

    Moet nog even bestuderen,bij een getweakte modem zit ook een standaard firewall.Die raad ik je aan uit te zetten als je maar een computer hebt.Dan hou je alleen de osx firewall(van Sharing prefs) en zet daar de juiste poorten open zoals hierboven beschreven.Mijn Alcatel is niet getweaked dus ik kan hier even niet zien hoe dat eruit ziet.

    (wordt vervolgd)


    Bijdrager
    ceeshonig

    ik heb een alcatel speedtouch 510 multipc modem met router erin en ik krijg ondanks alle handleidingen die hier staan geen bel/camera sessie draaiende. tekst-chatten gaat prima maar als ik wil bellen of webcam chatten in ichat dan stopt ichat “onverwacht”. heel irritant.
    Ik heb bij mijn ouders die geen adsl hebben maar wel kabel de boel wel makkelijk aan de praat kunnen krijgen.

    dus al iemand weet hoe het precies met deze modem/router zit dan hoor ik het graag.


    Bijdrager
    Syndic

    Is jouw ISP soms ook XS4ALL? Daar zit bij ons waarschijnlijk het probleem.


    Bijdrager
    ceeshonig

    nee ik heb planet. maar een vriend van mij heeft wel xs4all en geen problemen.


    Bijdrager
    Syndic

    Oh ok… een aantal van ons (gebruiken allemaal Xs4ALL) hebben constant problemen met iChat AV die eruit blijft knallen… vandaar mijn vraag aan jou :wink:


    Bijdrager
    Syndic

    Wat voor cam gebruik je? Geef ’s wat meer details…:D Jouw probleem lijt verdacht veel op het mijne namelijk


    Bijdrager
    ceeshonig

    ik heb een emac g4 en een philips vesta pro webcam (die overigens prima werkt met ichat op mijn ouders’ cube).
    planet internet adsl comfort
    en een alcatel speedtouch 510 multi-pc router-modem (er hangt ook nog een ibook aan)
    ik heb hetzelfde als jij dat als ik een webcam/bellen sessie wil starten dan wordt ik er uit gegooid (iChat is onverwacht gestopt)

    Maar ik kan het me niet voorstellen dat het aan de ISP ligt. volgens mij ligt het probleem in de modem/router. maar wat het is weet ik niet.


    Bijdrager
    Mac-ofiel
    ”ceeshonig”

    ik heb een emac g4 en een philips vesta pro webcam (die overigens prima werkt met ichat op mijn ouders’ cube).
    planet internet adsl comfort
    en een alcatel speedtouch 510 multi-pc router-modem (er hangt ook nog een ibook aan)
    ik heb hetzelfde als jij dat als ik een webcam/bellen sessie wil starten dan wordt ik er uit gegooid (iChat is onverwacht gestopt)

    Maar ik kan het me niet voorstellen dat het aan de ISP ligt. volgens mij ligt het probleem in de modem/router. maar wat het is weet ik niet.

    Ik gebruikte mijn Philips Vesta samen met Ivisit en als ik dan via iChat iemand probeerde te bellen, dan knalde ook bij mij iChat eruit. Dit probleem was opgelost toen ik de cam van de Mac afkoppelde, bij mij lag het dus echt aan de cam!!!!
    Heb dan ook maar snel een iSigth aangeschaft en die werkt als een zonnetje :lol: 8)


    Bijdrager
    Syndic

    Zit er in die Philips Vesta soms ook geen ingebouwde microfoon?


    Bijdrager
    ceeshonig

    in die vesta pro zit ook een microfoon ja. maar het kan volgens mij niet aan de webcam liggen want bij mijn ouders doet hij het prima (kabel).


    Bijdrager
    4RN0LD.V4N.R001J

    Klinkt wat vreemd maar ik heb hier een trust familyc@m en een spyc@m liggen die allebei problemen gaven. iVisit herkende hem wel maar gaf niet meer dan zwart beeld. In Macam doen ze het allebei maar je moet eerst op de play button drukken om de camera/afspeel modus ‘aan te zetten’. Als ik macam afluit zonder de cam te stoppen heb ik in iVisit wel beeld! Ichat klapt er helaas nog steeds uit als ik mijn webcam erin heb zitten.

    Toch een prima workaround voor speelgoed dat ik nog had liggen. Ik weet niet of je er wat aan hebt maar wie weet.


    Bijdrager
    snipper

    Dit was precies wat we zochten!:)

    Inderdaad wel de DNS nr’s invullen en het leek ook nodig om in de Vigor NAT configuratie de ‘Choose PC’ button aan te klikken en het IP adres van de gebruikte Mac aan te klikken.

    Geweldig, video-chatten! :mrgreen:


    Bijdrager
    larch

    Heb stap 1 van Torz achter de rug.
    Weet echter niet hoe ik deze ongedaan moet maken.
    Telkens als ik via pref./share/firewall kom krijg ik de volgende boodschap :

    Er wordt andere firewallsofware op deze computer uitgevoerd.
    Als u de instellingen van Apple firewall wilt wijzigen, moet u de andere firewallsoftware uitschakelen.

    Vreemd genoeg heb ik geen andere firewallsoftware (tenzij je stap 1 software noemt?!!!
    Vreemd genoeg zijn alle opties grijs (en ja, het slot staat open-is dus niet vergrendelt)[/img][/u]


    Bijdrager
    larch

    kan niemand mij helpen?


    Bijdrager
    snipper

    Sorry, ik weet hoegenaamd niets van firewalls

    :(


    Bijdrager
    larch

    :cry:
    Ik dus ook niet(dat is wel duidelijk), maar heb altijd wel de onhebbelijke gewoonte overal aan te prutsen.


    Bijdrager
    larch

    Stel ik zo een onnozel eenvoudige vraag?
    Of weet gewoon niemand direct het antwoord?

20 berichten aan het bekijken - 1 tot 20 (van in totaal 20)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.