8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)
  • Q:

    Bijdrager
    fibe

    .htaccess bestanden worden niet gelezen.

    Hi,

    Ik heb net een nieuwe webserver geïnstalleerd, maar krijg .htaccess bestanden niet werkend.
    De webserver is de standaard apache 1.3 die bij osx 10.4 wordt geleverd.


    Bijdrager
    edpannelap

    In de config files van apache moet/kun je aangeven dat je uberhaupt een .htacces file gebruikt en wat daar dan in mag staan. Mijn apache op mijn powerbookis aan gort dus ik kan het even opzoeken hoe en waar dat exact staat maar zal iets zijn van httpd.conf

    in het stukje van de default directory moet staan
    AllowOverride All

    hoop dat het helpt
    edwin


    Bijdrager
    computer space
    ”fibe”

    Hi,Ik heb net een nieuwe webserver geïnstalleerd

    Aangezet neem ik aan? Of heb je echt los iets geinstalleerd?


    Bijdrager
    fibe

    Jaja, aangezet:)

    Ik heb nu dit ingesteld:

    [code:1:0ff84f2925]<Directory "/Library/WebServer/Documents/domains/*/html">
    AllowOverride All
    </Directory>[/code:1:0ff84f2925]

    Maar werkt nog niet…

    Moet ik dat per domeinnaam in de Virtualhost bepalen?
    Of kan het ook zoals hierboven?


    Bijdrager
    edpannelap

    Volgens mij moet je het per directory aanzetten.
    weet het niet heel zeker.
    probeer het even.

    p.s. als je daarin wat aanpast moet je ook apache restarten.


    Bijdrager
    Jean-Jacques

    [code:1:48f543c8c6]
    AllowOverride All
    [/code:1:48f543c8c6]


    Bijdrager
    danielpunt

    Moet dit ook blijven staan?
    Options FollowSymLinks


    Bijdrager
    edpannelap

    Tja,

    meestal staat dit aan op een unix machine zodat je symbolic links werken met apache.
    kan geen kwaad dus gewoon laten staan. Je wordt helemaal gek als het uit staat en je probeert een keer keer een link te gebruiken:-)

    kijk anders eens in de manual van apache (er goed volgens mij)
    voor 1.3: http://httpd.apache.org/docs/1.3/

8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.