8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)
  • Q:
    Bijdrager
    dborneman

    .Htaccess aanzetten Mac Os X SL Server

    Ik heb inmiddels al heel wat topics uit 2003 en 2004 voorbij zien komen over hoe je .Htaccess aan kan zetten op Os X server. Ik kom er echter nog steeds niet uit want de aanwijzingen die daarin staan vermeld komen volgensmij niet meer helemaal overeen.

    Is er iemand hier in geslaagd op Leopard of Snow Leopard server .htaccess aan de praat te krijgen? Ik heb de beide bestanden laten genereren en in de map geplaatst echter worden ze niet herkent en is de website gewoon nog bereikbaar!

    Ik hoop dat iemand me hiermee verder kan helpen!

    Alvast bedankt!

    Bijdrager
    dborneman

    Ik ben inmiddels iets verder maar het werkt nog steeds niet:

    Via de terminal heb ik de httpd.conf opgezocht:
    CD /private/etc/apache2
    sudo pico httpd.conf

    Vervolgens heb ik Allowoveride veranderd op alle locaties naar ALL. (ik had eerst ook nog wat dingen eronder vermeld maar toen kreeg ik op elke pagina een foutmelding).

    Vervolgens via terminal de .htaccess aangemaakt en .htpasswd.
    1. cd /Library/Webserver/Documents/camera
    2. sudo pico .htaccess (copy paste) ctr+o (opgeslagen) ctr+x
    3. sudo pico .htpasswd (copy paste) ctr+o (opgeslagen) ctr+x

    Zie hier de htacess file:
    http://localhostr.com/files/9c579c/Screen+shot+2010-08-28+at+7.51.10+PM.png

    Ik kom echter nog steeds op de pagina zonder gebruik van een wachtwoord! Iemand een idee wat ik verkeerd doe?

    Bijdrager
    qazwsxedc

    Zijn beide bestanden te lezen door Apache? Welke rechten hebben de bestanden?

    Uit de apache documentatie http://httpd.apache.org/docs/current/howto/htaccess.html :

    When you put configuration directives in a .htaccess file, and you don’t get the desired effect, there are a number of things that may be going wrong.

    Most commonly, the problem is that AllowOverride is not set such that your configuration directives are being honored. Make sure that you don’t have a AllowOverride None in effect for the file scope in question. A good test for this is to put garbage in your .htaccess file and reload. If a server error is not generated, then you almost certainly have AllowOverride None in effect.

    If, on the other hand, you are getting server errors when trying to access documents, check your Apache error log. It will likely tell you that the directive used in your .htaccess file is not permitted. Alternately, it may tell you that you had a syntax error, which you will then need to fix.

    Misschien heb je er iets aan. Succes:smile:

    Bijdrager
    dborneman

    Bedankt voor je reactie!

    Ik kreeg inderdaad geen foutmelding toen ik wat onzin in me .htaccess bestand had gezet. Ik heb nu het onderste gedeelte dat specifiek op de directory staat gericht toegevoegd aan httpd.conf zie:
    http://localhostr.com/files/e8b39c/Screen+shot+2010-08-28+at+11.35.08+PM.png

    Ik krijg nu wel de foutmelding als ik naar de pagina ga, maar krijg niet de kans om in te loggen zie:
    http://localhostr.com/files/a33899/Screen+shot+2010-08-28+at+11.38.59+PM.png

    Betekent dat dat de htaccess file niet goed is? Ik heb het gewoon via een online generator laten genereren..

    Bijdrager
    Sumar

    Bij mij (weliswaar geen OSX server) werkt

    <br />
    <Directory "/Applications/MAMP/htdocs"><br />
        Options All<br />
        AllowOverride All<br />
        Order allow,deny<br />
        Allow from all<br />
    </Directory><br />
     

    prima met dit .htacces bestand

    <br />
    AuthType Basic<br />
    AuthName "Only Valid Users"<br />
    AuthUserFile /Applications/MAMP/htdocs/testht/passwd<br />
    require valid-user<br />
     

    En in de categorie overbodige opmerkingen: na wijzigingen van httpd.conf wel Apache herstarten (vergeet ik zelf ook nog wel eens)

    Bijdrager
    dborneman

    Ik heb het gevoel dat het mis gaat omdat mijn subdirectorie niet in dezelfde map zit als de map van mijn hoofdwebsite! Ik doe namelijk volgensmij alles verder exact hetzelfde!

    Hoe stel ik directory in in httpd.conf als:
    – hoofdmap website: /library/webserver/sites/www.bornie.nl.
    – submap website: /library/webserver/documents/camera

    Ik kan de submap dus bereiken via website.nl/camera

    Ik stel nu steeds de submap in bij httpd.conf en krijg dan ook een 403 melding! Iemand nog suggesties?

    Bijdrager
    qazwsxedc

    Submappen instellen via je config werkt volgens mij sowieso niet. Je kan domeinen en subdomeinen als virtual hosts instellen (vhosts.conf). Dus http://www.bornie.nl -> /library/webserver/sites/www.bornie.nl en camera.bornie.nl -> /library/webserver/documents/camera kan wel, maar http://www.bornie.nl/camera naar iets anders laten verwijzen lukt op deze manier niet. Je kan op je hoofddomein een alias maken (via de terminal, het ln (el-en) commando, met optie -s (soft link)). Dan moet je wel even controleren of er geen open basedir restricties gelden die ervoor moeten zorgen dat je site niets buiten zijn eigen map mag doen.
    .
    Mijn advies: probeer eerst de .htaccess goed werkend te krijgen op een normale config. Probeer dan de submap goed werkend te krijgen en combineer ze pas als ze beiden werken.

    Bijdrager
    dborneman

    Na ontzettend lang in alle configuratie files te hebben lopen klooien. Ging ik weer even verder googlen en toen kwam ik dus iemand tegen die hetzelfde probleem had en er toen achter kwam dat het in server admin gewoon een optie was!!

    Je gaat naar de website in kwestie tikt een checkbox bij allow all overrides aan en voila het werkt!

    Bedankt in ieder geval voor alle hulp!

8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.