30 berichten aan het bekijken - 1 tot 30 (van in totaal 30)
  • Q:
    Bijdrager
    Johnyw

    hosts file: facebook en facebook blokkering- hoe ?

    Hello,
    Ik moet om allerlei redenen, de toegang tot Facebook kunnen blokkeren op mijn Imac !
    Ik heb daar een en ander over gevonden hier op het forum, en wou dus het hosts file aanpassen.

    In eerste instantie geprobeerd met shift-appeltje-g en dan kreeg ik tot mijn verbazing dit:

    Ik begrijp er niets meer van, ik ben toch ingelogd als de hoofdgebruiker …?

    Dan geprobeerd met Gas Mask, daar kwam ik wel probleemloos in het hosts file,
    daar gewoon twee nieuwe regels toegevoegd:
    127.0.0.1 http://www.facebook.com
    127.0.0.1 facebook.com
    en gesaved.

    Maar , het werkt niet, ik kan, ook na herstart probleemloos naar Facebook ?
    Ik neem aan dat er toch maar één hosts file is? ( op mijn computer is maar een gebruiker, en dat ben ik),
    En hoe achterhaal ik als ik de nodige privileges heb, anders dan via de shortcut ?
    Wie kan me helpen aub, want het is hier echt de spuigaten uit aan het lopen !!

    Bedankt
    Johny

    Geblokkeerd
    geanonimiseerde gebruiker

    Er is geen map ‘hosts’, wel een bestand in de map ‘/etc’ dat zo heet.

    Wanneer je in Terminal de onderstaande opdracht invoert kan je het bewerken.

    sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /etc/hosts

    Je brengt dan de volgende twee regels aan en facebook is geblokkeerd (tweede regel zonder spaties voor en na de punt.

    127.0.0.1 facebook.com
    127.0.0.1 www . facebook.com

    Bijdrager
    Johnyw

    Ok, sorry, ben daar niet zo in thuis, ga het even proberen op uw manier.

    Bijdrager
    Jakko Westerbeke

    Wat ik me wel ene beetje afvraag is waarom je een website wilt blokkeren terwijl jij de enige gebruiker bent, en hoe het dan de spuigaten uitloopt. Gebrek aan zelfdiscipline?;)

    Bijdrager
    Johnyw

    Neen, een zwaar verslaafde vrouw aan Facebook en de spelletjes en nog meer onwaarschijnlijk toestanden die een verregaande inpakt hebben op mijn gezin

    Bijdrager
    Johnyw

    Nu kan ik het bestand hosts wel openen , en aangepast:

    Maar het werkt niet ?

    Wat wel vreemd is dat ik op mijn Imac inlog als Johny Willemyns en het paswoord,
    maar dat er in terminal “photostudio” verschijnt ?

    Daar begrijp is niets van ??

    Bijdrager
    Waffle ಠ_ಠ

    Is dat soms je korte gebruikersnaam (zoals in de Finder-zijbalk)? Probeer anders eens het bestand met pico te bewerken:
    sudo pico /etc/hosts
    en saven door op ctrl+x te drukken en dan ‘y’.

    Geblokkeerd
    geanonimiseerde gebruiker

    Ik zie dat je aan het einde een forward slash hebt toegevoegd ( / ). Die moet er niet bij.

    Bijdrager
    Johnyw

    Met die sudo pico enz lukt het me om het bestand te openen, maar ik kan daar niets aan toevoegen? Hoe moet ik dan doen ?
    Ben een leek op dit gebied ?

    Bijdrager
    Johnyw

    Het is gelukt, in die zin dat ik met pico heb kunnen werken.
    Maar jet bleek dat de beide lijnen omtrent facebook er eigenlijk reeds waren !

    Afgesloten zoals Waffle zei, maar zie, ik kan Facebook nog steeds zonder problemen openen in alle browsers !

    Wie helpt me dit op te lossen aub, word echt wanhopig hoor !
    Bedankt

    Bijdrager
    Johnyw

    Oh ja, en mijn paswoord zoals ik het gebruik om in te loggen, werkte perfect ..

    Moderator
    unSOUND

    Als je het hosts bestand aanpast moet je wel de DNS cache legen voor de zekerheid, anders werkt het soms niet. Dat kan ook vanuit de terminal, maar de code verschilt per versie van OS X.

    Tiger:
    lookupd -flushcache

    (Snow) Leopard:
    sudo dscacheutil -flushcache

    Overigens hoeft dat regeltje met #Optional block list er volgens mij niet eens bij te staan. Je voert die tekst gewoon in op de regel onder “255.255.255.255 broadcasthost”

    Bijdrager
    Johnyw

    Eerst een gebruikers vraagje omtrent werken in die teksteditor in terminal ( pico?)

    Eens ik de nodige tekst ingevoerd heb, en dan op ctrl x en dan op y gedrukt heb, wil ik graag terug naar de prompt (waar ik in eerste instantie terecht kwam bij het openen van de terminal).
    Er is daar waarschijnlijk ook een toetsen combinatie voor maar ik ken ze niet, dus sluit ik nu de terminal af en heropen hem, en voer dan het commando in om de DNS cache te legen !
    Hoe doe ik dat dus zonder terminal af te sluiten?

    Nu weer ter zake: het is dus gelukt om facebook te blokkeren, maar daardoor bereik in mijn uiteindelijke doel nog niet..
    Blijkt namelijk dat je dan nog altijd probleemloos bij die spelletjes kan !
    De URL van die rommel begint met: “http://apps.facebook.com/…..
    Ik heb dus nog een extra regel toegevoegd : apps.facebook.com, net onder de twee regels om facebook te blokkeren.
    Maar wat merk ik nu, als ik dan ctrl x en y invoer, word dit NIET bewaard, en is er van die apps.facebook.com in het hosts bestand niets terug te vinden wanneer het bestand heropen !
    Dus, die spelletjes zijn nog steeds bereikbaar !

    Help aub !!

    Bijdrager
    Johnyw

    Zie aub eerst de voorgaande post

    Alvorens alles in orde is wil ik graag mijn hosts file terug aanpassen, maar wanneer ik die twee lijnen die ik toegevoegd heb verwijder, krijg ik die verandering niet opgespaard met ctrl x en “y” ?

    Ik weet dat het misschien een beetje belachelijk klinkt, maar ik wil niet dat ze er iets van merkt alvorens het allemaal voor mekaar is !

    En sommigen zullen misschien stellen dat ik uit Terminal moet blijven omdat ik te weinig van afweet, maar geloof me aub, ik ben echt wanhopig !

    Bedankt voor alle hulp en raad !

    Inactief
    Anoniem

    Is het niet handiger om bijvoorbeeld LeechBlock (Firefox) of AdBlock (Safari) te installeren en dan aan te geven dat Facebook reclame is?

    Bijdrager
    Johnyw

    Hoe lang denk je dat het zal duren voor ze dat door heeft ? En het zijn de spelletjes die moeten geblokkeerd worden en facebook.. en niet enkel de publiciteit !

    Bijdrager
    Jakko Westerbeke
    Johnyw op 13 maart 2011

    Eens ik de nodige tekst ingevoerd heb, en dan op ctrl x en dan op y gedrukt heb, wil ik graag terug naar de prompt (waar ik in eerste instantie terecht kwam bij het openen van de terminal).

    Daar ben je als het goed is nadat je in Pico op ^C (Ctrl”X) gedrukt hebt — dat is namelijk het commando “Exit”:) Je moet op “y” drukken om je bestand te bewaren, als je het gewijzigd hebt, anders is die y niet nodig.

    Mocht je in Pico willen blijven na wijzigingen, dan druk op je ^W (commando “WriteOut” — m.a.w. “bewaar”). Hiermee bewaar je het bestand maar stop je Pico niet.

    Verder: als je je toegevoegde regels tijdelijk uit wilt schakelen, hoef je ze niet te wissen. Zet er gewoon een hekje (#) voor — alles dat na zo’n hekje komt, wordt namelijk genegeerd. Wil je ze later weer inschakelen, dan hoef je alleen het hekje weer weg te halen.

    Maar één ding dat ik me nu wel afvraag is of je vrouw het niet vreemd gaat vinden dat Facebook ineens helemaal niet meer werkt … Mij lijkt dit vooral een recept voor (om het maar diplomatiek te stellen) onenigheid …

    Bijdrager
    Johnyw

    ik heb dat # geplaatst, maar als ik dan ^X druk zijn de veranderingen niet bewaard en blijf ik precies in pico, ik ben dan ook niet terug aan de prompt …?

    Bijdrager
    Johnyw

    Hier blijf ik hangen, na ^C en Y en zie ik blijkbaar geen andere mogelijkheid dan de Terminal af te sluiten…

    Bijdrager
    Sumar

    Je kan het (denk ik) makkelijker doen via de gratis Textwrangler.

    Start Textwrangler, CMD-D, typ /etc/hosts en je zit meteen in het bestand. Als je wilt wijzigen moet je vervolgens je wachtwoord intikken.

    Bijdrager
    Vaio

    Ik ken er niks van maar als je vrouw surft naar fb.com dan kan ze dat toch ook openen? Ik denk dat je beter gebruik maakt van OpenDNS.

    Bijdrager
    Johnyw

    @ Vaio: ik geloof nooit dat ze er zal opkomen om fb.com in te voeren …
    @ Sumar: bedankt, met text wrangler was dat zo gepiept.
    Ik zal straks eens proberen om de apps.facebook.com ook uit te schakelen !
    Want nu is ze ermee bezig, van deze morgen reeds…

    Bijdrager
    iep

    Je kunt beter gebruik maken van een zogenaamde wildcard. Dat is de * (ook wel ster of asterisk). Door *.facebook.com naar 127.0.0.1 te laten verwijzen blokkeer je alles wat maar op .facebook.com eindigt dus ook apps.facebook.com. Overigens werkt dat /etc/hosts file alleen maar op de computer waar je ‘m aanpast.

    Bijdrager
    Johnyw

    Bedankt @Sumar voor de text wrangler tip.

    @iep
    , goeie tip , die wildcard.

    Dus voor de duidelijkheid, voor het ogenblik staat in mijn hosts bestand alleen:
    127.0.0.1 *.facebook.com

    Alleen mannen,
    Die spelletjes pagina’s blijven probleemloos te openen! (apps.facebook.com/….), dat is toch niet te geloven !

    In Firefox heeft ze een reeks Bookmark’s staan naar die spelletjes en die blijven gewoon bereikbaar !

    Dus, ik heb veel bijgeleerd, bedankt daarvoor, maar de kern van de zaak, de spelletjes ontoegankelijk maken is me tot nu toe niet gelukt . Hoe moet ik verder?

    Bijdrager
    Jakko Westerbeke
    Johnyw op 13 maart 2011

    ik heb dat # geplaatst, maar als ik dan ^X druk zijn de veranderingen niet bewaard en blijf ik precies in pico, ik ben dan ook niet terug aan de prompt …?

    Goed … dit is niet lullig bedoeld, maar misschien is het een idee als je eens even nadenkt over wat je op je beeld ziet:) Je drukt op ^X en dan krijg je dit te zien:

    Nu lijkt het op bovenstaande afbeelding voor mij verdacht veel alsof Pico je vraagt onder welke bestandsnaam je werk bewaard moet worden … Wellicht dat het dan een idee is om te kijken of die naam klopt, en zo ja, op de Return-toets (?) te drukken? En zo nee, die te wissen en er een andere te typen, gevolgd door een druk op de Return-toets?

    Bijdrager
    mark-a-mac

    Kun je in je router niet wat filters inbouwen? De apparaten die hier rondslingeren hebben dat soort mogelijkheden wel (maar ik weet er het fijne niet van qua functionaliteiten). Beveiligen met een eigen wachtwoord en hoppa (vrouwlief zal toch niet je netwerk gaan resetten…).

    Bijdrager
    iep
    Johnyw op 14 maart 2011

    Die spelletjes pagina\’s blijven probleemloos te openen! (apps.facebook.com/….), dat is toch niet te geloven !

    In Firefox heeft ze een reeks Bookmark\’s staan naar die spelletjes en die blijven gewoon bereikbaar !

    Heb je dan wel de dns cache geflusht zoals unSOUND dat heeft uitgelegd?

    Voor Firefox heb je trouwens ook de mooie extensie adblock waarmee je dingen kunt blokkeren (niet alleen advertenties). Daarmee zou je eventueel ook nog het nodige kunnen blokkeren.

    Ik kom in de comments van de volgende links nog wel een aantal handige tips tegen, het overwegen waard:
    http://osxdaily.com/2010/04/21/how-to-block-a-website-from-safari-firefox-or-chrome/
    http://osxdaily.com/2010/11/21/block-facebook/

    Het schijnt zelfs al standaard via de profile settings te kunnen: http://www.youtube.com/watch?v=l2f-H-9Ao78 Sommige mensen weten dat echter zelf snel te ontdekken…

    Bijdrager
    Little Idiot

    En wat met Little Snitch of HandsOff op de achtergrond laten draaien en het verkeer naar de spelletjes blokkeren?
    Of heel kinderachtig de vrouw een eigen account op de Mac geven en met ouderlijk toezicht de boel dichttimmeren?
    (de lerenriemmethode: de vrouw door middel van ouderwetsch huischhoudelijk geweld aan het verstand peuteren dat facebook niet mag)

    Bijdrager
    qazwsxedc

    Wildcards in je hosts file werken niet. Je moet dus ieder subdomein apart toevoegen.

    sudo nano /etc/hosts

    Voer wachtwoord in, gevolgd door <enter>, wordt niet getoond.

    Voeg de volgende regels toe (en mogelijk zijn er meer nodig) met een TAB tussen het IP adres en de host:

    <br />
    127.0.0.1		facebook.com<br />
    127.0.0.1		www.facebook.com<br />
    127.0.0.1		apps.facebook.com<br />
     

    Sla op met Ctrl-O. Sluit de editor af met Ctrl-X. Succes.

    edit: blijkbaar maakt OMT er automatisch http://www.facebook.com van. In je host file gebruik je geen http:// of slashes, alleen de hostname!

    Bijdrager
    iep

    De asterisk gebruiken werkt wel maar kennelijk niet als wildcard (het is dan feitelijk hetzelfde als piet.example.com). Bij gebruik van een dns server echter wel.

30 berichten aan het bekijken - 1 tot 30 (van in totaal 30)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.