21 berichten aan het bekijken - 1 tot 21 (van in totaal 21)
  • Q:

    Bijdrager
    meneer de koekepeer

    Hoe roep ik mijn localhost aan van een andere computer

    Hi,

    Op mn mac tik ik #mijnnaam#.local/~#mijnnaam# om mn localhost aan te roepen.

    Helaas werkt dit niet als ik de localhost van mn windows pc aanroep.
    Ik heb al geprobeerd de localhost aan te roepen via het ip nummer van mn mac, dus 10.0.0.9:80, dan kom ik op de apache pagina uit, maar als ik 10.0.0.9:80/#mijnnaam# doe, dan krijg ik een foutmelding.

    Alle shares staan aan, dus daar kan het niet aan liggen.

    Heef iemand advies?


    Bijdrager
    araminta

    127.0.0.1 of ‘localhost/~mrcakepear’?


    Bijdrager
    meneer de koekepeer

    Nee, dat doet het niet…


    Bijdrager
    maceddy

    Je moet in je System Preferences je web sharing even aanzetten…

    Dus niet je internetsharing, maar web sharing anders zat t nooit werken:)


    Bijdrager
    meneer de koekepeer
    ”meneer

    Alle shares staan aan, dus daar kan het niet aan liggen.

    Die staat dus aan:)


    Bijdrager
    maceddy

    Oeps, verkeerd gelezen, dacht dat er uit stond…

    :roll:


    Bijdrager
    meneer de koekepeer

    LOL:)


    Bijdrager
    Julian

    Je moet in de httpd.conf (/etc/httpd) de servername (ongeveer rond regel 350) aanpassen zodat er

    ServerName [ipadres of dns naam] komt te staan (niet die # ervoor)
    dus:
    ServerName http://10.0.0.9/

    Dan zou het moeten werken…
    (als je de server herstart)


    Bijdrager
    meneer de koekepeer

    Hmz.
    Kan de map /etc/httpd nergens vinden op mn mac??
    Ook gezocht op httpd.conf maar die kan de finder niet vinden:(


    Bijdrager
    Julian

    ben je in de terminal naar die map gegaan? Hij moet er zijn:

    cd /etc/httpd


    Bijdrager
    meneer de koekepeer

    In de terminal kom ik er direct.

    Ik waarschuw; ik ben geen terminal held ofzo, maar moet ik dit helemaal via de terminal doen!? Zo ja, kun je aub duidelijke aanwijzingen geven.

    In de map apache heb ik nu wel een httpd_conf.pm gevonden.
    Daar staat $ServerName, maar als ik dat wijzig doet dat het nog steeds niet vanaf mijn windows pc. (Ja, ik heb ge-herstart).

    Please advise:)


    Bijdrager
    Julian

    OK, komt ie:

    In de Terminal:

    ga naar de map /etc/httpd
    cd /etc/httpd

    open het bestandje httpd.conf in bv pico (simpele text editor)
    sudo pico httpd.conf

    Zoek de tekst ServerName op in het bestandje (ergens bij regel 350)

    uncomment de regel ServerName (haal # weg) en typ achter ServerName je ip adres (Dus je krijgt:
    ServerName http://10.0.0.9 )

    bestandje afsluiten (ctrl-x) saven en apache herstarten

    Ik hoop dat dit helpt…

    ps. ik hoop dat je de verandering in $ServerName weer hebt hersteld, volgens mij kun je dat beter niet aanpassen :)


    Bijdrager
    meneer de koekepeer

    Julian,

    Ik heb je aanwijzingen opgevolgd.
    Helaas doet ’t ’t nog steeds niet:(

    ServerName 10.0.0.9 doet ’t niet
    ServerName blaat doet ’t niet
    ServerName “blaat” doet ’t ook niet

    Uiteraard de server eerst netjes herstart met “sudo apachectl graceful”, zelfs nog een volledige herstart geprobeerd.

    Beetje frustrerend. In elk geval bedankt voor je hulp:)


    Bijdrager
    lampje

    vanaf je pc naar je mac? begrijp ik dat goed…

    vergeet je niet de ‘tilde’ te zetten?

    met: http://ipnummer/~username moet ’t gewoon lukken,
    de toevoeging :80 achter je ip is niet nodig, die poort
    gaat zowieso open voor http verkeer als je websharing aanzet.

    bv: http://10.0.0.1/~jantje

    gebruik je DHCP of heb je vaste adressen vanaf je router/switch?


    Bijdrager
    meneer de koekepeer

    DHCP.

    En wat jij zegt, lampje, was wat ik ook dacht.
    Zo werkte het eerst ook, maar van de een op de andere dag was dat over :?


    Bijdrager
    lampje

    heb je onder DHCP op je router wel 1 vast adres “geleased”
    (dwz. vastgezet) voor je server?
    anders heeft je server elke keer een ander adres…

    of heb je toevallig iTools op je computer gezet….
    die vrat bij mij alles op en de server deed ook niks meer,
    werd alles ingesteld zoals ik het juist niet wilde:evil:
    veel te veel toeters en bellen voor een simpel servertje……


    Bijdrager
    meneer de koekepeer

    Ik heb geen iTools, dat staat vast.
    Zal zo eens even kijken naar dat adresje, dank voor de tip:)


    Bijdrager
    meneer de koekepeer

    Ok, gotta love your mac:)

    Ik deed: http://10.0.0.4/~wilcooud
    Het moest zijn: http://10.0.0.4/~wilcooud/

    Let erg goed op de laatste “/”.

    Dank voor de hulp:)


    Bijdrager
    lampje

    oja……..k*t………daar ben ik ook wel eens ingetrapt dus:lol: :lol: :lol:


    Bijdrager
    meneer de koekepeer

    Thank god i’m not the only fool;)

    Beetje jammer dat de mac daar zo om zeurt.
    Hetzelfde met het openen van een folder.

    Je moet altijd “folder/index.html” doen.
    Als je gewoon “folder” of “folder/” doet krijg je directory index:(


    Bijdrager
    lampje

    ja is apache werkwijze…..

    alleen bij de standaard webfolders gaat ie automatisch naar
    de index.html……

21 berichten aan het bekijken - 1 tot 21 (van in totaal 21)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.