2 berichten aan het bekijken - 1 tot 2 (van in totaal 2)
  • Q:
    Bijdrager
    dejongonline

    Google Spreadsheet weeknummer genereren

    Wie kan mij helpen met de juiste formule in Google Spreadsheet?

    In Excel gebruik ik de volgende formule voor een weeknummer: =ALS(B#>0;ISO.WEEKNUMMER(B#);””)

    Google Spreadsheet kent geen ISO.WEEKNUMMER, maar alleen WEEKNUMMER. Het probleem is dan dat 15-02-2016 ineens in week 8 valt, en niet in week 7. Dit heeft ermee te maken dat 1 januari 2016 in week 53 valt. Hoe moet ik dit corrigeren?

    Sleutelbeheerder
    Night

    Google maakt standaard gebruik van de Amerikaanse weeknummering.
    Als het goed is kun je dit aanpassen in de TYPE optie:

    WEEKNUMMER(datum; [type])

    datum – De datum waarvoor het weeknummer wordt bepaald. Moet verwijzen naar een cel met een datum, een functie die als resultaat een datumtype geeft, of een getal.
    type – [ OPTIONEEL – standaardwaarde is 1 ] – Een getal dat overeenkomt met de dag waarop een week start en het systeem aangeeft waarmee de eerste week van het jaar wordt bepaald.

    OF

    How to get the week number from a date
    The native support for week numbers in Google Spreadsheets is dependent on the locale setting for the specific spreadsheet. In order to always get the ISO week number no matter what locale is used, you can use a third-party plugin:

    From the menu, choose Tools → Script gallery….
    Using the search field on top, search for WeekNumber.
    Click Install on the script published by [email protected].
    A dialog will prompt you to grant authorization. Press Continue and then Accept.
    Now, to get the ISO week number (1-53) of a date in cell A1, use =WeekNumber(A1).
    You need to repeat the above steps for every spreadsheet where you want to use week numbers.

    Read more about =WeekNumber() on the plugin’s help page.If you prefer to use only native functions, you must choose a locale that uses ISO week numbers. From the menu, choose File → Spreadsheet settings… and select e.g. United Kingdom. Note that setting the locale also affects other things, e.g. how dates and numbers are displayed, so you may prefer the plugin solution above.

    To get the ISO week number (1-53) for a date in cell A1, use =VALUE(RIGHT(TEXT(A1; “yyyy-ww”); 2)).

    How to get the number of weeks in a year
    To get the of ISO weeks in a year (i.e. the number of the last week), use =Weeknumber(DATE(A1; 12; 28)).

    Cell A1 contains the four-digit year (e.g. 2012).

2 berichten aan het bekijken - 1 tot 2 (van in totaal 2)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.