12 berichten aan het bekijken - 1 tot 12 (van in totaal 12)
  • Q:
    Bijdrager
    ocramarco

    geen autostartup apache

    Hey,
    Ik heb probleempje met mijn Apache server. Deze start namelijk niet automatisch op.
    Maar als ik met de hand in de terminal: [code:1:425ec2b2eb]$ sudo apachectl configtest [/code:1:425ec2b2eb] geeft hij de output OK. en als ik:[code:1:425ec2b2eb]$ sudo apachectl start[/code:1:425ec2b2eb] doe, doet apache het ook gewoon. Is op zich geen probleem want hierna doet hij het prima en het is vooral een test server voor mij.
    Ik heb een PM G5 2* 2.0Ghz, MacOSX 10.4.6, standaard apache geinstalleerd.
    Deze problemen geeft hij vanaf dat ik mijn Powermac heb aangeschaft.

    Bijdrager
    SeaTrue

    misschien heel dom antwoord maar moet je niet ergens instellen dat die automatisch opstart (bij systeemvoorkeuren-> users->….)

    Bijdrager
    ocramarco

    Ja daar heb ik aan gedacht, maar dat is het niet.
    Dit heb ik nooit gedaan bij me andere macjes.

    Bijdrager
    Richard5

    Kijk even met de terminal in de file /etc/hostconfig en check of daar de volgende regel staat:
    WEBSERVER=-YES-
    als die er niet staat dan even toevoegen of NO in YES veranderen.

    Ik ga er trouwens vanuit dat je de standaard bijgeleverde apache gebruikt en niet een van een andere installatie pakketje. Dan kan het namelijk anders zijn.

    Bijdrager
    ocramarco

    Deze regel staat er in en de optie staat op YES.
    Dus helaas dat is het probleem ook niet..

    edit: 1 na laatste regel vermeld ik dat ik inderdaad de standaard voor geinstalleerde apache gebruik

    Bijdrager
    Richard5

    Wat gebeurd er als je in de Terminal het volgende commando geeft:
    [code:1:b777f244f8]sudo /System/Library/StartupItems/Aoache/Apache start[/code:1:b777f244f8]
    Dat is het commando wat afgevuurt word als je de machine reboot.

    Bijdrager
    ocramarco

    vraagt password en dan gaat hij gewoon terug naar terminal regel.
    Maar de webserver doet het dan nog niet.
    Pas als ik: [code:1:2ac2a415e5]$ sudo apachectl start[/code:1:2ac2a415e5] doe, doet hij het pas goed.
    Hij geeft verder geen error logs of iets dergelijks.

    Bijdrager
    Richard5

    Oeps, had je typo wel gezien ?
    [code:1:8940bf16d5]sudo /System/Library/StartupItems/Apache/Apache start[/code:1:8940bf16d5]

    Op zich vreemd want dit startup item roept ook apachectl aan ?

    Bijdrager
    ocramarco

    Ja, lijkt net of hij inderdaad apachectl niet oproept bij het opstarten van de mac.
    Hij geeft wel een foutmelding (Het rare is dus dat hij deze niet wegschrijft in een log :?) als ik meteen [code:1:f8b90cdd51]sudo /System/Library/StartupItems/Aoache/Apache start[/code:1:f8b90cdd51]
    maar die weet ik even niet, iets met PID file en dan verwijst hij naar /usr/sbin/apachectl
    Zal de volgende keer even kijken als ik me mac opnieuw opstart.

    Bijdrager
    Richard5

    wat je kan checken is het PATH welk gedefinieerd staat per gebruiker. Doe eens ‘which apachectl’ en kijk welke er gebruikt wordt als gewone user en log daarna eens in als root en probeer het nog een keer.

    Bijdrager
    ocramarco

    Beide wordt er gebruik gemaakt van /usr/sbin/apachectl

    Bijdrager
    Richard5

    Vreemd, ik ben effe los, misschien dat iemand anders het weet///

12 berichten aan het bekijken - 1 tot 12 (van in totaal 12)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.