14 berichten aan het bekijken - 1 tot 14 (van in totaal 14)
  • Q:
    Bijdrager
    Bas_H_Design

    geektool vraag

    hoi,

    ik ben al een tijdje met geektool bezig maar zodra ik de commands voor bvb dag,maand etc invul komt het in het nederlands
    op mn scherm te staan. ‘donderdag’ of ‘maart’.

    Graag zou ik dit in het emgels willen hebben zoals bvb ‘saturday’ of ‘january’.

    Iemand een idee hoe ik dit doe?

    Gr bas thnx alvast

    Bijdrager
    chris24924

    Heb je je systeemtaal op Nederlands of Engels staan?

    Bijdrager
    Bas_H_Design

    op engels, dat is het rare…

    Bijdrager
    chris24924

    Vreemd…ook je Mac opnieuw opgestart?

    Bijdrager
    Bas_H_Design

    ook al meerdere keren gedaan.

    Zou het aan geektool of de code zelf kunnen liggen?

    Bijdrager
    SunKeeper

    Post dan eens de code die je momenteel gebruikt. Zo komen we ook geen minimeter verder.

    Bijdrager
    curryhano

    Ik heb ook zo’n probleem gezien bij de flash installer van Adobe. Deze kijkt volgens mij naar de regio die je in hebt gesteld en niet naar de systeemtaal.

    Bijdrager
    Bas_H_Design

    Gewoon de standaard commands gebruik ik.
    Nog geen ingewikkelde scrips ofzo…

    date +%B
    date +%d
    date “+%A, %B %d”
    date +%A
    date +”%l:%M”
    date +”%p”

    Deze commants.

    Bijdrager
    Franky Mac

    Normaal gesproken moeten die commando’s de systeemtaal aanhouden, dus Engels als je dat hebt ingesteld. Wat krijg je als je in een terminal sessie locale ingeeft?

    BTW, dit is niet het goede forumonderdeel voor dit soort vragen.

    Bijdrager
    Bas_H_Design
    Franky op 12 januari 2014

    Normaal gesproken moeten die commando’s de systeemtaal aanhouden, dus Engels als je dat hebt ingesteld. Wat krijg je als je in een terminal sessie locale ingeeft?

    hoe moet dit?

    Bijdrager
    SunKeeper

    Open de Terminal in Programma’s/Hulpprogramma’s. (of zoek in het zoekveld bovenaan je Launchpad)
    Typ in het geopende venster:

    locale

    en geef een Enter.
    Indien je Mac op Nederlands staat ingesteld krijg je zoiets als dit:

    Bijdrager
    Bas_H_Design

    gedaan en krijg inderdaad hetzelfde als hierboven.
    Echter als ik bij preferences/language & region kijk staat er bij preferred languages: english…?

    Wel staat er bij region: netherlands – dutch…?

    Bijdrager
    Franky Mac

    Vreemd, dat zou allemaal LANG=”en_US.UTF-8″ moeten zijn (tenzij je voor UK-Engels hebt gekozen, dan β€˜en_GB.UTF-8’).

    Het zou best eens kunnen dat region ook op US of UK moet staan.

    Inderdaad, na wijziging hier en uit- en inloggen krijg ik in de Terminal na het ingeven van locale:

    LANG=”en_US.UTF-8″
    LC_COLLATE=”en_US.UTF-8″
    LC_CTYPE=”en_US.UTF-8″
    LC_MESSAGES=”en_US.UTF-8″
    LC_MONETARY=”en_US.UTF-8″
    LC_NUMERIC=”en_US.UTF-8″
    LC_TIME=”en_US.UTF-8″
    LC_ALL=

    En na date “+%A, %B %d”
    Monday, January 13

    Bijdrager
    Bas_H_Design

    Dat was het dus, top! ga ik dat nog een veranderen.

    Thnx for de help!

14 berichten aan het bekijken - 1 tot 14 (van in totaal 14)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.