4 berichten aan het bekijken - 1 tot 4 (van in totaal 4)
  • Q:

    Bijdrager
    Pivni Pes

    Fileserver met Netatalk 3.0.7

    Ik heb op onze server even een virtuale server aangemaakt met Ubuntu 12.04, dit meer als sandbox om even flink in te stoeien.
    Onze huidige fileserver draait Ubuntu 10.04 met Netatalk 2.x (de standaard uit de box versie welke mee wordt geleverd)
    Onze netwerk bestaat alleen maar uit Apple machines en daarom hebben wij gekozen voor Netatalk.
    Dit werkt redelijk goed maar heeft ook zijn minpuntjes welke in versie 3.0.7 zijn verwijdert.
    Op onze nieuwe server wil ik Ubuntu 14.04 installeren welke binnenkort uit komt en hierop wil ik Netatalk 3.0.7 draaien.
    Aangezien Netatalk 3.x helemaal anders is dan versie 2.x loop ik een beetje vast.

    Ik heb het volgende gedaan met installeren:

     
    Standaard Netatalk verwijderen.
     - sudo apt-get remove netatalk
     
    Benodigdheden installeren.
     - sudo apt-get install build-essential pkg-config checkinstall git-core avahi-daemon libavahi-client-dev libcrack2-dev libwrap0-dev autotools-dev automake libtool libdb-dev libacl1-dev libdb5.1-dev db-util db5.1-util libgcrypt11 libgcrypt11-dev libpam0g-dev
     
    Netatalk 3.0.7 downloaden en installeren.
     - wget <a href="http://downloads.sourceforge.net/project/netatalk/netatalk/3.0.7/netatalk-3.0.7.tar.bz2" rel="nofollow">http://downloads.sourceforge.net/project/netatalk/netatalk/3.0.7/netatalk-3.0.7.tar.bz2</a>
     
    Uitpakken.
     - tar -cvf netatalk-3.0.7.tar.bz2
     
    Naar de map.
     - cd netatalk-3.0.7
     
    Configure install.
     - ./configure \
        --prefix=/usr/local \
        --enable-debian \
        --enable-zeroconf \
        --with-cracklib \
        --with-acls \
        --with-pam \
        --enable-tcp-wrappers \
        --with-pam-confdir=/etc/pam.d \
        --with-dbus-sysconf-dir=/etc/dbus-1/system.d \
        --sysconfdir=/etc/netatalk3 \
        --with-init-style=debian
     
    Build.
     - make
     - sudo make install 
     

    Vervolgens heb ik een heel simpel afpd config gemaakt om te testen:

     
    [testserver]
    path = /home/testserver
    valid users = testserver
     

    De gebruikersnaam is testserver en het wachtwoord is ook testserver
    De owner en group van de map /testserver zijn ook testserver, octal is 755
    Van de map /home zijn owner en group root en octal is ook 755

    Als ik nu met CMD+K verbind met de server en bij naam en wachtwoord testserver invult dan krijg ik de melding “er zijn geen gedeelde onderdelen beschikbaar of u hebt er geen toegang toe op de server”

    Opzicht is deze config zeer simpel en snap ik niet waarom het niet werkt, maar aangezien ik er al een behoorlijke tijd mee bezig bent kijk ik me er wellicht helemaal blind op.

    Misschien is er iemand wie mij kan vertellen welke stommiteit ik ben begaan:lol:


    Bijdrager
    Plainey

    (Ik probeer zoveel mogelijk mee te denken..:) )

    Al “afpd -V” gedraait om 100% zeker te weten dat de juiste versie wordt aangeroepen? Poort 548 openstaan?


    Bijdrager
    Pivni Pes

    Bedankt voor het mee denken, je hebt me perfect geholpen(y)
    Poort 548 had ik niet open staan in de router, maar dit gebruikte ik ook niet bij Netatalk 2.x
    Wij gebruiken de fileserver alleen intern of via een VP tunnel.

    Misschien stom, maar ik was vergeten “afpd -V” te gebruiken.
    Nu een poosje naar de uitkomst te kijken en nog het een en het ander uitproberen zag ik mijn fout.
    Ik was de hele tijd bezig in het verkeerde config bestand “/etc/netatalk/afpd.conf”
    Dit is het bestand van Netatalk 2.x, versie 3.x heeft een ander bestand: “nano /etc/netatalk3/afp.conf”
    Nu werkt het als een zonnetje(y)

    Nu kan ik verder gaan stoeien in mijn sandbox:lol:


    Bijdrager
    Plainey

    Mooi om te horen dat het opgelost is in ieder geval.:)

4 berichten aan het bekijken - 1 tot 4 (van in totaal 4)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.