8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)
  • Q:
    Bijdrager
    Divality

    E-mail server: Relaying denied. (state 14)

    Beste lezers,

    Vandaag heb ik een Mac Lion OSX 10.7.3 server ingericht, deze moet zich kunnen focusen op 2 services: VPN en E-mail. De VPN is inmiddels gelukt en werkt uitstekend, helaas heb ik met de e-mail nog een probleempje.

    Kort even de netwerkstructuur:

    Cisco Router -> Airport Extreme -> Server

    De Cisco router geeft een extern IP aan de Airport Extreme op de WAN poort. Vervolgens treedt de Airport Extreme als DHCP server.

    Airport Extreme 192.168.1.1
    Server 192.168.1.2

    Ik heb een webhosting pakket genaamd http://www.domeinnaam.com.
    In het controlepaneel heb ik Batch-SMTP ingesteld en het externe IP ingevuld van mijn internetverbinding.

    Vervolgens heb ik op mijn Mac OSX Lion server enkele e-mailadressen aangemaakt, voorbeeld is [email protected]. Ik hen een testclient ingericht bestaand uit een Macbook Pro met de applicatie Mail, hierin heb ik het emailadres [email protected] ingesteld via iMap.

    Hét probleem;

    Als een extern persoon wilt mailen naar [email protected] krijg ik de volgende error:
    Delivery Status Notification (error)
    Relaying denied. Proper authentication required. (state 14)

    Het e-mailadres waarmee ik een e-mail stuur is een willekeurig Gmail adres.

    Ik ben al zeker 10uur bezig met dit probleem. Het kan niet liggen aan de SMTP server van de versturende partij, dat is een correcte geteste SMTP server. (Gmail, webinterface)

    Via Google zie ik veel problemen met bovenstaande melding, alleen zijn ze niet soortgelijk met mijn probleem. Ik denk dat het ergens aan de MX records ligt of aan de partij die de mailrecords moet doorsturen? Ondertussen heb ik alle setting al meerdere keren veranderd en gecontroleerd maar ik kom er niet uit…

    Wie kan me op de goede weg helpen? Bedankt voor het lezen. :)

    Bijdrager
    MadDonna

    Je geeft eigenlijk zelf de fout al aan. Je smtp server draait op domeinnaam.com, die server verwacht een verzend adres met als eind @domeinnaam.com. Voor elk ander adres zal hij relaying denied geven.

    Ik heb zelf een smtp server draaien binnen mijn purplehorses domein. Die accepteert alleen maar purplehorses.nl email adressen als verzendadres.

    Bijdrager
    Divality

    Ah, dat is duidelijk, dus ik kan alleen maar binnen het domein versturen.

    Hoe kan ik dit oplossen?

    Bijdrager
    Artell

    Ik ben even aan het zoeken…

    Bij Microsoft Exchange servers moet je op de ontvangstconnector ook “anonymous” aanvinken om mail van buitenaf te kunnen ontvangen. Standaard staat die ook op alleen mail van authenticated users ontvangen. Wellicht dat de Lion Mailserver ook zo’n instelling heeft.

    en

    Je geeft aan dat je Batched SMTP gebruikt bij je provider. Dit betekend meestal dat je MX10 op je eigen extern IP-Adres staat en een MX20 als achtervang bij de betreffende provider. Als je eigen server dan niet actief is vangt de provider het voor je op. Je kunt dit mooi nakijken op mxtoolbox, deze site geeft je veel info over je mailserver en DNS instellingen

    of

    Weet je wel zeker dat poort 25 (SMTP) wel beschikbaar is op je internetverbinding thuis? Veel Nederlandse providers sluiten deze poort namelijk om SPAM te voorkomen. Voor zover ik weet heeft alleen XS4all hem open staan, en natuurlijk de vele zakelijke lijnen.

    Succes

    Bijdrager
    Artell

    Je geeft eigenlijk zelf de fout al aan. Je smtp server draait op domeinnaam.com, die server verwacht een verzend adres met als eind @domeinnaam.com. Voor elk ander adres zal hij relaying denied geven.

    Relaying is het versturen van mail via een server die niet de server voor dat domein is.. In dit geval is zal de server van @domeinnaam.com natuurlijk mail willen ontvangen die gericht is aan @domeinnaam.com. De server zal geen mail willen ontvangen die gericht is aan @nietmijndomeinnaam.com, zou hij dat wel doen dan is dat relayen, want hij zou deze mail weer willen doorsturen naar de mailserver van @nietmijndomeinnaam.com.

    Probeer eens of je vanaf een externe internetverbinding een telnet sessie kunt maken met domeinnaam.com 25. Lukt dat niet dan heb je je probleem.. (de HELO info van mxtoolbox is in principe ook genoeg..)

    Bijdrager
    Gfive

    Maar zoals al eerder aangeven, je dient wel een DNS opgezet te hebben en een Hostname: server.mijndomeinnaam.com.

    Vervolgens kan je, indien nodig, relay in stellen in je server.app, Onder mail “relay outgoing mail trough isp” klik op edit.

    Wellicht heb je hier wat aan: http://www.4elements.com/blog/comments/macmini_server_2011_part_II en part III en Part IV

    Bijdrager
    cerberusss

    Waarom niet gewoon de GMail servers gebruiken?

    Je maakt via de GMail settings een extra “account” aan, d.w.z. je stelt in dat je geauthoriseerd bent om een bepaald e-mail adres te lezen/gebruiken. GMail Settings -> Accounts -> Send Mail As.

    Bijdrager
    Divality

    Ik ga dadelijk jullie oplossingen proberen.:)

    Kleine notitie voor Gfive; Ik heb mail.domeinnaam.com gekoppeld, dit functioneert.

8 berichten aan het bekijken - 1 tot 8 (van in totaal 8)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.