11 berichten aan het bekijken - 1 tot 11 (van in totaal 11)
  • Q:
    Bijdrager
    dintel

    Dubbele aanhalingstekens/quotes [Solved]

    Op codeschool.com is een soort virtuele commandline waarin je elke keer je codes typt. Nu heb ik vaak de ” nodig. Echter komt er elke keer, nadat ik de ” typ de ” (bij shift ingedrukt) of de ‘ (zonder shift) erachter.

    Je kunt het zelf proberen op Try Ruby

    Kan ik dit uitschakelen? (Slimme aanhalingstekens staan uit)

    Bijdrager
    Jakko Westerbeke

    Als ik dat even probeer op de site waarnaar je linkt, gebeurt het bij mij niet. Als ik een aanhalingsteken typ, komt er maar eentje, totdat ik hem nog een keer aansla — een oplossing voor je probleem heb ik dan ook niet, maar ik vermoed niet dat het aan slimme aanhalingstekens ligt. Dat laatste gaat namelijk over de vorm van de aanhalingstekens, zodat je in kunt stellen dat je bijvoorbeeld Nederlandse „” aanhalingstekens wilt hebben, of Duitse „“ of Franse «». Dat heeft niks te maken met of er automatisch een tweede neergezet wordt.

    Bijdrager
    dintel

    Dank Jakko, ik had ook al het vermoeden dat het uiteindelijk niet lag aan de ‘slimme’ aanhalingstekens. Maar hoe kan ik het dan oplossen? Het gebeurt in ieder geval ook op andere macs.

    Bijdrager
    ikkezelluf

    En het wordt nog gekker….. ik heb het geprobeerd in Firefox omdat ik dacht dat het waarschijnlijk een browserprobleem was maar in Firefox kan ik in “Try Ruby” helemaal geen ” en/of ‘ intypen terwijl alle andere karakters wel lukken…. :slant:

    Overigens heb ik met “Try Ruby” in Safari hetzelfde probleem als Dintel…….

    Bijdrager
    ocramarco

    Ik heb geen enkel probleem met Firefox, Chrome en Safari. Helaas kan ik het niet reconstrueren. Wellicht met taal instelling te maken?

    Bijdrager
    dintel

    Welke taalinstellingen heb jij ocramarco? Mijn toetsenbord staat ingesteld als VS internationaal

    Bijdrager
    michiel112

    Is het niet een instelling die je ergens in je account aan of uit hebt gezet? Meeste code-editors hebben namelijk deze functie en meestal staat die functie ook aan. Je moet je quote toch altijd sluiten en dit zorgt ervoor dat je dat niet vergeet. Met haakjes doen de meeste editors het ook voor je.

    Bijdrager
    dintel

    Ik snap wat je bedoeld, maar dan zou je cursor er tussen moeten springen. Nu verschijnt het tweede aanhalingsteken pas als je een andere letter intikt.

    Bijdrager
    dintel

    Het probleem verdween toen ik mijn keyboard layout veranderde naar US – uitgebreid.

    De rest heb ik hier verder beschreven: http://help.codeschool.com/discussions/code-school/8866-double-quotes

    Bijdrager
    Jakko Westerbeke

    This discussion is private or deleted.

    Bijdrager
    dintel

    Double quotes
    Code School User
    January 07, 2013 @ 10:46 AM
    When I was trying ‘ruby’ and now ‘r’, every time I wanted to type something in the console the ” appeared double.

    When I need to type something in the console like: “Random text” is comes to: “”andom text”

    You can try to reproduce the problem on: http://tryr.codeschool.com/levels/1/challenges/1

    The problem is quite annoying, and I don’t think this (http://en.wikipedia.org/wiki/Quotation_mark_glyphs) covers all.

    SUPPORT STAFF2 Posted by Code School Support on January 08, 2013 @ 04:54 PM

    Hi there,

    This is pretty interesting. I have not been able to reproduce this, but I do know it’s happened, in very isolated cases, to customers using other courses.

    As Gregg, our founder, had mentioned over here, this issue usually relates to that wikipedia article you linked to. We usually see this issue when people are copying and pasting content from other resources which might use glyphs. Usually it’s not the keyboard itself that uses glyphs.

    You might have already read Gregg’s support entry, but I’d just like to go through the same questions he asked for debugging purposes:

    Just to verify, you’ve tried manually typing in the results? You’re definitely not copy and pasting?
    If Yes, is there anything unique or different about the character set /language you’re using?
    Thank you for your cooperation and patience as we try to debug this.

    -Robert

    3 Posted by Code School User on January 08, 2013 @ 05:50 PM

    Hi Robert,

    I’m just trying the course again, and everything seems to be normal. I changed the keyboard layout from US (International) – PC to US – Extended. When I switch back to US (International) – PC, it reproduces the bug.

    I’ve seen Gregg’s support entry, but I just typed everything manually.

    I hope this will be helpful for future support!

    Jan

11 berichten aan het bekijken - 1 tot 11 (van in totaal 11)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.