12 berichten aan het bekijken - 1 tot 12 (van in totaal 12)
  • Q:
    Bijdrager
    e.m.

    (WordPress) Domein toont blank page, home enkel met permalink! probleempje..

    Dag iedereen,

    Ik heb een wordpress geinstalleerd op een sever maar na enkele updates wil deze niet meer werken zoals behoren.

    Wat gebeurd er?
    Telkens ik nu naar de domein ga (bv: example.com) staat er enkel het woord ‘test’ bovenaan in de hoek.
    Nu als ik mijn url aanpas in mijn browser naar bv: example.com/nl/home_nl/ kom ik direct uit op de juiste pagina, mijn home page.

    Ik heb mij al rot gezocht naar waarom dit gebeurd, terwijl vroeger mijn pagina netjes automatisch naar mijn homepage ging. (example.com/nl/home_nl/)

    Iemand een idee hoe dit kan komen? en waar ik dit kan oplossen?

    Ik heb ook al gekeken bij de custom settings van mijn theme’s of de homepage wel op statisch staat en ik de juiste heb aangeduid.
    Het lijkt mij theme onafhankelijk gezien ik van theme verander het probleem zich blijft voordoen.

    Alvast bedankt!
    E.M.

    Bijdrager
    Shmoo

    Zit je toevallig bij TransIP met de webhosting?

    Bijdrager
    e.m.

    Hey, Neen bij Nucleus.

    Maar als je zo’n probleem kent bij TransIp kan het eventueel hetzelfde zijn?
    Ik heb sites bij beide providers, en nergens ooit zo iets tegen gekomen..

    misschien een probleem met mijn .htaccess file?

     
     
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
     
    # END WordPress
     
    Bijdrager
    Shmoo

    PHP 7.0 kan de oorzaak zijn, maar dat is wat lastig om uit te leggen hoe je dit terugzet naar 5.6

    Ik heb dit probleem bij TransIP met één bepaalde site, lokaal test ik alles met PHP 7 en is er niets aan de hand en zodra ik ook maar één bestandje overschrijf op de server gaat alles op wit en moet ik de PHP versie terugzetten naar 5.6 om het weer terug te krijgen.

    Het .htaccess bestand hierboven is prima.

    Bijdrager
    e.m.

    Hmmmmnnn moeilijk.

    Ik heb nog een site waar ik tegelijk aan werk met dezelfde hosting, ik gebruik dezelfde theme en zelfde versie van wordpress.
    Enkel is de server een andere shared linux hosting bij binnen mijn hosting. (edit: deze werk wel normaal)

    Ik heb geen idee welke php mijn site momenteel runt.. dit is wat mijn php admin mij verteld:
    Database: Software version: 5.5.48-MariaDB – MariaDB Server
    PHPadmin: Version information: 3.5.2.2, latest stable version: 4.6.2

    Bijdrager
    Shmoo

    Wat je kunt doen is inloggen met FTP op je server en dan even het wp-config.php bestand bewerken.

    Dit voeg je toe aan het begin.

    Op deze manier.

    
    
    * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    define( 'WP_MEMORY_LIMIT', '96M' );
    
    

    En daarna voeg je dit even toe aan hetzelfde bestand maar dan bijna aan het eind van het bestand.

    
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    
    
    

    Dit zorgt er voor dat je meer informatie krijgt over wat er met je site aan de hand is. Je moet dan wel even uitloggen van FTP > dan in de browser naar je site navigeren en als het dan nog steeds wit is log je weer in je FTP en ga je naar de folder wp-content daar moet nu een bestand aangemaakt zijn dat debug.log heet. Daarin moet dan omschreven staan wat er fout ging toen je de site wilde bezoeken.

    Bijdrager
    e.m.

    Hey eerst en vooral bedankt dat je mij wil helpen!

    Ik heb de volgende code voor mijn config:

     
    <?php
     
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     *
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    define( 'WP_MEMORY_LIMIT', '96M' );
     
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '**********');
     
    /** MySQL database username */
    define('DB_USER', '**********');
     
    /** MySQL database password */
    define('DB_PASSWORD', '**********');
     
    /** MySQL hostname */
    define('DB_HOST', '**********');
     
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8mb4');
     
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
     

    en dan onderaan:

     
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
     
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
     
    /* That's all, stop editing! Happy blogging. */
     
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
     
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
     
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
     
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
     
     

    De define codes heb ik er even van tussen gelaten zo ook de data base login uiteraard;)

    Nu ik krijg geen debug.log info te zien in mijn ftp => /public_html/wp-content

    Bijdrager
    Shmoo

    Je moet alleen niet die ‘informatie’ mee kopiëren maar enkel de define functies toevoegen. De ‘informatie’ plaats ik alleen om aan te tonen waar in het wp-config.php bestand je deze code het beste kunt neerzetten.

    Nu heb je twee dezelfde blokken, al lijkt het wel valid te zijn..

    Zie mijn voorbeeld.
    Alles dat groen is, heeft totaal geen doel en is alleen maar hulptekst om meer uitleg te geven.

    en

    Zorg dat je 100% zeker bent dat je naar een pagina surft waar WordPress actief moet zijn. Als je bijv. een static HTML site hebt en alleen WordPress gebruikt voor het ‘blog’ of ‘portfolio’ gedeelte dan moet je naar een pagina surfen waar je zeker van bent dat dit door WordPress genegeerd wordt.

    Ooo is het belangrijk dat je uitlogt van FTP en weer opnieuw inlogt na het bezoek van je site want FTP ververst zich niet automatisch.

    Als dat niet werkt dan log je weer in op FTP en dan verander je de naam van je thema naar iets met BACKUP of XXX er achter zodat WordPress de connectie verliest met je thema en terugvalt op een van de standaard thema’s.
    Let wel op dat je een van die standaard thema’s aanwezig moet hebben. Dus, twentysixteen, twentyfifiteen, foutteen enz enz. Een dan die thema’s moet naast de je eigen thema staan in geval van backup.

    Daarna doe je hetzelfde met elke plugin.. Dus verander de namen van alle plugins met iets als BACKUP of XXX er achter zodat WordPress ook connectie met deze verliest.

    Bijdrager
    Shmoo

    En als bovenstaande niet werkt om WordPress terug te krijgen dan moet je contact opnemen met het bedrijf dat de webhosting regelt, zodat zij het achter de schermen even kunnen nakijken.

    Ik ga nu namelijk voetbal kijken..

    Bijdrager
    e.m.

    Ik probeer wat zaken + wat jij hierboven voorsteld!
    Alvast heel erg bedankt!

    Voetbal? Engeland – Wales? Have Fun!
    En nogmaal merci!

    Bijdrager
    EagerB0bNerd

    Telkens ik nu naar de domein ga (bv: example.com) staat er enkel het woord ‘test’ bovenaan in de hoek.
    Nu als ik mijn url aanpas in mijn browser naar bv: example.com/nl/home_nl/ kom ik direct uit op de juiste pagina, mijn home page.

    Kijk eens in de broncode van die “test” pagina, wat zie je dan?
    Het zou kunnen dat er nog een index.html pagina op de server staat.
    Als je geen expliciete URL invult zoals example.com/nl/home_nl/ krijg je namelijk de index.html pagina te zien.

    Bijdrager
    EagerB0bNerd

    En doublecheck ook nog dat je siteadres goed staat ingesteld onder Instellingen>siteadres en je startpagina onder lezen>Startpagina toont

12 berichten aan het bekijken - 1 tot 12 (van in totaal 12)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.