4 berichten aan het bekijken - 1 tot 4 (van in totaal 4)
  • Q:
    Bijdrager
    Jack4ya

    “Die site doet ut niet”

    Ik heb af en toe iemand die roept:
    “Die site doet ut niet”

    Daar heb ik niets aan zonder dat ik wat over de betreffende machine weet, ik moet dus de configuratie weten. Als ik daarom vraag, dan snappen ze niet wat ik wil.

    Ik wil ze eigenlijk naar een url sturen en vragen of je me de inhoud van de pagina kunnen mailen/printen/faxen whatever.
    Daarin staat dan, os versie, browser, wat wel en wat niet enabled etc…

    Is daar een kant-en-klaar scriptje voor (php, javascript is prima) of is er al een uitgewerkte site ergens?

    Bijdrager
    Kyokushinkai

    Hmm, ik weet niet in hoeverre dat kan, maar met php kun je de $_SERVER variabele misschien gebruiken.

    [code:1:26b377ec3b]
    <?php
    echo $_SERVER[’HTTP_USER_AGENT’];
    ?>
    [/code:1:26b377ec3b]
    Bovenstaande code geeft bijvoorbeeld het resultaat:
    Mozilla/5.0 (Macintosh; U; PPC Mac OS X; nl-nl) AppleWebKit/417.9 (KHTML, like Gecko) Safari/417.9.2

    Bijdrager
    Jack4ya

    Ik kan natuurlijk ook even het probleem posten, misschien heeft iemand een BrainWave:

    Op meeste machines werkt alles naar behoren, nu is er alleen een andere afdeling bij de klant die iets anders ziet.
    Het lijkt er op dat de ssi niet willen; de css includes gaan wel goed.
    Geen menu, hoofd en footer… ofwel precies de includes…

    Een screenshot laat zien, dat ie wel via php content uit de database haalt (en dus wel een “gewoon” deel parsed), maar dat hij kennelijk niet de php van de include zelf parsed.

    Een willekeurige pagina, zeg maar (versimpeld):

    <inc. header>
    <inc. menu>
    <content uit database via php/mysql>
    <inc. footer>

    Daarvan houd ik over:

    <content uit database via php/mysql>

    Maar op meeste computers werkt alles naar behoren… :x

    Bijdrager
    hansman

    Ik heb ongeveer hetzelfde probleem gehad. Dat lag aan het inlogprofiel van de gebruiker(op XP)
    Na het profiel opnieuw te hebben aangemaakt ging het prima. Even proberen, inloggen onder een andere naam en wachtwoord.

4 berichten aan het bekijken - 1 tot 4 (van in totaal 4)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.