13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)
  • Q:

    Bijdrager
    Jack4ya

    Denk je nét alles goed te hebben, zelfs IE6, komt IE7 langs

    [size=9:e191accc48]Url van probleem pagina staat verderop in dit draadje, met uitbreidingen[/size:e191accc48]
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

    Zoals gezegd, denk je net alles pixelperfect te hebben komt IE7 weer voorbij zeilen.
    (Voor zover ik getest had) Het is een wat vrijere website, dus geen standaard (cms achtig) layout.
    De vraag of dit wel zo wenselijk is voor een website laten we in dit topic maar even liggen.

    In meeste voor de hand liggende browsers werkt het volgens mij naar behoren: De vlakjes zijn rollovers.

    Maar in IE7 gaat er iets fout. Het lijkt erop dat er bij meerdere vlakjes, de positionering aan gort gaat.

    Testjes leveren het volgende op:
    Bij 1 kolom staat het al te laag,
    bij 2 kolommen valt het er zowat uit,
    dus bij de beoogde 7 kolommen is het echt niet meer zichtbaar.

    Ik zie niet eens in welke richting ik moet kijken… kan ik IE7 niets als IE6 laten gedragen ofzo? sealed:

    Dat is meer een work around, dat weet ik, maar ik zie niet goed wat ik anders kan doen….


    Bijdrager
    iJoost

    Er zitten wel een paar CSS-fouten in:

    [code:1:96ad34616c]Warning: Error in parsing value for property ‘list-style-type’. Declaration dropped.
    Source File: http://www.insight-development.nl/css/hovers.css
    Line: 9[/code:1:96ad34616c]

    [code:1:96ad34616c]Warning: Expected ‘,’ or ‘{’ but found ‘html’. Ruleset ignored due to bad selector.
    Source File: http://www.insight-development.nl/css/hovers.css
    Line: 40[/code:1:96ad34616c]

    [code:1:96ad34616c]Warning: Expected ‘,’ or ‘{’ but found ‘html’. Ruleset ignored due to bad selector.
    Source File: http://www.insight-development.nl/css/menu-v2.css
    Line: 14[/code:1:96ad34616c]

    [code:1:96ad34616c]Warning: Error in parsing value for property ‘display’. Declaration dropped.
    Source File: http://www.insight-development.nl/css/menu-v2.css
    Line: 86[/code:1:96ad34616c]

    En mochten dat weer de CSS-hacks zijn, dan is dit keer het antwoord. Dan weet je nu precies waarom hacks niet zo’n goed idee zijn.;-)


    Bijdrager
    Jack4ya

    Nou meer slordigheidsfoutjes in de code.
    Die heb ik gecorrigeerd en ook even de xml gevalideerd.
    De code zou nu in orde moeten zijn.

    Het lijkt me zéér onwaarschijnlijk dat het nu opgelost is.

    Ik heb hier alleen geen IE7 dus ik zal morgen kijken.


    Bijdrager
    iJoost

    De twee error in hoovers.css zitten er nog steeds in.


    Bijdrager
    Jack4ya
    ”iJoost”

    De twee error in hoovers.css zitten er nog steeds in.

    Joh? Dan gebruik ik zeker de verkeerde validator??
    Ik gebruik http://jigsaw.w3.org/css-validator/

    He? Als ik in de code kijk online, dan zie ik de fout nog, maar als ik in DirectAdmin het document open dan staat het goed. Zal wel een DirectAdmin probleem zijn dan…. Ow wacht… cache… DUH!


    Bijdrager
    JJmac

    Is niet helemaal de juiste topic maar dit las ik op NU

    Dit keer richt de kritiek zich met name op XAML, dat volgens de klagers is ontworpen om HTML te vervangen, de taal waarmee webpagina’s worden gecreëerd. XAML is echter “volledig afhankelijk van Windows”, aldus de ECIS, waardoor alternatieve software geen kans krijgt. Ook Open XML, een door Microsoft ontwikkelde standaard voor kantoorbestanden die in Windows Vista en Office 2007 wordt gebruikt, ligt onder vuur.


    Bijdrager
    Jack4ya

    [size=9:770b6c00a2]linkjes weer verwijderd, zie verderop[/size:770b6c00a2]
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

    Om even mee te kunnen kijken.

    (in de xml/html, css files zijn eender)
    versie2 is gelijk aan de eerste, met uitzondering van het feit dat er nu maar 1 kolom gevuld is.
    versie3 is gelijk aan de eerste, met uitzondering van het feit dat er nu maar 2 kolommen gevuld zijn.

    versie2: Wat opvalt is dat je dan wél roll-overs ziet, met uitzondering van het eerste blokje??
    versie3: Wat opvalt is dat je dan wél roll-overs ziet, met uitzondering van de eerste vier blokjes??

    Mijn vermoeden is positionering, maar volgens mij doe ik niets (al te) vreemds?


    Bijdrager
    Jack4ya

    GEVONDEN waar het zit… nu nog de oplossing :?

    In de hovers.css staat

    #hoverts a span {
    visibility: hidden;
    }

    In alle browser betekent dit zoiets als: verberg maar wel aanwezig.
    en in IE7 zoiets als, verberg en ook niet aanwezig.

    Het verschil komt vervolgens dan van de mouse hover ->
    bij mouse over verandert visibility: hidden; naar visibility: visible;

    Alleen als IE7 het verborgen spannetje he-le-maal niet ziet valt er ook niets te hoveren.


    Bijdrager
    iJoost

    Als dat zo is, dan haalt IE7 visibilty en display door elkaar. Bij een display: none hoort het element geen ruimte meer in te nemen in de layout. Bij visibility: hidden neemt ie nog wel ruimte in maar wordt niet meer getoond. De W3C is daar heel duidelijk over:

    http://www.w3.org/TR/REC-CSS2/visufx.html#visibility


    Bijdrager
    Jack4ya
    ”iJoost”

    Als dat zo is, dan haalt IE7 visibilty en display door elkaar. Bij een display: none hoort het element geen ruimte meer in te nemen in de layout. Bij visibility: hidden neemt ie nog wel ruimte in maar wordt niet meer getoond. De W3C is daar heel duidelijk over:

    http://www.w3.org/TR/REC-CSS2/visufx.html#visibility%5B/quote:9180990322%5D

    Dat zou kunnen, maar dat kan misschien aan mijn constructie liggen. Ligt me meer voor de hand dat IK iets fout doe, dan IE7 …. alhoewel :lol:

    Ik dacht het even te omzeilen met een transparent background maar ook dan is het beoogde “vlak” dan ‘onzichtbaar’ zonder de ruimte die het wel moet hebben.

    –edit–
    Ik dacht misschien doordat ik geen hoogte/breedte had meegegeven, maar dat het geen positief effect als ik het wel doe.

    Is dit nu een bug?


    Bijdrager
    mac748

    Heb je al geprobeerd de position specifiek aan te geven, dus bij relative elementen “position: relative;”
    daarnaast help het bij absoluut gepositioneerde elementen de left en top aan tegeven ook al wil je de default waarde gebruiken (= 0).
    Verder gaat IE7 iets anders om met de z-index en is het soms nodig van alle geneste elementen de z-index aan te geven om je uiteindelijke doel te bereiken.
    bijv. de span lijkt weg door visibility hidden, maar misschien staat de z-index niet goed voor IE en krijgt ie daardoor geen hover.


    Bijdrager
    Jack4ya

    NIET QUOTEN / PASTEN SVP
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
    http://www.insight-development.nl/matrix-v4.html
    http://www.insight-development.nl/matrix-v5.html
    inloggen met test & test
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
    – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
    Ik heb de z-indexes er weer uitgehaald, was nog een restant.
    Dus dat is nu niet meer van toepassing denk ik.

    Verder heeft bijna alles (zo niet alles, nog even checken) inderdaad een position meegekregen al dan niet absolute en dan met extra waarden (ook al is het default)

    –edit–

    ow wacht in matrixposties.css niet.
    Ik probeer nu jullie tips uit op op versie 4

    en ik heb het nu in order op: (toch?) in versie 5


    Bijdrager
    Jack4ya

    Nou goed…

    Ik heb het verder opgegeven, maar IE7 wil inderdaad wel eens een eigen plan trekken. (dat op geen van de andere brwosers lijkt)

13 berichten aan het bekijken - 1 tot 13 (van in totaal 13)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.