10 berichten aan het bekijken - 1 tot 10 (van in totaal 10)
  • Q:

    Bijdrager
    Lucide-B

    delete user sub-folders in El Capitan

    Mijn SSD is mijn opstartschijf en de documenten heb ik op een grote harddisk staan.
    In mijn user folder op de SSD maak ik symbolic links naar de folders op de grotere harddrive.
    Dit ging altijd prima..

    Alleen sinds El Capitan kan je in de user folder geen sub-folders meer verwijderen.
    Als ik bij voordeel de originele ‘Documents’ folder wil verwijderen nadat ik een symbolic link heb gemaakt krijg ik de volgende melding:

    “Documents” can’t be modified or deleted because it’s required by OS X.”

    Ik heb al geprobeerd de permissions aan te passen onder ‘Get Info’ maar zonder resultaat.
    Wat kan ik doen zodat ik toch de subfolders kan verwijderen?


    Bijdrager
    Jakko Westerbeke

    Gebruik je de externe harde schijf ook nog voor iets anders, of alleen maar om documenten op te bewaren? Want in dat laatste geval zou je hem (met waarschijnlijk wat pijn en moeite) kunnen mounten onder /Users/jouw gebruikersnaam/Documenten zodat hij naadloos op de plek van die map terechtkomt.


    Bijdrager
    Lucide-B

    Dank voor je reactie Jakko,

    ik gebruik die schijf ook voor andere dingen helaas en ik schuif vaak folders tussen mijn 4 harde schijven in de Mac Pro anders was het een mooie oplossing geweest.

    Ik heb zelfs geprobeerd om SIP uit te schakelen (System Integreer Protection) maar dan zelfs kan ik die folders niet deleten.


    Bijdrager
    feek

    Een ideetje… geen idee of het gaat lukken.

    Maak een nieuwe gebruiker aan met admin rechten. Log uit en log weer in onder de nieuwe gebruiker. En maak vervolgens in de nieuwe gebruiker de gewenste symlink aan in de user folder van de oorspronkelijk gebruiker.

    • Deze reactie is gewijzigd 2 jaren, 5 maanden geleden door  feek.

    Bijdrager
    Lucide-B

    Dat ideetje had ik lokaal en geprobeerd feek.. helaas zonder succes.
    Ik had zelfs opgestart van een andere harddrive als admin user.. mocht ik nog steeds die bloody folder niet weggooien.


    Bijdrager
    Lucide-B

    Dit heb ik ook geprobeerd om de ‘Documents’ folder te verwijderen in Terminal:

     
    sudo rm -rf/Users/[username]/Documents
     

    Ik kreeg dit als antwoord:

     
    rm: illegal option -- /
    usage: rm [-f | -i] [-dPRrvW] file ...
           unlink file
     
     

    Bijdrager
    Pivni Pes

    Misschien er een spatie tussen zetten;-)
    Klein rot typ foutje waar je soms telkens weer over valt.

    Dus zo: sudo rm -rf /Users/[username]/Documents


    Moderator
    Night

    Wel vreemd; deze folders staan nl. helemaal niet in de rootless.conf

    Deze methode zou toch echt, ook in El Capitan, moeten werken:

    Move special OS X user folders to external drive


    (zie m.n. het omlijnde stukje code)

    • Deze reactie is gewijzigd 2 jaren, 5 maanden geleden door  Night.
    • Deze reactie is gewijzigd 2 jaren, 5 maanden geleden door  Night.

    Bijdrager
    Lucide-B

    Dank Pivni Pes!!

    Gelukt nu:D


    Bijdrager
    Pivni Pes

    (y) geen dank

10 berichten aan het bekijken - 1 tot 10 (van in totaal 10)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.