19 berichten aan het bekijken - 1 tot 19 (van in totaal 19)
  • Q:

    Bijdrager
    CharlotteH

    Data merging Indesign en numbers

    Hoi,

    Ik ga visitekaartjes maken voor een bedrijf. Ik wil dit graag gaan doen met data merging. Ik heb de gegevens in Numbers staan, maar als ik het csv bestand importeer, dan komen de titels (eerste rij) bij data merging achter elkaar te staan ipv onder elkaar. En zo kan ik dus niet elke titel apart selecteren. Nu zie ik bij elke tutorial ook dat ze met Excel werken en begin ik me dus af te vragen of dit sowieso wel kan met Numbers. Weet iemand dat? Mocht ik echt Excel nodig hebben, is er een manier om alleen Excel te downloaden/kopen? Ik zie op de site van office dat je gelijk aan een abonnement vastzit..

    Help!

    Ik hoop dat iemand me hiermee kan helpen:)

    Groetjes,

    Charlotte


    Bijdrager
    Tee Loo

    Hoi Charlotte.

    De juiste opmaak van de CSV file is belangrijk voor numbers.

    Afhankelijk van je taalinstelling of regio instelling kan het zijn dat een punt(.) een comma(,) moet zijn of een dubbele punt (:) een puntkomma(;) of visa versa.

    Wat ik meestal doe is alle ‘separation values’ vervangen door iets anders. (find& replace)

    Probeer alle vier de opties eens uit.

    Meestal ligt het daaraan. Numbers kan dit gewoon prima doen! Excel is echt niet nodig.

     


    Bijdrager
    Tee Loo

    Ohja, en als je de CSV file importeert geeft numbers meestal ook aan of de eerste rij de titel is of niet.


    Bijdrager
    Blieper

    Ik doe de instellingen vooraf zoveel mogelijk in Numbers en dan kun je het gewoon exporteren naar de oudere excel format en die is perfect te gebruiken in InDesign. Let hierbij op dat je exporteert met Macinstoch Unicode 16, anders krijg je geen umlaut en accenten op je letters!!

    Soms kan het handig zijn om Tekenstijlen aan te maken en die te koppelen aan je velden die je gaat Importeren.


    Bijdrager
    Blieper

    <p class=”cite”>Tee Loo op 28 maart 2019 om 18:57</p>
    Ohja, en als je de CSV file importeert geeft numbers meestal ook aan of de eerste rij de titel is of niet.

    Inderdaad, let er op dat de eerste rij altijd wordt gezien als ‘Koptekst’ dus die zal worden geĂŻnterpreteerd als je veldnamen in je Datamerge, let er op dat dat geen data is die je ook verwerkt wilt zien.


    Bijdrager
    CharlotteH

    Hee, thanks voor het meedenken! Het is voor mij de eerste keer dat ik data merge ga gebruiken, dus het is nog erg nieuw voor mij :). Ik had in eerste instantie sowieso geen punten, komma’s etc. gebruikt. Dat heb ik nu getest en een komma achter de titels lijkt het beste te werken. Maar dan nog gaat het niet helemaal goed. Ik heb even een simpel doc en screenshots gemaakt van wat ik heb gedaan. Zouden jullie eens mee willen kijken?

    De eerste is het Numbers doc. Dus met komma’s achter de titels. De tweede is wanneer ik het CSV file in Indesign heb gehaald. De titels komen nu wel onder elkaar te staan (wat zonder komma’s niet het geval is). Maar je ziet eigenlijk al dat er iets fout gaat. Want voor alle titels (behalve Name) komt een ; te staan. En de laatste titel is alleen maar ;;;;. De derde screenshot is als ik het voorbeeld laat zien. Op de een of andere manier komt de data alleen maar in het eerste tekstvlak te staan.

    Ik hoop dat jullie me hiermee kunnen helpen! Alvast heel erg bedankt!


    Bijdrager
    bartb112

    Charlotte

    Zorg dat je comma’s in de rij titel weghaalt.
    Dan exporteer of opslaan als CSV unicode16 door tabs gescheiden.
    Dan gegevensbron selecteren dan zou het goed moeten zijn, op deze manier een kolom #QR noemt kan je zelfs datamerge met QR code doen:) .

     


    Bijdrager
    Blieper

    Komma weghalen inderdaad en de lege rijen en kolommen ook verwijderen in je tabel, dan kun je verder gewoon je velden in InDesign selecteren en een Alinea of Tekenstijl geven voor de opmaak:-)


    Bijdrager
    CharlotteH

    Ben ik weer:) Dank voor al het meedenken! Maar, ik durf het bijna niet te zeggen, het lukt me nog niet. Ik heb weer even wat screenshots toegevoegd om te laten zien wat ik doe:

    Ik heb alle lege rijen en kolommen weggehaald:

    Hierna exporteer ik het naar een CSV file. Ik heb inclusief tabelnamen aangevinkt (is dat hetzelfde als ‘door tabs gescheiden’?)  en de tekstcodering gezet op Unicode UTF-16

    Maar als ik het importeer in Indesign krijg ik dit. Hij pakt nu dus de tabelnaam als titel. Terwijl ik de eerste rij als titels wil. Maar ik kom er maar niet uit hoe ik dat voor elkaar krijg. Ik denk dat het probleem ligt bij ‘door tabs gescheiden’. Dat ik dat nog ergens moet opgeven, alleen ik heb geen idee waar.

     

    Als iemand me hier weer verder mee kan helpen, ontzettend veel dank! Privé berichtje mag ook hoor, als men er ondertussen gek van wordt;-)

    In ieder geval alweer heel erg bedankt!


    Bijdrager
    bartb112

    inclusief tabelnamen vinkje zetten !

     


    Bijdrager
    CharlotteH

    <p class=”cite”>bartb112 op 29 maart 2019 om 14:04</p>
    inclusief tabelnamen vinkje zetten !

     

    Ah ja screenshot niet op het juiste moment gemaakt zie ik nu ;-). Die heb ik aangevinkt. Maar dan krijg ik dus dit:

    Hij pakt op de een of andere manier de tabelnaam ipv de koptekst rij. Ik krijg de tabelnaam ook niet verwijderd. Als ik de tekst verwijder, maakt hij er automatisch ‘Tabel 1’ van. Ik kan hem verbergen, maar dat maakt ook niks uit.

    Het is waarschijnlijk een stom klein detail wat ik nu niet goed doe, maar geen idee wat..

     


    Bijdrager
    bartb112

    Oké, dit heb ik ook wel eens:) stap 2 OpenOffice downloaden die installeren dan daar csv bestand in maken.


    Bijdrager
    Blieper

    Gewoon de tabelkop verwijderen en dan is het verder goed


    Bijdrager
    Blieper

    Heb eerder ook met csv geprobeerd, maar ik zou toch voor komma gescheiden cellen gaan, kun je alles mee maken


    Bijdrager
    Piet-Frans

    Bij de Nederlandse en Belgische Numbers wordt bij het exporteren naar csv file geen komma maar punt-komma gebruikt.
    Denk nu dat Indesign een bestand met komma’s als separator geen ; (punt komma’s)
    (Heb zelf geen Indesign, dus kan dit niet checken)

    Bekijk eerst eens je csv bestand met de gewone Teksteditor.
    Dus rechterknop klikken, dan “open met” selecteren. Kies uit lijst programmas : Teksteditor.
    Het Csv bestand is tenslotte een simpel tekstbestand met de inhoud van al je rijen en kolommen,
    gescheiden door een komma of punt-komma !

    In jouw voorbeeld :

    Name;City;Number;
    Henk;Breda;4
    Hans;Tilburg;8

    Als dit het geval is moeten alle ; veranderd worden in , !
    Dan kan je de test eens doen in Indesign.

    Is natuurlijk niet handig bij uitgebreidere bestanden.
    Er is een truuk om Numbers bij het exporteren naar CSV wel een komma te laten gebruiken.

    Ga naar ‘Systeemvoorkeuren’ – ‘Taal en Regio’
    Bij ‘Voorkeurstalen’ naar Nederlands en dan rechtsonder ‘Geavanceerd’
    Onder ‘Algemeen’ zie je Scheidingstekens getallen : Decimalen staat , verander dit in . (punt)

    Druk op Ok en verlaat systeemvoorkeuren.
    Doe een export naar CSV en check via Teksteditor.
    Indien komma’s zou Indesign het nu (hopelijk) goed moeten doen.

    Een omslachtige truuk en ook na gebruik uw originele settings terugzetten.

    Was eigenlijk zelf ook verbaasd dat in Numbers zelf geen optie zat om seperator aan te passen in CSV export .

    Hope this helps !


    Bijdrager
    HaWollie

    1. De opzet van je tabel in Numbers is goed; alle lege rijen en kolommen verwijderen.

    2. Tabel exporteren als CSV, codering Unicode (UTF-16), maar “Inclusief tabelnamen” NIET aanvinken!

    3. Met de rechter muisknop het CSV bestand openen in Teksteditor. Je CSV bestand moet er dan zo uitzien:
    (Indien er als eerste regel toch “Tabel 1” staat, dan deze regel geheel verwijderen zodat er als eerste regel “Name;City;Number” staat.)

    4. Met “Zoek en vervang” (alt+cmd+f) alle puntkomma’s vervangen voor een komma:

    5. Je CSV moet er vervolgens zo uit zien:

    6. Het CSV bestand gewoon bewaren (cmd-s) en Teksteditor sluiten.

    In Indesign moet het CSV bestand nu op de juiste wijze zichtbaar zijn in het “Gegevenssamenvoeging” paneel.


    Bijdrager
    CharlotteH

    <p class=”cite”>Piet-Frans op 29 maart 2019 om 22:33</p>
    Bij de Nederlandse en Belgische Numbers wordt bij het exporteren naar csv file geen komma maar punt-komma gebruikt.
    Denk nu dat Indesign een bestand met komma’s als separator geen ; (punt komma’s)
    (Heb zelf geen Indesign, dus kan dit niet checken)

    Bekijk eerst eens je csv bestand met de gewone Teksteditor.
    Dus rechterknop klikken, dan “open met” selecteren. Kies uit lijst programmas : Teksteditor.
    Het Csv bestand is tenslotte een simpel tekstbestand met de inhoud van al je rijen en kolommen,
    gescheiden door een komma of punt-komma !

    In jouw voorbeeld :

    Name;City;Number;
    Henk;Breda;4
    Hans;Tilburg;8

    Als dit het geval is moeten alle ; veranderd worden in , !
    Dan kan je de test eens doen in Indesign.

    Is natuurlijk niet handig bij uitgebreidere bestanden.
    Er is een truuk om Numbers bij het exporteren naar CSV wel een komma te laten gebruiken.

    Ga naar ‘Systeemvoorkeuren’ – ‘Taal en Regio’
    Bij ‘Voorkeurstalen’ naar Nederlands en dan rechtsonder ‘Geavanceerd’
    Onder ‘Algemeen’ zie je Scheidingstekens getallen : Decimalen staat , verander dit in . (punt)

    Druk op Ok en verlaat systeemvoorkeuren.
    Doe een export naar CSV en check via Teksteditor.
    Indien komma’s zou Indesign het nu (hopelijk) goed moeten doen.

    Een omslachtige truuk en ook na gebruik uw originele settings terugzetten.

    Was eigenlijk zelf ook verbaasd dat in Numbers zelf geen optie zat om seperator aan te passen in CSV export .

    Hope this helps !

    Top, thanks! Yes, dit werkt:) En bedankt voor de tip!


    Bijdrager
    CharlotteH

    <p class=”cite”>HaWollie op 31 maart 2019 om 11:08</p>
    1. De opzet van je tabel in Numbers is goed; alle lege rijen en kolommen verwijderen.

    2. Tabel exporteren als CSV, codering Unicode (UTF-16), maar “Inclusief tabelnamen” NIET aanvinken!

    3. Met de rechter muisknop het CSV bestand openen in Teksteditor. Je CSV bestand moet er dan zo uitzien:
    (Indien er als eerste regel toch “Tabel 1” staat, dan deze regel geheel verwijderen zodat er als eerste regel “Name;City;Number” staat.)

    4. Met “Zoek en vervang” (alt+cmd+f) alle puntkomma’s vervangen voor een komma:

    5. Je CSV moet er vervolgens zo uit zien:

    6. Het CSV bestand gewoon bewaren (cmd-s) en Teksteditor sluiten.

    In Indesign moet het CSV bestand nu op de juiste wijze zichtbaar zijn in het “Gegevenssamenvoeging” paneel.

    Yes, het werkt zo! Dank voor de duidelijke stappen:)


    Bijdrager
    Blieper

    Dit is zo omslachtig, dit is allemaal gewoon aanwezig in Numbers.

    Zoals ik zei, lege velden en kolommen verwijderen en daarna exporteren als en bij Geavanceerde opties als xls exporteren en klaar!!

    Voor de rest staat dan alles in je bestand zoals het moet zijn voor importeren of mergen bij InDesign.

    Je hoeft dus echt niet naar Textediter

19 berichten aan het bekijken - 1 tot 19 (van in totaal 19)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.