14 berichten aan het bekijken - 1 tot 14 (van in totaal 14)
  • Q:
    Bijdrager
    digilb

    Critical Error bij installatie SL op iMac late 2011

    Enkele klanten van ons werken met Apple’s: sommigen met Lion, anderen nog met Snow Leopard. Om hen beter van dienst te zijn, willen wij hun situatie kunnen nabootsen. Hiervoor hebben we vorige week een iMac (instapmodel) gekocht met Lion voorgeinstalleerd. Nu wil ik er een dualboot machine van maken met Snow Leopard. Ik heb met het schijfhulpprogramma de harddisk in 2 gelijke partities verdeeld. Als ik vervolgens opstart met een retail Snow Leopard-DVD dan krijg ik meteen een critical error met de melding “not supported CPU”. Ik kan dan alleen nog maar hem hard uit- en aanzetten met de powerbutton.

    Als ik de Snow Leopard-installatie probeer te starten vanuit Lion, dan krijg ik de foutmelding: “U kunt deze versie van het programma Mac OS X-installatie niet gebruiken met deze versie van Mac OS X. U hebt Mac OS X-installatie 23.1.”

    Wat te doen?

    Bijdrager
    digilb
    Bijdrager
    Macosxachist

    Nope, en ik zou het niet doen: het is maar helemaal de vraag of SL zich normaal zal gedragen op die iMac.

    Bijdrager
    digilb

    Deze generatie iMac is geintroduceerd op 3 mei 2011. En Lion is geintroduceerd op 20 juli 2011.
    Kortom: deze iMac’s zijn oorspronkelijk uitgeleverd met Snow Leopard. Dat MOET er dus goed op draaien, zou ik zeggen.

    Wellicht dat de installer van Snow Leopard niet overweg kan met de restore-partitie van Lion, maar dat hij (eenmaal geinstalleerd) prima draait?

    Bijdrager
    SunKeeper

    Nee, oudere versies van Mac OS X werken alleen op de Macs die voor de release van Lion beschikbaar zijn gekomen.

    Waarom je niet kan opstarten van de DVD: die DVD bevat helemaal geen drivers/kexts voor de hardware die in die nieuwe Mac zit. Dus dan krijg je inderdaad een Kernel Panic, dat klopt helemaal.

    Daarnaast is het een algemeen begrip dat je begint met het oudste besturingssysteem, en daarna eventueel het nieuwere systeem installeert, als je er meerdere naast elkaar wilt.

    Dus het is voor dit soort doeleinden een stuk makkelijk om een wat oudere Mac te kopen, die kan het wel allemaal draaien.

    Samenvatting: probeer voortaan meer informatie te verzamelen voordat je begint.:smile:

    Bijdrager
    digilb

    Nee, oudere versies van Mac OS X werken alleen op de Macs die voor de release van Lion beschikbaar zijn gekomen.

    Maar dat is toch het geval in deze situatie? SL moet werken op een mid-2011 iMac, want het werd er mee uitgeleverd. Of bedoel je dat Apple iets aan de mid-2011 iMac’s heeft veranderd nadat in juli Lion is uitgebracht?

    Bijdrager
    SunKeeper

    Ja, Lion is juist die verandering. Lion zorgt ervoor dat je geen Snow Leopard meer kan installeren naast Lion. Apple wil nou eenmaal dat je de nieuwste versie draait.

    Ik heb mijn post hierboven nog geëdit.

    Het draait dus zeker, maar installeren kan alleen vanaf een recenter uitgebrachte DVD.

    Bijdrager
    digilb

    Maar verwacht je wel dat de oplossing van
    http://www.zdnet.com/blog/government/how-to-install-snow-leopard-on-a-brand-new-lion-based-mac/10652?pg=5&tag=content;siu-container
    gaat werken?

    Dus een oude iMac aansluiten, en dan via firewire (target-mode) Snow Leopard installeren op de lege partitie van de nieuwe iMac?

    Oftewel: gaat alleen de installatie fout, of ook de werking van Snow Leopard?

    Bijdrager
    Pasav

    JE zal een originele DVD moeten hebben van deze iMac voor deze werd uitgeleverd met Lion. De iMac werd nl met een “speciale” versie (build nummer) uitgeleverd. Kan zijn dat de volledige 10.6.8 wel draait maar dat kan je dan alleen via de disk target mode oplossen.

    Bijdrager
    Afroman
    SunKeeper op 12 oktober 2011

    Ja, Lion is juist die verandering. Lion zorgt ervoor dat je geen Snow Leopard meer kan installeren naast Lion. Apple wil nou eenmaal dat je de nieuwste versie draait.

    Ik heb mijn post hierboven nog geëdit.

    Het draait dus zeker, maar installeren kan alleen vanaf een recenter uitgebrachte DVD.

    Hoezo? Snow Leopard heeft precies de drivers die op een iMac 2011 werken.:/

    Bijdrager
    Pasav

    De iMac is waarschijnlijk uitgebracht met een Build Nummer van 10.6.7, dan zou een 10.6.8 DVD de installatie moeten kunnen doen.

    Bijdrager
    Hanton

    Heb net hetzelfde ondervonden bij mijn nieuwe MacBook Pro.
    Wil eigenlijk liever SL draaien maar dat gaat niet op deze machine,
    mijn poging tot installatie met de SL retail dvd geven een kernel panic.

    Niet veel tijd om erop te zoeken, ben dus gewoon aan de slag met Lion
    maar vind SL een veel fijner systeem om professioneel mee te werken.

    Bijdrager
    digilb

    @Hanton: is VirtualBox ( https://www.virtualbox.org/wiki/Downloads ) een oplossing voor zo-nu-en-dan? Gevirtualiseerd werken lijkt me niet het fijnst als vaste OS, maar als het even niet anders kan? En inderdaad, Apple dwingt je mee te gaan met de tijd (zit je dan, met een muis met ps/2 connector:grin: ).

    Bijdrager
    digilb

    Opgelost!:smile:
    Vanaf een oude (witte) iMac heb ik Snow Leopard geinstalleerd op een USB-harddisk. Vervolgens opgestart vanaf de USB-schijf en geupdate naar 10.6.8.

    Daarna de USB-schijf aan de nieuwe (Lion) iMac gehangen, opgestart onder Lion en de 10.6.8 partitie op de USB-schijf gekopieerd naar een (eerder aangemaakte) tweede partitie op de harde schijf van deze Lion iMac.

    Check & OK.

    (Waarschijnlijk had het ook wel gewerkt via de firewire-target-modus, maar ik heb hier geen firewire 400/800 kabel liggen.)

14 berichten aan het bekijken - 1 tot 14 (van in totaal 14)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.