30 berichten aan het bekijken - 1 tot 30 (van in totaal 36)
  • Q:

    Bijdrager
    abbenhui

    bestandsnaam als naam van de foto in FOTO

    Meer mensen zullen het al gemerkt hebben: alle foto’s die je importeert in FOTO hebben als naam “naamloos”.
    Dat vond ik erg lastig; alle foto’s hadden een bestandsnaam, maar die wordt dus niet overgenomen.

    Na speuren op diverse fora kwam ik bijgaand applescript tegen; het werkt geweldig.
    Ik wil het dus graag met jullie delen.

    Create an Automator action, that executes an Apple Script to change the titles to the filename, if the title is empty:

    The Apple Script:

    on run {input, parameters}
    tell application “Photos”
    activate
    set imageSel to (get selection)
    if imageSel is {} then
    error “Please select an image.”
    else
    repeat with im in imageSel
    set title to the name of im
    if not (exists (title)) then
    set the name of im to the filename of im
    end if
    end repeat
    end if
    end tell
    return input
    end run

    Launch Automator, create a new service, and drag a “Run Apple Script” action into the workflow.
    Copy and paste the text above into the “Run Apple Script” action to replace the default text in the action.
    Set “service receives” on “no input” and application is Foto.

    Save this workflow with a suitable name. It will be installed in the services.

    Now launch Photos and select a few test images.
    Open the “Photos Menu > Services”.
    The service should be shown in the menu – I saved my version as “filename2title”.
    Select the service to let it run. When you click the selected photos again, the titles should change.

    Succes.


    Bijdrager
    2010pulver

    Ik heb Uw tip geprobeerd uit te voeren in Automater.
    Maar zo simpel als U uitleg is, zo moeilijk is deze terug te vinden in Automater.
    Er worden zoveel opties aangeboden. Ik loop daarbij vast.

    Run Apple Script action into the workflow.
    Welke stappen moet je nemen om dit voor elkaar te krijgen.

    Als ik Automater opstart, krijg ik onderstaande scherm.
    Wat moet ik dan kiezen?

    Bij voorbaat vriendelijk bedankt.


    Bijdrager
    abbenhui

    Ik zal proberen de tekst naar Nederlands te vertalen; dat zal helpen.

    Start Automator, maak een nieuwe voorziening, en sleep “Voer Apple Script uit” naar de workflow.

    Kopieer en plak deze tekst:

    on run {input, parameters}
    tell application “Photos”
    activate
    set imageSel to (get selection)
    if imageSel is {} then
    error “Please select an image.”
    else
    repeat with im in imageSel
    set title to the name of im
    if not (exists (title)) then
    set the name of im to the filename of im
    end if
    end repeat
    end if
    end tell
    return input
    end run

    in de “Voer Apple Script uit” actie ter vervanging van de standaardtekst in de actie.

    Instellen “Voorziening ontvangt geselecteerde” op “geen input” en “alle programma’s” instellen op Foto.

    Het geheel opslaan met als naam “Filename2Title”. Het zal in “Voorzieningen” worden bewaard.
    Start FOTO en selecteer een paar testopnamen.
    Open in “foto’s Menu > Voorzieningen”.

    Klik daar op “Filename2Title”.

    Nu zijn je foto’s van een titel voorzien.

    Succes.


    Bijdrager
    2010pulver

    Ik ben een stapje verder gekomen.

    Echter bij:
    Instellen “Voorziening ontvangt geselecteerde” op “geen input” en “alle programma’s” instellen op Foto.
    blijf ik hangen.

    In onderstaande schermafbeelding zie ik geen van de door U genoemde items.


    Excuses voor de onwetendheid;!


    Bijdrager
    abbenhui

    Ik dan ook maar een schermbeeldje:

    Ik vermoed dat je in de linkerkolom Foto hebt gekozen. Dat moet je dus NIET doen.


    Bijdrager
    2010pulver

    Bij mij is het menu dus niet zichtbaar voor het kiezen:
    Voorziening ontvangt geselecteerde = tekst
    in alle programma’s = foto

    Hoe krijg ik dat zichtbaar?

    Bij staat “Programma ontvangt bestanden en mappen als invoer”


    Bijdrager
    abbenhui

    Ik weet het niet zeker, maar ik denk dat het komt omdat je in de linkerkolom al “Foto” hebt geselecteerd.
    Gooi even weg wat je gemaakt hebt (afsluiten, niet opslaan) en begin eens opnieuw volgens de stappen zoals beschreven en getekend.


    Bijdrager
    2010pulver

    Bij mij verschijnt niet de optie niet.

    Als ik onder Archief “Nieuw” kies, krijg ik het volgende:

    /uploads/community/3f566b2f31d8d3d543f07f2b033066638a394931_54008.jpg

    Welke optie moet ik hier dan kiezen? Misschien dat het daar in zit?


    Bijdrager
    2010pulver


    Bijdrager
    abbenhui

    Deze:


    Bijdrager
    2010pulver

    Dat is gelukt.

    Maar “Foto’s Menu” kan ik nergens terugvinden in Foto.;!


    Bijdrager
    abbenhui

    In het menu op de balk boven in je scherm: Foto – Voorzieningen – Filename2Title ……..


    Bijdrager
    2010pulver

    Ja sorry had inmiddels ook gevonden.
    Heb een testje uitgevoerd, maar nu komt de melding


    Bijdrager
    abbenhui

    afbeelding niet te zien.


    Bijdrager
    2010pulver


    Bijdrager
    abbenhui

    nog steeds alleen maar een blauw vlakje. Kom op, ik wil onderhand ook gaan slapen ….


    Bijdrager
    2010pulver


    Bijdrager
    abbenhui

    Als je alles goed gedaan hebt moet het er zo uitzien:

    Kijk dit nou even na; als het PRECIES hetzelfde is moet het gewoon werken.


    Bijdrager
    abbenhui

    Dus:

    eerst in Foto een paar foto’s selecteren

    Dan naar Menu-Voorzieningen-Filename2Title aanklikken.


    Bijdrager
    2010pulver

    Oke ga ik doen.

    In ieder geval hartstikke bedankt voor de ondersteuning.

    Weltrusten.


    Bijdrager
    Louk Lachnit

    Geachte Abbenhul,
    Dank u voor uw helder omschreven instructies.
    Ik heb deze zojuist precies uitgevoerd.
    Dat was geen enkel probleem.
    Echter, als ik op het allerlaatst 2 foto’s selecteer, en dan op “menu-voorzieningen-Filename2Title” klik, krijg ik een meldig als op bijgaande schermafbeelding. (Er heeft zich een fout voorgedaan bij het uitvoeren van de taak “voer Apple Script uit”)
    Het kan zijn dat er inmiddels (bijna 2 jaar later) iets is veranderd.
    Bent u daarvan op de hoogte en kunt u mij ook verder helpen, het hoeft niet zo lang te duren als met die andere bezoeker, die u uit uw slaap hield;-)
    Alvast mijn hartelijke dank
    /Users/louk/Desktop/Schermafbeelding 2016-12-23 om 15.22.25.png


    Bijdrager
    Louk Lachnit

    /uploads/community/984845db77f1bd4c74913275cb928b0ee1c77464_94580.jpg


    Bijdrager
    abbenhui

    Ik zie geen foto (hoe moeilijk kan dat toch zijn) maar ik zet hieronder de laatste versie van het script:
    Als jezorgt dat het er zo uitziet moet het werken, bij mij nu ook op Sierra.

    • Deze reactie is gewijzigd 1 jaar, 10 maanden geleden door  abbenhui.

    Bijdrager
    maassen

    Helaas ik kom hier niet uit,ik krijg geen afbeeldingen te zien en ook de laatste versie van het script is niet te openen.
    Ik heb het script aangemaakt, maar ik krijg het in Foto, menu, voorzieningen niet te zien. De bovenste regel blijft grijs,


    Bijdrager
    maassen

    De bovenste regel werkt nu, maar ik krijg een foutmelding


    Bijdrager
    Louk Lachnit

    De afbeeldingen toonden niet omdat er bij OMT een server uitlag. Zij mailden mij net hierover. Zie schermafbeelding die nu hopelijk wel werkt:


    Bijdrager
    maassen

    Ik heb je laatste script exact overgenomen,maar ik blijf de foutmelding nog steeds krijgen. Ik heb alleen de naam Photos gewijzigd in Foto’s zoals het in de map programma’s staat.


    Bijdrager
    abbenhui

    En dat had je waarschijnlijk niet moeten doen.


    Bijdrager
    Louk Lachnit

    Geachte heer Abbenhui, ik blijf de foutmelding ook krijgen, terwijl ik volgens mij het juist script en de juiste instellingen heb toegepast.


    Bijdrager
    Louk Lachnit

    Dit is mijn foutmelding:

30 berichten aan het bekijken - 1 tot 30 (van in totaal 36)

Je moet ingelogd zijn om een reactie op dit onderwerp te kunnen geven.